2.52 Thermal Transport Modelling and Tools

Adina Tutorial
Steady State Thermal Conduction Example
3/14/2001
As an engineer, what properties do you need in order to analyze steady-state structural or thermal problems:

**Structural: What is tip deflection?**

![Structural Diagram]

**Thermal: What are isotherms?**

![Thermal Diagram]
We will be using the zip drive, Removable disk (D:\), for disk space reasons.

To boot Adina: Double click on the icon ADINA-AUI 7.4.

**Adina Modules**

ADINA-IN - pre-processor

ADINA-T / ADINA / ADINA-F - solvers

ADINA- PLOT - post-processor

Pre-processor: Used to generate geometry, and finite element mesh, characterize
finite element solution and define materials and boundary
conditions

Solver: Hands off solution of mathematical FE model

Post-processor: Used to visualize results, verify proper model behavior, and make
engineering decisions

**Garbage-in-Garbage-out phenomenon!! Be careful with finite element solvers.**

We will look at two examples using the same geometric model:
Steady-state
Transient

The problem we will investigate will form the basis of part of your next problem set.
STEADY STATE EXAMPLE
Pre-Processing (ADINA-IN Module)

1. Change ADINA to ADINA-T in upper left hand corner of adina window. Make sure the setting is Steady-State in the box beside Adina-T.

2. Construct ‘guide points’ 1 through 4 and ‘reference point’ 5
   On toolbar, select: Geometry > Points
   ‘Point #’ is the point identification number
   X1 is the x coordinate, X2 is the y coordinate, X3 is the z coordinate
   (inexplicably, you are looking at the yz plane, not the xy plane as you might expect)

3. Enter label numbers and coordinates for the points as shown below:

   ![Diagram of points 1 through 5]

<table>
<thead>
<tr>
<th>Point #</th>
<th>X1 (m)</th>
<th>X2 (m)</th>
<th>X3 (m)</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>0</td>
<td>0.14</td>
<td>0</td>
</tr>
<tr>
<td>2</td>
<td>0</td>
<td>0.2</td>
<td>0</td>
</tr>
<tr>
<td>3</td>
<td>0</td>
<td>0</td>
<td>0.14</td>
</tr>
<tr>
<td>4</td>
<td>0</td>
<td>0</td>
<td>0.2</td>
</tr>
<tr>
<td>5</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
</tbody>
</table>

4. Click ‘Apply’ or ‘OK’ button to generate points
   (‘OK’ button generates points and closes the window - ‘Apply’ button simply generates points)

5. On toolbar, select: Geometry > Lines > Define
6. Generate inner curve:
Click ‘Add’ button, define line number 1 (I suggest you go sequentially)
- Click OK for the line number
- Go to ‘Type’ box - change to ‘arc’
- Go to ‘Defined By’ button - ensure it is set to ‘P1, P2, Center’
  - Allows user to define arc start point, end point and center, respectively
- Go to ‘P’ button even with the Start Point cell - click it
- Move mouse target to one of the inner curve endpoints - left click once
- Move mouse target to the other inner curve endpoint - left click once
- Move mouse target to center point (at 0,0 in yz plane) left click once
- Click Save button at the top of the line box to generate the inner curve

Note: if you have clicked on the ‘P’ button to select points, you will not be able to rearrange windows on your screen. To regain control of the cursor, hit the ‘Esc’ key. You will then have to click the ‘P’ button again, and start selecting points from scratch.

7. Repeat previous step for outer curve - click ‘Add’ button first!
   - IMPORTANT NOTE: Don’t forget to click the ‘Add’ button before defining a new line.
     - If you change the line endpoints in the dialogue box without generating a new line number, it will overwrite your previous line. This point is applicable for generation of all lines, surfaces and solids!

8. Generate end lines
   - click ‘Add’ button for new line
   - Go to ‘Type’ box - change to ‘straight’
   - Using the ‘P’ button, choose the endpoints for one of the two straight lines
   - Click Save button at the top of the line box to generate the first straight line

9. Repeat for second end line - click ‘Add’ button first!

10. On toolbar, select: Geometry > Surface > Define

11. Click ‘Add’ button - choose surface number, click ‘OK’ button when satisfied
    - Go to ‘Type’ box - select ‘vertex’
    - Using the ‘P’ button, use the mouse cursor to select the four surface endpoints in clockwise OR counterclockwise order
    - Click ‘OK’ button when done

You are now finished with generating geometry - now we proceed to meshing operations. At this point, it is probably a good idea to save the FE database (FE codes have a tendency to crash now and again...)

On toolbar, select: File > Save As > Removable Disk (D:) > filename.idb
(I called it ps_1_ss.idb, and will refer to this file later in this tutorial)

Model Definition and Meshing Operations

For FE models, you need to define:
- element type (structural/thermal, 1D/2D/3D, plane stress/isotropic, etc...)
- material properties
- applied loads/boundary conditions

Start with material properties

1. **On toolbar, select: Model > Material > Conduction > k isotropic, c constant**
   - click ‘Add’ button, click ‘OK’ to define material 1
   - enter conductivity and specific heat (Note that ADINA uses volumetric heat capacity in the field for ‘specific heat’. Enter the value of \(\rho c_p\) in the field for specific heat, with units similar to \(J/m^3\cdot{\degree}C\)). For this model, we will assume a volumetric specific heat of 3.4E6 \(J/m^3\cdot{\degree}K\), and a thermal conductivity of 401 \(W/m\cdot{\degree}K\) (representative values for copper)
   - click ‘OK’ to define material 1

Now define element type

2. **On toolbar, select: FE-Representation > Element Groups**
   - click ‘Add’ button, click ‘OK’ to define element type 1
   - go to ‘Type’ button, change to ‘2-D Conduction’
     - Note: we would use other elements as applicable (e.g. 1D conduction elements for 1D heat flow, 3D for 3D heat flow, etc...)
   - Change ‘Element Type’ to ‘Planar’
   - default material is material 1, which we previously defined
   - click ‘OK’ to define element type 1

Now, begin meshing discretization

3. **FE-Representation > Mesh Density > Line**
   - click on the ‘P’ button, then click on one of the structures ARCS.
   - go to ‘Method’, change to ‘Use Number of Divisions’
   - go to ‘Number of Subdivisions’ box, change to 20
   - click on ‘Save’ and repeat above procedure for the second ARC.
   - repeat the procedure for the straight curves (click ‘P’ button, click one of the straight lines, change to ‘Use Number of Divisions’, change number of subdivisions to 7, then click ‘Save’)

**NOTE:** ADINA seems to have some sort of bug, and will occasionally replace one of your mesh ‘seeds’ with an incorrect number of subdivisions. Visually verify that you have 20 subdivisions around the arcs and 7 subdivisions on the straight lines. If this happens, remesh the arc that ADINA changes on you.

Now generate the FE mesh.

4. **On toolbar, select: FE-Representation > Create Mesh > Surface**
   - The default settings are ok as they are (Element group 1, 8 nodes per element, etc...)

Page 6
For more complicated operations, you will have to change things on this menu.

In the green area at the bottom right of the screen enter '1' on the first line of the Surface # box. Click 'OK'. - you should have something that looks like this:

Note: segmented lines occur due to geometry resolution.
There is no effect on the solution...

Before continuing, it is important to discuss units. FE codes are not 'smart'. If you enter temperature in °C, you MUST be consistent with the rest of your material properties (e.g. thermal conductivity in W/m²°C, specific heat in J/m³°C, etc...). Likewise with °F. This is analogous to structural analyses, in which units are only important in that they are consistent. If you use inches to define your geometry, you must use psi, instead of MPa in defining the elastic modulus...

Now, apply thermal loading conditions.

5. On toolbar, select: Model > Loading > Temperature
   - Apply prescribed temperature boundary conditions (BC) on flat sides
   - Assume 500°C at vertical flat, 100°C at horizontal flat
   - Click 'Add' button, then 'OK' button to specify temp BC 1
   - In the Magnitude box, change from 0 to 500, click 'Apply' button (brings up subsequent 'load application' dialogue box)
   - In the first row of the matrix enter '1' for the 'Label #'.
   - Click on the 'Load Type' box and chose 'Temperature'.
   - In the 'Load # box, enter 1 (the 500°C boundary condition)
   - Under the 'Site Type' section, click on the box and pick 'Line'
In the ‘Site #’ box, enter the line number corresponding to the straight vertical line. For most of you this will be either numbers 3 or 4. If you are unsure just pick one - it can easily be edited later.

- Left click once on the ‘OK’ button to apply the 500°C boundary condition
- Repeat this procedure for the 100°C BC.
- Click ‘Add’ button, then click ‘OK’ to specify temp BC 2
- In the Magnitude box, change temperature from 0 to 100, click ‘Apply’ button
- Again, in the ‘Label #’ box, enter 2
- Chose ‘Temperature’ from the ‘Load Type’ box.
- In the ‘Load #’ box, enter 2 (the 100°C boundary condition)
- Again, change ‘Site Type’ to ‘Line’
- In the ‘Site #’, box, enter the line number corresponding to the straight horizontal line.
- Click ‘Apply’ to apply the 100°C boundary condition to the FE model - then ‘OK’
- Click ‘OK’ in the Temperature Loading window

In order to view the loads and make sure they are at the correct locations:

- Go to Display > Load Plot > Use Default

You should see the 500°C boundary condition applied to the vertical straight line and the 100°C boundary condition applied to the horizontal line. If you do not then return to the temperature loading window, as outlined above, and reverse the 2 numbers in the ‘Site #’ box.

Now, we need the adiabatic boundary conditions on the arcs (use 0 heat flux BC)

6. On toolbar, select: Model > Loading > Heat Flux
   - Click ‘Add’ button, then ‘OK’ button to define heat flux BC 1
   - Since we are adiabatic on the arcs, leave heat flux value at 0, click the ‘Apply’ button
   - In the ‘Label #’ box enter 3
   - In the ‘Load Type’ box select ‘Heat Flux’
   - In the ‘Load #’ box enter 1 (0 heat flux BC)
   - Select ‘Line’ in the ‘Site Type’ box
   - Enter the line number (either 1 or 2) for one of the ARCS in the ‘Site #’ box.
   - Click the ‘Apply’ button to apply the adiabatic BC
   - Repeat for the second adiabatic arc (enter 4 for ‘label #’ make sure type of load is ‘heat flux’, and ‘load #’ REMAINS 1 - the 0 heat flux BC, ‘Site Type’ is Line and ‘Site #’ is either 1 or 2)
   - Click ‘Apply’ then ‘OK’ and then ‘OK’ again.
These previous steps may have been somewhat confusing. We have, in effect, defined what value the boundary conditions have, and then told Adina where these boundary conditions are applicable. To summarize, steps 5-6 have defined the following:

**Table 1: Boundary Conditions**

<table>
<thead>
<tr>
<th>Temperature/Heat Flux Load Number</th>
<th>Type</th>
<th>Load Application (BC) Number</th>
<th>Physical Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Temperature</td>
<td>1</td>
<td>500°C vertical plane</td>
</tr>
<tr>
<td>2</td>
<td>Temperature</td>
<td>2</td>
<td>100°C horizontal plane</td>
</tr>
<tr>
<td>1</td>
<td>Heat Flux</td>
<td>3</td>
<td>Adiabatic inner arc</td>
</tr>
<tr>
<td>1</td>
<td>Heat Flux</td>
<td>4</td>
<td>Adiabatic outer arc</td>
</tr>
</tbody>
</table>

Make sure you are comfortable with the manner in which these boundary conditions are applied, and understand how to do them on your own. Ask us if you have any questions on this point. It is one of the trickier steps in the process.

Once these BC’s are applied, you are ready to run the FE solver, ADINA-T. Save the database first.

7. **On toolbar, select: File > Save**

Prior to running solver, need to create a datafile

1. **On toolbar, select: File > ADINA-T (save it as ‘ps_1_ss.dat’)***

2. **In the bottom left corner click OFF the checkmark in the Run ADINA-T box**

3. **Make sure you are saving to the zip disk (Removable Disk D:). Enter the filename (ps_1_ss). Adina automatically gives it the extension.dat. Click ‘Save’**.
SOLVER - ADINA-T

1. On toolbar, select: File > Launch ADINA-T
2. Click ‘Start’ then the filename (ps_1_ss.dat)
3. Wait for solver to run - look for any error messages, or the successful run message

If no problems, proceed to ADINA-PLT, for post-processing...

Note: The actual solution of the FE model is hands off, and is the easiest portion of the analysis process for the user.
Post-Processing

1. Open ADINA PLOT

2. On toolbar, select: File > Open

3. Change filter to search for *.por (porthole files) instead of the default *.idb. A Porthole file is the file generated by ADINA, ADINA-T or ADINA-F. It contains the calculated system response. It is read into ADINA for post-processing.

4. Open ps_1_ss.por

5. Click on Mesh Plot icon on the first Toolbar

6. Click on the Band Plot icon on the second Toolbar

7. Look at allowable results - click okay for temperature distribution

8. Edit > Undo (to remove isotherms)

9. Click on the Vector Plot icon (beside Band Plot icon). Select Heat Flux and OK. This shows the lines of constant heat flux
10. Clear the screen using the Clear icon (beside the Mesh Plot icon). Redraw the mesh using the Mesh Plot icon.

11. Next, we want to draw \( q \) vs. \( r \) over the vertical side of the structure.

12. On the bottom toolbar click Show Node Labels.

13. Zoom in on the vertical line using the zoom icon from the general toolbar. You will have to draw a rectangle around the area you wish to zoom.

14. Definitions > Model Line > Node. This allows you to define a line by passing through a number of nodes you select.

15. Chose Add. Call the new line ‘ONE’.

16. In the green column ‘Node #’ enter the node numbers of the straight line, starting from the bottom and ending at the top. OK

17. Unzoom - Clear screen

18. Graph > Response Curve (Modal Line)

19. In the ‘X:’ box, change “variable” to “coordinate” and change “distance” to “z-coordinate”.

20. In the ‘Y:’ box, change “variable” to “flux” and the change “smoothing technique” to “averaged”. OK. The graph of Heat_Flux_Y vs. z-coordinate with the legend “Line ONE” appears.

21. To print as a postscript, go to File > Snapshot, change the setting from Adobe Illustrator (*.ai) to PostScript (*.ps) and name the file “ps_1line”. This can be printed out from any Athena printer using the command lpr -Pprintername filename.ps at the Athena prompt. Alternatively the file can be printed directly on the ME printers (Lexmark Optra and cyphus) simply by going to File > print.

22. Next we would like to be able to export any data we need, to a file for numerical manipulation. Here we will export the heat flux \( q \) data on line ONE to a file that we can use later, for example to numerically integrate \( Q \), where \( Q \) is defined as:

\[
Q = \int_{r_1}^{r_2} qdr
\]

23. Graph > List
24. Click on ‘Export’. Call the file ps_1.txt

25. You can now use a spreadsheet or other software to view the data in this file and integrate numerically to obtain Q.

26. Next we would like Adina to plot T vs. Arc length along any arc. For this we first need to define a new “line” which in this case is actually an arc. Suppose we would like to do this along the shorter arc that defines our boundary (the lower arc).

27. Erase the graph presently on the screen (Clear), the reconstruct the geometry and nodes as before (mesh plot, show node labels). Zoom in on the arc.

28. Definition > Model line > Node

29. Click on the Add box. Name this line “arc”.

30. In the green column ‘Node #’ enter the node numbers along the arc, starting from the top and ending at the bottom. OK Note: its not necessary to enter every single node number. Every third node or so will suffice.

31. Clear (general toolbox)

32. Graph > Response Curve (modal line)

33. Make sure ‘model line name’ is “ARC”, “X:” variable is set to ‘coordinate’ and ‘distance’ and the “Y:” coordinate variable are set to ‘temperature’ Click ‘OK’ What is plotted now is T as a function of distance along the arc length you specified.

34. Done! (Note: Before you exit, you can save the result file as a *.pdb. This would save all the model points and line definitions that you just selected. However this file does take up significant disk space so its not recommended that you do so at this time)