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TRANSIENT EXAMPLE

Note that we will be using the geometry and mesh exactly as they exist in the steady state model.
What parameters do we need to adjust for accurate modeling of thermal transients?

- (HINT: they determine effective thermal ‘time constant’ of structure)

- ~ (HINT: how do you load the structure?)

Copy existing database (<filename>.idb) to another file, T called mine ps_1_trans.idb.
To perform this function, go to Removable Disk (D:) in the local icon:

Click on the file (ps_1_ss), Edit > Copy, Edit > Paste -

Click on the copied file, File > Rename: <newfilename>.idb

We will use <newfilename> idb for the transient example. For the rest of this tutorial, 1 will
assume you have named your new file ‘ps_1_trans.idb’, If you name it something else, just
substitute the filename you use in place of ‘ps_1_trans’ throughout this section of the tutorial.
Open the new filename in ADINA-IN (the preprocessor).

1. Open ADINA-IN by clicking this option in the ADINA system window

2. In the ADINA-IN toolbar, select: File > Open > open the new transient file
(PS_1_trans.idb)

3. Under the ADINA-In toolbar, change the Analysis Type button from ‘Steady-State’ to
“Transient’

4. Adjust material properties as needed
- For this model, we will assume the same materiai properties as the first tutorial. The

material is copper with a volumetric specific heat of 3.4E6 J/m3°K, and a thermal
conductivity of 401 W/m°K.
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Now, we define the driving time function. For this example, let’s assume the horizontal plane at
(0° is constant at 100°C vertical plane at 90° is driven to 500°C using the following function:

500 L — — — -

400

5)
L300 4 e - — — — —
g |
2
E I
£ 200 e
| 1
= L S
I I
100 | | I |
! | | ] , L
[ I | | | ™t
1.0 2.0 3.0 4.0 6.0 .0

Time (minutes)

We need to define the driving function. There are two ways to do this. Recall in your previous
model, you defined a temperature of 500°C on the vertical plane at 90°. We can:

- (A) Redefine this temperature as 1°C and use desired temperatures as the scaling factors

OR

- (B) Use the 500°C temperature, and calculate required scaling factors to give desired
temperatures - we will use this method.

5. From the toolbox: Control > Time Function
- In dialogue box, enter the Time and Value pairs, using the above function (note the

two options A and B (use option B) as defined previously)

Time (sec) Value (A) Value (B) Note: we define the time
o 0 in seconds, since our
0 material properties are
60 200 0.4 defined in units which use
seconds.
120 200 0.4
Must be consistent here.
180 300 0.6 This is one of the easiest
(and most dangerous)
240 200 04 mistakes a user can make.
300 500 1
3000 500 1
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The time 3000 seconds is just used as a point to signify constant temperature after t = 5 minuies. .

6. Click ‘Save’ button to define time function 1.

Note that if we leave the 100°C boundary condition alone, Adina will assume that the time
function applied above also applies to this BC. We therefore need to specify another driving

function - this one a scaling constant equal to 1.0 (which will multiply the 100°C BC).

7. From the toolbox: Control > Time Function
- Click ‘Add’ to define time function 2.
- In dialogue box, enter the Time and Value pairs:

Time Value
0 1
3000 1

- Click ‘Save’ button to define time function 2.

8. Assign time functions to appropriate boundary conditions

(time function 1 scales the S00°C temperature BC, while time function 2 scales the 100°C
ternperature BC)
~ Under toolbar: Model > Loading > Temperature

- In dialogue box make sure Temperature number 1 (the 500°C BC) is selected.

- Click the ‘Apply’ button

- In dialogue box, click the ‘time function’ field corresponding to temperature
number 1. You should have a choice between the numbers 1 and 2. Click on “1°.

- In the ‘time function’ field corresponding to temperature number 2 change that to
2,

- In the ‘time function’ field corresponding to both heat fluxes change to time
funetion number 2’.

a - Click the ‘OK’ button to modify the new boundary conditions.

Solution Time Step Definition

Now, we need to think about what are called solution time steps. Look at the driving function.
What happens if we select a time step of 2 minutes for solution (i.e. FE solution is calculated
every two minutes through the transient)? Will we have an accurate solution?

So, do we pick a time step of 0.001 minutes for solution to get high resolution? What are the
associated difficulties?
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Problems involving stability and solution convergence arise when a time step is chosen that is too
large. In this situation a solution is not converged upon and the solver stops prematurely. The
maximum timestep is coupled to the element size and the thermal diffusivity. If you dont give the
program enough time to diffuse the heat through an element before going on to the next time step
then this error arises. Adina gives some guidelines for determining this maximum time step. For
Euler forward explicit time integration scheme, as is usually the case, the maximum allowed
timestep is given by:

2
Ar< (ax)
4o
Where o, is the thermal diffusivity of the material and Ax, is the element size, which can be
taken as the minimum distance between any two adjacent corner nodes of an element. For any
other integration scheme the timestep given above can also be used although it is a more
conservative estimate.

The above equation determines the max allowable timestep. Determining how small the optimal
time step increments need be depends on the accuracy level required. This is something that only
comes with experience. Generally, if you obtain a solution, you should rerun the model with a
smaller time step, and see if the response has changed. If two successive runs with different time
steps have similar responses, you can generally assume that you have a fairly accurate solution.
There are complications that we don’t have time to go into here. I am happy to discuss them with
any or all of you outside of class.

Fortunately, you can use the Fourier number as an estimate for reasonable solution time steps.
Recall:

_w
=1

For our example, assuming a steady-state Fourier number of 3/2, using the material properties and
an estimate of the arc length of our component, we get a time of:
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prior to our component reaching steady-state, following a step change in applied temperature at its
vertical boundary. This corresponds to roughly 15 minutes. Assuming that our component is
semi-infinite, how long will it take for the temperature step disturbance to reach the horizonial
surface?
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= 45.38 seconds
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Since the disturbance moves from the vertical boundary to the horizontal boundary in
~ 45 seconds, as a {irst order approximation, we should have time steps slightly smaller than this.

9. In toolbar: Control > Time Step
- In dialogue box, we need to define the number of steps and elapsed time for each step.
- For instance, if we wanted 30 solutions equally spaced along the transient up to time
t = 300 seconds, we would enter 30 for the number of steps, and 10 as the timestep
magnitude. :

Let’s take a moment to look at-our transient. How should we define our time steps?

When are thermal stresses generally a problem? Think about constraints, and temperature
gradients. Should we be more concerned with gradual gradients or severe gradients? You must
use engineering judgement in defining tirne steps for FE solutions.

Thermal FE solutions are obtained for one or two reasons - calculating hot-spots in a structure, or
determining a temperature profile to map onto a structure for stress calculations. Depending upon
displacement constraints, the maximum thermal stresses and/or hot spots can occur at steady-
state, or somewhere along a transient. Unfortunately, hand calculations sometimes can’t get you
very far when you have complicated geometry with non-linear thermal driving functions.

Back to our example. Let’s start with something reasonable. Let’s use 30 steps with step
magnitude of 10 seconds. This will get us to t = 5 minutes of the transient.

10. Click ‘Add’ in dialogue box to define your timesteps.
- you will need a name, not a number, to identify the time step profile (I called mine
‘driver’, and will refer to this name later)
- enter a name for the profile (use driver to stay consistent with my nomenclature),
then click ‘OK’
- enter ‘30’ under number of steps (in row 1) and enter 10 under timestep magnitude
(also in row 1).

Note that you can have a complicated profile of time steps, with a small number of widely spaced
steps in regions where the thermal driving function is changing gradually, and with a large nuraber
of tightly spaced steps in regions where the driving function is changing rapidiy.

We have currently requested ADINA to give solutions at t = 300 seconds - the time at which the
boundary temperature reaches its steady-state value, However, it is intuitive that the model will
not yet be at steady-state at this time. We need to step out toward steady-state conditions with our
time steps. Using our calculations of the Fourier number, we know that 15 minutes is an estimate
for the time to reach steady-state conditions, following a step change in temperature at the
boundary. Let’s ask ADINA to solve for timesteps once 2 minute from t = 300 seconds to

= 1200 seconds.

11. In the second row (under the time step information you’ve already input), enter ‘15’ for
the number of steps, and enter ‘60” for the timestep magnitude.
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- Click ‘Save’ button to save the time step information.

‘We now need to set the initial temperature of the body to 30° C. If we do not do this Adina
assumes the intital temperature to be 0°C.

12. Model > Initial Conditions > Define

- Add (name the condition “Inmitial-temp’)

- Click the ‘variable’ box and pick ‘temperature’

- In the ‘value’ box input 30

- Save

- Click ‘Apply Initial Conditions’

- In the ‘Apply to’ box pick ‘surface’. Make sure ‘Default Initial Condition’ is set at
‘Initial-temp’

- Under ‘Surface # enter ‘1°. Under ‘Initial Condition’ enter ‘Initial Temp’

-0k - Ok

We are ready to run the solver on the transient model. Before leaving ADINA-IN, we need to
save the database, and generate the datafile for the solver to use.

13. Under toolbar: File > Save (saves the database - *.idb file)
14. Under toolbar: File > ADINA-T > <filename>.dat (I called mine ps_1_trans.dat)

15. Click OFF the Run ADINA-T checkmark, then ‘Save’

SOLVER - ADINA-T

1. Enter ADINA-T solver by File > Launch ADINA-T
2. Start > <filename>.dat

3. Wait...
m

Some notes on troubleshooting transient finite element models:

1. Always look at the last time step of the transient solation. Is it consistent with results
from the steady state model?

2. Look at the time history plot of several nodes throughout the model. Do they make
physical sense? (i.e. are nodes on the vertical plane tracking the driving temperature
function? Are there any sharp discontinuities in the time history temperatures? etc....)
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3. Not a bad idea to re-run the transient model with more time steps in the region of
interest, especially if you are looking for thermally induced stresses. For example,
consider the following:

A

Run 1 with 5 time steps (e)
Run 2 with 20 time steps (x)

\

Could miss this behavior depending on time step resolution!

-
_—

Let’s lock at our response. What do you think the resolution of our sclution will be?
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Post-Processor - ADINA-PL.OT

1. Clear the window: toolbar - Clear

2. Load results file (porthole file)
- Under toolbar: File > Open > Porthole Files (*.por) <filename>.port
- Be sure to select the fransient porthole file, not the steady-state one...

3. Click on the ‘mesh plot’ button in the toolbar
4. Click the ‘band plot* button on the toolbar
5. Examine the temperature profile
- Note that by default, ADINA will display results for the last time step of a transient.

From our estimate of the Fourier number, we would expect that ADINA would display
the steady state temperature profile. Indeed, you should see:

ADINA ‘ - L.

‘TEMPERATURE
TIME 1200.

— 5100
— 480.0
— 450.0
= 420.0
—3%0.0
—360.0
— 330.0
— 3000
— 2700
— 2400
— 2100
— 180.0
1500
—120.0
=~ 90.0

MAXIMUM
A 5000

MINIMUN
¥ 1000




6. Next, we would like to look at a movie of the temperatuye profile and see approximately when
we reach steady state.

7. Display > Movie Shoot > Load Step. OK
8. Display > Animate. QK

9. We find out that the movie is going too fast for us to see where the actual steady state is
reached, therefore we should chose a larger delay in the animation (like pressing slow on your
VCR).

10. Display > Animate > Minimum delay. Enter 3.

11. It appears that the temperature profile no longer changes past 780 sec. Of course, since we
specified our time intervals after 300 seconds to be in jumps of 60 seconds, we lost some resolu-
tion on where exactly steady state was reached. One would have to change the time step in the
original problem statement for better resolution (from Adina-T, Control > Time Step, as done
when problem was defined).

12. Next, we would like to look at the specific temperature history of our choice and check if 780
sec is representative of steady state.

13. General Toolbar: ‘Clear’, then ‘Mesh Plot’, then ‘show node labels’.

14. T chose to look at a node around 30° from the horizontal. Zoom into that region. I chose node
322. (your node numbering may be different).

15. Definition > Model Point > Node. Add. Call it node322 (or whatever number you chose),
then OK. In the Node # box, also enter 322, OK.

16. Clear (general toolbar)
17. Graph > Response Curve (Model Point)

18. In the ‘X Coordinate’ box, change temperature to ‘Miscellanecus’ in the variable field.
Chose ‘time’ OK

19. We get a nice graph. Note 2 things. First, we have many more points up to 300 sec due to our

fine time increment. Second, steady state appears indeed to occur at around 800 sec as the graph
flattens out.

20. Next, we would also like to plot q vs. r for various times along the left hand vertical edge of
the structure.

21. Clear, then Mesh Plot and Show Node Labels



22. Zoom in on the vertical straight line.

23. Definition > Model line > Node. Add - call it ‘LINE1’. In the ‘Node #’ colurnn enter in the
nodes corresponding to the vertical line. OK

24. Clear (general toolbar)
25. Definitions > Response > Add. Enter TIME240

26. In “Type”, select “Load Step” and in “Sotution Time” type 240. Save. This tells ADINA
that we want the response at 240 sec.

27. Add again. Type TIME241 (1 second later}. Again, in “Solution Time” type 241, OK.
28. Graph > Response Curve (Model Line).

29. Graph attributes. Click on “...” next to “Y-Axis”. Add. Call it AXIS1. Change minimum
value to -200,000 and maximum value to 0, OK.

30. Next to curve depiction, click on “..”” Add. Enter TIME240. In legend attributes, next to
legend, change from “automatic” to “custom”. In legend box, enter TIME 240. OK,

31. Next to curve depiction, select TIME240 instead of default using the down arrow.
32. Next to “Y-Axis”, select AXIS1 instead of default using the down arrow
33. Response, select TTME240 using the down arrow.

34. In X-Coordinate “Variable” box, select “coordinate” and then “Z-coordinate” from the
box below it.

35. In the Y-Coordinate ‘“Variable” box, select “Flux”, verify that below it is
“Heat_Flux_Y”. Select “Averaged” smoothing technique.

36. We will now add to the same plot the response at TIME241. Repeat the last 8 steps except
type TIME241 wherever it says TIME240. You may also want to chose another symbol for the
line while doing the curve depiction (just type in “X” instead of “curve” in the symbol attributes
box).

37. You should now have a graph with two curves and two legends, TIME240 and TIME241,

38. This process can be repeated in very similar steps to obtain time response for T vs. arc length
(as we discussed in the steady state case).

39. Phew, finally done.............



