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Anthropology Dept.

Quicktime Tutorial
Fall 2000

To add subtitles to a song (or any audio clip):

Software you need:

1)  Quicktime 4 Pro (or above) available from www.apple.com

2)  SoundEdit 16 v. 2.07 (produced my Macromedia)

3)  Language kit for language you are working from

Hardware

Macintosh w/ CD ROM drive

And, if working from a cassette tape,

• Walkman

• Audio patch cord: stereo 1/8” plug to stereo 1/8”

The steps in detail:

1)  Install necessary software  (SoundEdit and Quicktime 4 Pro)

2) Save lyrics in text file.  Prepare them in the format necessary to convert to Quicktime

movie (see Step 5 below).

3) Digitize the song (from cassette tape) – If music is on CD skip to 3A below

a) Connect Walkman to computer:  use mini-plug patch cord – one end in walkman

headphone jack, other plug to computer microphone jack (N.B., into microphone

plug, NOT speaker plug)

b) open SoundEdit 16
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c) If only one track showing  Insert > Track (this will record tape to stereo)

d) Check record levels

a) Windows > levels

b) Play song (press play on walkman)

c) If no sound coming in, open Control Panels > Monitors and Sound

(if MacOS 9, Control Panels > Sound)

- select Sound button

- check that Sound Monitoring Source is “Sound In”

- close control panel

e) On Walkman, cue song about 5 seconds before you want to record

f) Play walkman; in SoundEdit press record (red dot button).  YOU ARE NOW

RECORDING from walkman to computer. The levels lights should be moving

showing the playing song, the timer on the Controls window of SoundEdit should

be counting down time.

g) When song is over, Stop recording (square button Controls window in

SoundEdit).

h) Save file as Audio IFF (add .aiff suffix to file name)

i) Convert AIFF file to MP3 to conserve disk space

- In SoundEdit, check encoding settings.  Xtras > Shockwave for Audio

Settings (n.b., “Shockwave for Audio” is the same as MP3).  Settings

should be:  “128 Kbits/Sec” and “High (more processing time).  Do NOT

convert stereo to mono.

- File > Export.  Use “Export Type” pull-down menu to select “SWA file.”

Rename file to add suffix “.mp3”  NOTE:  This is the audio file you will

be using in the final product.

3A)  Digitize song from CD

a) Insert CD into CD-ROM drive
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b) Open SoundEdit, click CD icon button (or Xtras > Convert CD Audio).  Select

track you want to digitize.  Check record settings by using OPTIONS button (44.1

Mhz, stereo, 16 bits),  then choose track # (i.e., number of track on CD), and . . .

c) Save as Audio IFF (name-you-choose.aiff).  NOTE:  You will use this file to set

“cue” marks that will be used to identify time code for lyric subtitles.

d) Edit the song by dragging cursor over areas.  You can select just the portion you

want to translate

e) Convert AIFF file to MP3 to conserve disk space

- In SoundEdit, check encoding settings.  Xtras > Shockwave for Audio

Settings (n.b., “Shockwave for Audio” is the same as MP3).  Settings

should be:  “128 Kbits/Sec” and “High (more processing time).  Do NOT

convert stereo to mono.

- File > Export.  Use “Export Type” pull-down menu to select “SWA file.”

Rename file to add suffix “.mp3”  NOTE:  This is the audio file you will

be using in the final product.

4)  Make cues, i.e., identify the points where you want each line of subtitles inserted.

a) What you will do:  In SoundEdit, you play the AIFF version of the song you just

digitized, and while it plays you will add “cue points.”  These will be the points

where Quicktime will insert subtitles into the song.  (Why?  Because you need to

tell Quicktime when exactly you want each line of the lyrics of the song to play in

conjunction with the audio.  This is the simplest and most accurate way I’ve

found to work out the time code)

b) How:  Play song in SoundEdit (black triangle in Controls window or space-bar to

start song playing).  (Don’t hear any sound?  Check Control Panels > Monitors

and Sound > Sound Out.  Make sure that volume slider is up).

c) Add Cue by SoundEdit:  “cmd + M” for each cue
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d) Check and Edit cues:  Windows > Cues (to view and help edit Cue placement)

HINT:  double-click cue (e.g., cue 2) then space-bar to play.  NOTE:  This is a

very important step.  Make sure you are happy with where the subtitles will

appear, because it is harder to go back and change them later.

e) Print cue time stamps.  Use  screen capture to make a print out of the Cues

window in SoundEdit.  With SoundEdit Cues window open and showing the

numbers you want to print out, press  “cmd + shift +3” all at once. The cursor

turns into crosshairs.  Select the area you’d like to print (press down and hold at

one corner, drag – with button down – to other corner.  When you release the

mouse button, “Picture 1” is saved to your hard disk. Open “Picture 1” (double-

clicking on file should open it in SimpleText), then Print.

Some notes about working with cues:

As noted in (d) above, you toggle to cue by double-clicking cue number then

space bar.  Now you can hear when that number line of the lyrics will appear.

You can drag cues on the time line above the sound file to adjust position earlier

or later.

You can see a more detailed breakdown of the sound file by adjusting the scale of

the view.  At the bottom of sound file window, and to the right of “16 Bits/44.1 kHz”

there are small vertical lines; dragging the small triangle right and left will adjust the

scale of the view:  slide left for more detailed view; slide right to fit more of the song

in the window.

You can delete cues by dragging them off the time line or by using the Cues

window (highlight unwanted cue, then delete button).

5)  Prepare text file of lyrics to be converted into a Quicktime movie

In SimpleText, use the print out of the Cues from SoundEdit to add time stamps to

your text file.  Don’t forget to set the desired parameters for the movie of subtitles

you are creating.  I recommend the following settings to prepare a movie for

electronic classroom presentation.  You may the language, font size, and font style to

suit your own needs.  Note that the format below produces the effect of having two

lines of lyrics appear in order.

{QTtext} {font:Osaka}
              {bold} {size:36}
　{timeScale:100}
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              {width:600} {height:380}
              {timeStamps:absolute} {language:Japanese}
[00:00:00.00]
"Addicted to You"

Written and Performed by

UTADA Hikaru

(1999)

[00:00:06.00]

[00:00:06.50]

Produced by:
Jimmy Jam and Terry Lewis
1999(c)
(Toshiba EMI, TOCT-4180）
------------------------
[00:00:11.46]

[00:00:24.51]

I don't need to see you

別に会う必要なんて無い　(foreign language lyrics here)

[00:00:28.88]

I don't need to see you
I've got a lot to do

別に会う必要なんて無い　(foreign language lyrics)

しなきゃいけないこと沢山あるし (foreign language lyrics)

[00:00:34.63]

we don't need to talk everyday

毎日話す必要なんて無い　(foreign language lyrics)
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IN ENGLISH:  the following code will give you 36 point, bold, Geneva font in a

window that is 600 pixels wide by 380 pixels tall. The text will be centered.  SIMPLY

PASTE THE FOLLOWING AT THE TOP OF YOUR SUBTITLES TEXT FILE.

{QTtext} {font:Geneva}
              {bold} {size:36}
　{timeScale:100}

              {width:600} {height:380}
              {timeStamps:absolute} {language:English}
[00:00:00.00]

WARNING:  KNOWN PROBLEM – Occasionally, for some reason I have not been

able to ascertain, the text file becomes corrupted in a way that makes it impossible to

convert to a Quicktime movie.  WORK AROUND:  As you enter your time code,

periodically save the text file using “save as” and assign a higher number (e.g.,

Eagles-HotelC-TC5.txt) and so on as you go along.  You can skip to the next step to

keep checking that the file can be converted using Quicktime.  If it doesn’t convert,

you may have to go back to the highest number that is working and re-enter the

subsequent time code.  Any ideas for resolving this problem would be appreciated.

For more information on working with Text Tracks in Quicktime, consult

www.apple.com/quicktime and follow the link to Authoring.  One of the sections will

discuss Text Tracks.  There is information for other uses and for uses on the Web.  A

search for Text Tracks should also pull up some useful information.)

6)  Convert text file into a “text track” movie

a) In Quicktime Player, File > Import  then choose text file you have been editing.

b) When asked to save, I recommend appending “STnm.mov” (ie. “subtitle no music

movie”) to the title, because you will need this file later if you are using a foreign

language.

Troubleshooting:  Sometimes the text file will not convert (see “Warning” above).

Also, the initial time code [00:00:00.00] must be on the line immediately below

the information in the brackets (you may not skip a line).  There may be other

tricks.  Consult Quicktime site for more information on text tracks.
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c) You can play this movie in the Quicktime player to check if the subtitles come out

looking right.  At this point, however, there will be no music.  For that, go to the

next step.

7)  Add the music to the subtitle movie, using “Add” function of Quicktime 4 Pro:

a) In Quicktime Player, open the MP3 version of your song.  File > Open  and

select your audio mp3 file.  The “open” button will turn to “convert” (and that’s

fine; select it).

b) Copy this entire file (Edit > Select All or “cmd + a”).  Then, Edit > Copy (or

“cmd + c); close the mp3 file.

c) Open the “. . . STnm.mov” (i.e., subtitle no music movie file that you created in

Step 6.

d) Again, select all (Edit > Select All or “cmd + a”).

e) AND NOW THE MOST AMAZING STEP OF ALL.  WHAT:  You will add the

music (mp3 file now copied to the clipboard) to the subtitle movie file (which is

open in the Quicktime player).

HOW:  Hold down the “option” key and, at the same time, pull down the “Edit”

menu.  Where you would usually find the “Paste” menu item, it now reads “Add”

– choose “Add.”  This adds the music to the subtitle movie.  Save as under a new

name.

Your movie is now complete.  Play it to see how it looks.

8) Foreign languages.  If you want your foreign language subtitles to display correctly

even on a machine that does not have the appropriate language kit, there is a way to

do so.  (E.g., for electronic classrooms or to post on a web site so that students can

download the file).
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a)  Once you have finished polishing the timing and layout of your subtitles (i.e., up

to Step 6C), open your  “. . . STnm.mov” file in Quicktime Player.  In other

words, use the Text Track movie without music.  DO NOT USE the subtitle file

with music (Step 7) since doing the conversion below will substantially diminish

the sound quality unnecessarily.

b) File > Export (give a name that reflects the conversion you will do.  I use “Artist-

Title-STSor8fps.mov” which indicates I use Sorenson video compressor at 8

frames per second and the file is saved as a Quicktime movie.)  DON’T EXPORT

YET.

c) The pull down menu “Export” should read:  “Movie to Quicktime Movie.”

DON’T EXPORT YET.

d) Choose “Options” button. THIS IS THE KEY STEP.

• Choose “Video > Settings” then “Compressor > Sorenson Video”; 8 frames

per second; quality Medium; Key frame every 24 frames.

e) Now EXPORT (this will take some time).

f) Return to Step 7 and add the MP3 music file.

Why do this?  What you are doing is taking a “text track” (Step 6) movie which relies

on your foreign language kit to interpret the fonts and converting this to a “video

movie” that is simply a series of frames saved as, essentially, picture data.  Any

computer with Quicktime 4 (Pro or freeware version) will be able to see the foreign

language lyrics with this adjustment.

Troubleshooting:  Sometimes in doing this conversion, the lyrics of two different

sections will overlap creating gobbledy-gook for a few frames.  WORK AROUND:

Instead of using Sorenson video compressor, use Cinepak (Export > Options >

Video/Settings > Compressor > Cinepak).  Cinepak uses up more disk space than

Sorenson, but it seems to work more accurately in making this conversion.

VIDEO:  You can, of course, use the same techniques to add subtitles to video.  One

trick is to export the audio track of your video clip, then create the text track subtitles

using the steps above.  Then, using video editing software add in the subtitle movie

you created.
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For more examples of my work:

http://iancondry.com

follow link to Multimedia Projects to see examples

follow link to QuickTime Tutorial for this handout

OR

http://www1.union.edu/~condryi/ctech/  (Culture and Technology course page)

Good luck.

Suggestions, comments, questions? Email to:  condryi@union.edu

October 2000

Anthropology Dept.

Union College

Schenectady, NY 12308


