PREPWebPartLibrary20

SharePoint PREP 2.0

PREPWebPartLibrary20 Namespace

Namespace hierarchy

Classes

Class | Description
PREPMatrixWebPart20 |
PREPProjectAdmin20 |
RepeaterColumn |
RepeaterFooter |
RepeaterHeader |
UserAlerts |

Structures

Structure | Description
PREPMatrixWebPart20.PREPImages |


PREPMatrixWebPart20 Class

For a list of all members of this type, see PREPMatrixWebPart20 Members.

System.Object
System.Web.UI.Control
Microsoft.SharePoint.WebPartPages.WebPart
PREPWebPartLibrary20.PREPMatrixWebPart20

public class PREPMatrixWebPart20 : WebPart

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: PREPWebPartLibrary20

Assembly: PREPWebPartLibrary20 (in PREPWebPartLibrary20.dll)

See Also

PREPMatrixWebPart20 Members | PREPWebPartLibrary20 Namespace

Generated from assembly PREPWebPartLibrary20 [2.0.0.0]


PREPMatrixWebPart20 Members

PREPMatrixWebPart20 overview

Public Instance Constructors

PREPMatrixWebPart20 Constructor Initializes a new instance of the PREPMatrixWebPart20 class.

Public Instance Properties

AllowMinimize (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
AllowRemove (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
AllowZoneChange (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
BindingContainer (inherited from Control) |
BrowserDesignMode (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
Caption (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ClientID (inherited from Control) | Gets the server control identifier generated by ASP.NET.
ClientName (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ConnectionID (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
Connections (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
Controls (inherited from Control) | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy.
Description (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
DetailLink (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
Dir (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
EffectiveFrameType (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
EffectiveStorage (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
EffectiveTitle (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
EnableViewState (inherited from Control) | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client.
ExportControlledProperties (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
FrameState (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
FrameType (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
Height (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
HelpLink (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ID (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
IsIncluded (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
IsIncludedFilter (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
IsVisible (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
MissingAssembly (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
NamingContainer (inherited from Control) | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value.
Page (inherited from Control) | Gets a reference to the Page instance that contains the server control.
Parent (inherited from Control) | Gets a reference to the server control's parent control in the page control hierarchy.
PartImageLarge (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
PartImageSmall (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
PartOrder (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
Permissions (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
Qualifier (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
Site (inherited from Control) | Gets information about the Web site to which the server control belongs.
StorageKey (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
TemplateSourceDirectory (inherited from Control) | Gets the virtual directory of the Page or UserControl that contains the current server control.
Title (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
TraceEnabled |
UniqueID (inherited from Control) | Gets the unique, hierarchically-qualified identifier for the server control.
UnknownXmlElements (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
UseDefaultStyles (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
Visible (inherited from Control) | Gets or sets a value that indicates whether a server control is rendered as UI on the page.
Width (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ZoneID (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |

Public Instance Methods

AfterDeserialize (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
CanRunAt (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
CreateWebPartMenu (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
DataBind (inherited from Control) | Binds a data source to the invoked server control and all its child controls.
Dispose (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
EnsureInterfaces (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindControl (inherited from Control) | Overloaded. Searches the current naming container for a server control with the specified id parameter.
GetData (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
GetDesignTimeFooter (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
GetDesignTimeHeader (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetInitEventArgs (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
GetRequiresData (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
GetToolParts (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
GetType (inherited from Object) | Gets the Type of the current instance.
HasControls (inherited from Control) | Determines if the server control contains any child controls.
LoadResource (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
PartCacheInvalidate (inherited from Microsoft.SharePoint.WebPartPages.WebPart) | Overloaded.
PartCommunicationConnect (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
PartCommunicationInit (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
PartCommunicationMain (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
RenderControl (inherited from Control) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
ResolveUrl (inherited from Control) | Converts a URL into one that is usable on the requesting client.
SetRenderMethodDelegate (inherited from Control) |
ShouldSerializeAllowMinimize (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializeAllowRemove (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializeAllowZoneChange (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializeConnectionID (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializeConnections (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializeDescription (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializeDetailLink (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializeDir (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializeExportControlledProperties (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializeFrameState (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializeFrameType (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializeHeight (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializeHelpLink (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializeIsIncluded (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializeIsIncludedFilter (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializeIsVisible (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializeMissingAssembly (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializePartImageLarge (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializePartImageSmall (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializePartOrder (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializeTitle (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializeWidth (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializeZoneID (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

DataBinding (inherited from Control) | Occurs when the server control binds to a data source.
Disposed (inherited from Control) | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested.
Init (inherited from Control) | Occurs when the server control is initialized, which is the first step in the its lifecycle.
Load (inherited from Control) | Occurs when the server control is loaded into the Page object.
PreRender (inherited from Control) | Occurs when the server control is about to render to its containing Page object.
Unload (inherited from Control) | Occurs when the server control is unloaded from memory.

Protected Instance Properties

CacheType (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ChildControlsCreated (inherited from Control) | Gets a value that indicates whether the server control's child controls have been created.
ClassResourcePath (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ContainerWidth (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
Context (inherited from Control) | Gets the HttpContext object associated with the server control for the current Web request.
Events (inherited from Control) | Gets a list of event handler delegates for the control. This property is read-only.
HasChildViewState (inherited from Control) | Gets a value indicating whether the current server control's child controls have any saved view-state settings.
IsTrackingViewState (inherited from Control) | Gets a value that indicates whether the server control is saving changes to its view state.
OverflowAuto (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
SerializeAll (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ViewState (inherited from Control) | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page.
ViewStateIgnoresCase (inherited from Control) | Gets a value that indicates whether the StateBag object is case-insensitive.
WorkItemTimeout (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |

Protected Instance Methods

AddParsedSubObject (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
BuildProfileTree (inherited from Control) |
ClearChildViewState (inherited from Control) | Deletes the view-state information for all the server control's child controls.
CreateChildControls (inherited from Control) | Notifies server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering.
CreateControlCollection (inherited from Control) | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control.
EnsureChildControls (inherited from Control) | Determines whether the server control contains child controls. If it does not, it creates child controls.
Finalize (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
FindControl (inherited from Control) | Overloaded.
GetCustomBuilder (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
IsLiteralContent (inherited from Control) | Determines if the server control holds only literal content.
LoadViewState (inherited from Control) | Restores view-state information from a previous page request that was saved by the SaveViewState method.
MapPathSecure (inherited from Control) | Retrieves the physical path that a virtual path, either absolute or relative, maps to.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyWorkItemComplete (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
OnBubbleEvent (inherited from Control) | Determines whether the event for the server control is passed up the page's UI server control hierarchy.
OnDataBinding (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
OnInit |
OnLoad (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
OnPreRender (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
OnUnload (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
PartCacheInvalidate (inherited from Microsoft.SharePoint.WebPartPages.WebPart) | Overloaded.
PartCacheRead (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
PartCacheWrite (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
RaiseBubbleEvent (inherited from Control) | Assigns any sources of the event and its information to the control's parent.
RegisterInterface (inherited from Microsoft.SharePoint.WebPartPages.WebPart) | Overloaded.
RegisterWorkItem (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
RegisterWorkItemCallback (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
Render (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
RenderChildren (inherited from Control) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client.
RenderWebPart |
RenderWorkItemTimeout (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
SaveViewState (inherited from Control) | Saves any server control view-state changes that have occurred since the time the page was posted back to the server.
TrackViewState (inherited from Control) | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property.

Protected Internal Instance Properties

SaveProperties (inherited from Microsoft.SharePoint.WebPartPages.WebPart)
ShouldValidate (inherited from Microsoft.SharePoint.WebPartPages.WebPart)
WebPartMenu (inherited from Microsoft.SharePoint.WebPartPages.WebPart)

Protected Internal Instance Methods

AddedControl (inherited from Control) | Called after a control is added to the Controls collection of another control.
RemovedControl (inherited from Control) | Called after a control is removed from the Controls collection of another control.
ReplaceTokens (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |

See Also

PREPMatrixWebPart20 Class | PREPWebPartLibrary20 Namespace

Generated from assembly PREPWebPartLibrary20 [2.0.0.0]


PREPMatrixWebPart20 Constructor

Initializes a new instance of the PREPMatrixWebPart20 class.

public PREPMatrixWebPart20();

See Also

PREPMatrixWebPart20 Class | PREPWebPartLibrary20 Namespace

Generated from assembly PREPWebPartLibrary20 [2.0.0.0]


PREPMatrixWebPart20 Properties

The properties of the PREPMatrixWebPart20 class are listed below. For a complete list of PREPMatrixWebPart20 class members, see the PREPMatrixWebPart20 Members topic.

Public Instance Properties

AllowMinimize (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
AllowRemove (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
AllowZoneChange (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
BindingContainer (inherited from Control) |
BrowserDesignMode (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
Caption (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ClientID (inherited from Control) | Gets the server control identifier generated by ASP.NET.
ClientName (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ConnectionID (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
Connections (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
Controls (inherited from Control) | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy.
Description (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
DetailLink (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
Dir (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
EffectiveFrameType (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
EffectiveStorage (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
EffectiveTitle (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
EnableViewState (inherited from Control) | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client.
ExportControlledProperties (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
FrameState (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
FrameType (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
Height (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
HelpLink (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ID (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
IsIncluded (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
IsIncludedFilter (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
IsVisible (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
MissingAssembly (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
NamingContainer (inherited from Control) | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value.
Page (inherited from Control) | Gets a reference to the Page instance that contains the server control.
Parent (inherited from Control) | Gets a reference to the server control's parent control in the page control hierarchy.
PartImageLarge (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
PartImageSmall (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
PartOrder (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
Permissions (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
Qualifier (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
Site (inherited from Control) | Gets information about the Web site to which the server control belongs.
StorageKey (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
TemplateSourceDirectory (inherited from Control) | Gets the virtual directory of the Page or UserControl that contains the current server control.
Title (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
TraceEnabled |
UniqueID (inherited from Control) | Gets the unique, hierarchically-qualified identifier for the server control.
UnknownXmlElements (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
UseDefaultStyles (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
Visible (inherited from Control) | Gets or sets a value that indicates whether a server control is rendered as UI on the page.
Width (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ZoneID (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |

Protected Instance Properties

CacheType (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ChildControlsCreated (inherited from Control) | Gets a value that indicates whether the server control's child controls have been created.
ClassResourcePath (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ContainerWidth (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
Context (inherited from Control) | Gets the HttpContext object associated with the server control for the current Web request.
Events (inherited from Control) | Gets a list of event handler delegates for the control. This property is read-only.
HasChildViewState (inherited from Control) | Gets a value indicating whether the current server control's child controls have any saved view-state settings.
IsTrackingViewState (inherited from Control) | Gets a value that indicates whether the server control is saving changes to its view state.
OverflowAuto (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
SerializeAll (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ViewState (inherited from Control) | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page.
ViewStateIgnoresCase (inherited from Control) | Gets a value that indicates whether the StateBag object is case-insensitive.
WorkItemTimeout (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |

Protected Internal Instance Properties

SaveProperties (inherited from Microsoft.SharePoint.WebPartPages.WebPart)
ShouldValidate (inherited from Microsoft.SharePoint.WebPartPages.WebPart)
WebPartMenu (inherited from Microsoft.SharePoint.WebPartPages.WebPart)

See Also

PREPMatrixWebPart20 Class | PREPWebPartLibrary20 Namespace

Generated from assembly PREPWebPartLibrary20 [2.0.0.0]


PREPMatrixWebPart20.TraceEnabled Property

public bool TraceEnabled {get; set;}

See Also

PREPMatrixWebPart20 Class | PREPWebPartLibrary20 Namespace

Generated from assembly PREPWebPartLibrary20 [2.0.0.0]


PREPMatrixWebPart20 Methods

The methods of the PREPMatrixWebPart20 class are listed below. For a complete list of PREPMatrixWebPart20 class members, see the PREPMatrixWebPart20 Members topic.

Public Instance Methods

AfterDeserialize (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
CanRunAt (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
CreateWebPartMenu (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
DataBind (inherited from Control) | Binds a data source to the invoked server control and all its child controls.
Dispose (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
EnsureInterfaces (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindControl (inherited from Control) | Overloaded. Searches the current naming container for a server control with the specified id parameter.
GetData (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
GetDesignTimeFooter (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
GetDesignTimeHeader (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetInitEventArgs (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
GetRequiresData (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
GetToolParts (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
GetType (inherited from Object) | Gets the Type of the current instance.
HasControls (inherited from Control) | Determines if the server control contains any child controls.
LoadResource (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
PartCacheInvalidate (inherited from Microsoft.SharePoint.WebPartPages.WebPart) | Overloaded.
PartCommunicationConnect (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
PartCommunicationInit (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
PartCommunicationMain (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
RenderControl (inherited from Control) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
ResolveUrl (inherited from Control) | Converts a URL into one that is usable on the requesting client.
SetRenderMethodDelegate (inherited from Control) |
ShouldSerializeAllowMinimize (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializeAllowRemove (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializeAllowZoneChange (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializeConnectionID (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializeConnections (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializeDescription (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializeDetailLink (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializeDir (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializeExportControlledProperties (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializeFrameState (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializeFrameType (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializeHeight (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializeHelpLink (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializeIsIncluded (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializeIsIncludedFilter (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializeIsVisible (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializeMissingAssembly (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializePartImageLarge (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializePartImageSmall (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializePartOrder (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializeTitle (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializeWidth (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializeZoneID (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

AddParsedSubObject (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
BuildProfileTree (inherited from Control) |
ClearChildViewState (inherited from Control) | Deletes the view-state information for all the server control's child controls.
CreateChildControls (inherited from Control) | Notifies server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering.
CreateControlCollection (inherited from Control) | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control.
EnsureChildControls (inherited from Control) | Determines whether the server control contains child controls. If it does not, it creates child controls.
Finalize (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
FindControl (inherited from Control) | Overloaded.
GetCustomBuilder (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
IsLiteralContent (inherited from Control) | Determines if the server control holds only literal content.
LoadViewState (inherited from Control) | Restores view-state information from a previous page request that was saved by the SaveViewState method.
MapPathSecure (inherited from Control) | Retrieves the physical path that a virtual path, either absolute or relative, maps to.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyWorkItemComplete (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
OnBubbleEvent (inherited from Control) | Determines whether the event for the server control is passed up the page's UI server control hierarchy.
OnDataBinding (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
OnInit |
OnLoad (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
OnPreRender (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
OnUnload (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
PartCacheInvalidate (inherited from Microsoft.SharePoint.WebPartPages.WebPart) | Overloaded.
PartCacheRead (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
PartCacheWrite (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
RaiseBubbleEvent (inherited from Control) | Assigns any sources of the event and its information to the control's parent.
RegisterInterface (inherited from Microsoft.SharePoint.WebPartPages.WebPart) | Overloaded.
RegisterWorkItem (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
RegisterWorkItemCallback (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
Render (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
RenderChildren (inherited from Control) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client.
RenderWebPart |
RenderWorkItemTimeout (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
SaveViewState (inherited from Control) | Saves any server control view-state changes that have occurred since the time the page was posted back to the server.
TrackViewState (inherited from Control) | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property.

Protected Internal Instance Methods

AddedControl (inherited from Control) | Called after a control is added to the Controls collection of another control.
RemovedControl (inherited from Control) | Called after a control is removed from the Controls collection of another control.
ReplaceTokens (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |

See Also

PREPMatrixWebPart20 Class | PREPWebPartLibrary20 Namespace

Generated from assembly PREPWebPartLibrary20 [2.0.0.0]


PREPMatrixWebPart20.OnInit Method

protected override void OnInit(
EventArgs e
);

See Also

PREPMatrixWebPart20 Class | PREPWebPartLibrary20 Namespace

Generated from assembly PREPWebPartLibrary20 [2.0.0.0]


PREPMatrixWebPart20.RenderWebPart Method

protected override void RenderWebPart(
HtmlTextWriter output
);

See Also

PREPMatrixWebPart20 Class | PREPWebPartLibrary20 Namespace

Generated from assembly PREPWebPartLibrary20 [2.0.0.0]


PREPMatrixWebPart20.PREPImages Structure

For a list of all members of this type, see PREPMatrixWebPart20.PREPImages Members.

System.Object
System.ValueType
PREPWebPartLibrary20.PREPMatrixWebPart20.PREPImages

public struct PREPMatrixWebPart20.PREPImages

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: PREPWebPartLibrary20

Assembly: PREPWebPartLibrary20 (in PREPWebPartLibrary20.dll)

See Also

PREPMatrixWebPart20.PREPImages Members | PREPWebPartLibrary20 Namespace

Generated from assembly PREPWebPartLibrary20 [2.0.0.0]


PREPMatrixWebPart20.PREPImages Members

PREPMatrixWebPart20.PREPImages overview

Public Static Fields

Document
IdeasTask
MyIdeasTask
MyTaskInProgress
MyTaskNotStarted
TaskCompleted
TaskInProgress
TaskNotStarted

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

PREPMatrixWebPart20.PREPImages Class | PREPWebPartLibrary20 Namespace

Generated from assembly PREPWebPartLibrary20 [2.0.0.0]


PREPMatrixWebPart20.PREPImages Fields

The fields of the PREPMatrixWebPart20.PREPImages structure are listed below. For a complete list of PREPMatrixWebPart20.PREPImages structure members, see the PREPMatrixWebPart20.PREPImages Members topic.

Public Static Fields

Document
IdeasTask
MyIdeasTask
MyTaskInProgress
MyTaskNotStarted
TaskCompleted
TaskInProgress
TaskNotStarted

See Also

PREPMatrixWebPart20.PREPImages Class | PREPWebPartLibrary20 Namespace

Generated from assembly PREPWebPartLibrary20 [2.0.0.0]


PREPMatrixWebPart20.PREPImages.Document Field

public static string Document;

See Also

PREPMatrixWebPart20.PREPImages Class | PREPWebPartLibrary20 Namespace

Generated from assembly PREPWebPartLibrary20 [2.0.0.0]


PREPMatrixWebPart20.PREPImages.IdeasTask Field

public static string IdeasTask;

See Also

PREPMatrixWebPart20.PREPImages Class | PREPWebPartLibrary20 Namespace

Generated from assembly PREPWebPartLibrary20 [2.0.0.0]


PREPMatrixWebPart20.PREPImages.MyIdeasTask Field

public static string MyIdeasTask;

See Also

PREPMatrixWebPart20.PREPImages Class | PREPWebPartLibrary20 Namespace

Generated from assembly PREPWebPartLibrary20 [2.0.0.0]


PREPMatrixWebPart20.PREPImages.MyTaskInProgress Field

public static string MyTaskInProgress;

See Also

PREPMatrixWebPart20.PREPImages Class | PREPWebPartLibrary20 Namespace

Generated from assembly PREPWebPartLibrary20 [2.0.0.0]


PREPMatrixWebPart20.PREPImages.MyTaskNotStarted Field

public static string MyTaskNotStarted;

See Also

PREPMatrixWebPart20.PREPImages Class | PREPWebPartLibrary20 Namespace

Generated from assembly PREPWebPartLibrary20 [2.0.0.0]


PREPMatrixWebPart20.PREPImages.TaskCompleted Field

public static string TaskCompleted;

See Also

PREPMatrixWebPart20.PREPImages Class | PREPWebPartLibrary20 Namespace

Generated from assembly PREPWebPartLibrary20 [2.0.0.0]


PREPMatrixWebPart20.PREPImages.TaskInProgress Field

public static string TaskInProgress;

See Also

PREPMatrixWebPart20.PREPImages Class | PREPWebPartLibrary20 Namespace

Generated from assembly PREPWebPartLibrary20 [2.0.0.0]


PREPMatrixWebPart20.PREPImages.TaskNotStarted Field

public static string TaskNotStarted;

See Also

PREPMatrixWebPart20.PREPImages Class | PREPWebPartLibrary20 Namespace

Generated from assembly PREPWebPartLibrary20 [2.0.0.0]


PREPProjectAdmin20 Class

For a list of all members of this type, see PREPProjectAdmin20 Members.

System.Object
System.Web.UI.Control
Microsoft.SharePoint.WebPartPages.WebPart
PREPWebPartLibrary20.PREPProjectAdmin20

public class PREPProjectAdmin20 : WebPart

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: PREPWebPartLibrary20

Assembly: PREPWebPartLibrary20 (in PREPWebPartLibrary20.dll)

See Also

PREPProjectAdmin20 Members | PREPWebPartLibrary20 Namespace

Generated from assembly PREPWebPartLibrary20 [2.0.0.0]


PREPProjectAdmin20 Members

PREPProjectAdmin20 overview

Public Instance Constructors

PREPProjectAdmin20 Constructor Initializes a new instance of the PREPProjectAdmin20 class.

Public Instance Properties

AllowMinimize (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
AllowRemove (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
AllowZoneChange (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
BindingContainer (inherited from Control) |
BrowserDesignMode (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
Caption (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ClientID (inherited from Control) | Gets the server control identifier generated by ASP.NET.
ClientName (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ConnectionID (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
Connections (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
Controls (inherited from Control) | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy.
Description (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
DetailLink (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
Dir (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
EffectiveFrameType (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
EffectiveStorage (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
EffectiveTitle (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
EnableViewState (inherited from Control) | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client.
ExportControlledProperties (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
FrameState (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
FrameType (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
Height (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
HelpLink (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ID (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
IsIncluded (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
IsIncludedFilter (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
IsVisible (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
MissingAssembly (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
NamingContainer (inherited from Control) | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value.
Page (inherited from Control) | Gets a reference to the Page instance that contains the server control.
Parent (inherited from Control) | Gets a reference to the server control's parent control in the page control hierarchy.
PartImageLarge (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
PartImageSmall (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
PartOrder (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
Permissions (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
Qualifier (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
Site (inherited from Control) | Gets information about the Web site to which the server control belongs.
StorageKey (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
TemplateSourceDirectory (inherited from Control) | Gets the virtual directory of the Page or UserControl that contains the current server control.
Title (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
UniqueID (inherited from Control) | Gets the unique, hierarchically-qualified identifier for the server control.
UnknownXmlElements (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
UseDefaultStyles (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
Visible (inherited from Control) | Gets or sets a value that indicates whether a server control is rendered as UI on the page.
Width (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ZoneID (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |

Public Instance Methods

AfterDeserialize (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
CanRunAt (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
CreateWebPartMenu (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
DataBind (inherited from Control) | Binds a data source to the invoked server control and all its child controls.
Dispose (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
EnsureInterfaces (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindControl (inherited from Control) | Overloaded. Searches the current naming container for a server control with the specified id parameter.
GetData (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
GetDesignTimeFooter (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
GetDesignTimeHeader (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetInitEventArgs (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
GetRequiresData (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
GetToolParts (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
GetType (inherited from Object) | Gets the Type of the current instance.
HasControls (inherited from Control) | Determines if the server control contains any child controls.
LoadResource (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
PartCacheInvalidate (inherited from Microsoft.SharePoint.WebPartPages.WebPart) | Overloaded.
PartCommunicationConnect (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
PartCommunicationInit (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
PartCommunicationMain (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
RenderControl (inherited from Control) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
ResolveUrl (inherited from Control) | Converts a URL into one that is usable on the requesting client.
SetRenderMethodDelegate (inherited from Control) |
ShouldSerializeAllowMinimize (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializeAllowRemove (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializeAllowZoneChange (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializeConnectionID (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializeConnections (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializeDescription (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializeDetailLink (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializeDir (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializeExportControlledProperties (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializeFrameState (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializeFrameType (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializeHeight (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializeHelpLink (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializeIsIncluded (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializeIsIncludedFilter (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializeIsVisible (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializeMissingAssembly (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializePartImageLarge (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializePartImageSmall (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializePartOrder (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializeTitle (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializeWidth (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializeZoneID (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

DataBinding (inherited from Control) | Occurs when the server control binds to a data source.
Disposed (inherited from Control) | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested.
Init (inherited from Control) | Occurs when the server control is initialized, which is the first step in the its lifecycle.
Load (inherited from Control) | Occurs when the server control is loaded into the Page object.
PreRender (inherited from Control) | Occurs when the server control is about to render to its containing Page object.
Unload (inherited from Control) | Occurs when the server control is unloaded from memory.

Protected Instance Properties

CacheType (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ChildControlsCreated (inherited from Control) | Gets a value that indicates whether the server control's child controls have been created.
ClassResourcePath (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ContainerWidth (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
Context (inherited from Control) | Gets the HttpContext object associated with the server control for the current Web request.
Events (inherited from Control) | Gets a list of event handler delegates for the control. This property is read-only.
HasChildViewState (inherited from Control) | Gets a value indicating whether the current server control's child controls have any saved view-state settings.
IsTrackingViewState (inherited from Control) | Gets a value that indicates whether the server control is saving changes to its view state.
OverflowAuto (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
SerializeAll (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ViewState (inherited from Control) | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page.
ViewStateIgnoresCase (inherited from Control) | Gets a value that indicates whether the StateBag object is case-insensitive.
WorkItemTimeout (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |

Protected Instance Methods

AddParsedSubObject (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
BuildProfileTree (inherited from Control) |
ClearChildViewState (inherited from Control) | Deletes the view-state information for all the server control's child controls.
CreateChildControls |
CreateControlCollection (inherited from Control) | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control.
EnsureChildControls (inherited from Control) | Determines whether the server control contains child controls. If it does not, it creates child controls.
Finalize (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
FindControl (inherited from Control) | Overloaded.
GetCustomBuilder (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
IsLiteralContent (inherited from Control) | Determines if the server control holds only literal content.
LoadViewState (inherited from Control) | Restores view-state information from a previous page request that was saved by the SaveViewState method.
MapPathSecure (inherited from Control) | Retrieves the physical path that a virtual path, either absolute or relative, maps to.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyWorkItemComplete (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
OnBubbleEvent (inherited from Control) | Determines whether the event for the server control is passed up the page's UI server control hierarchy.
OnDataBinding (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
OnInit |
OnLoad (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
OnPreRender (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
OnUnload (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
PartCacheInvalidate (inherited from Microsoft.SharePoint.WebPartPages.WebPart) | Overloaded.
PartCacheRead (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
PartCacheWrite (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
RaiseBubbleEvent (inherited from Control) | Assigns any sources of the event and its information to the control's parent.
RegisterInterface (inherited from Microsoft.SharePoint.WebPartPages.WebPart) | Overloaded.
RegisterWorkItem (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
RegisterWorkItemCallback (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
Render (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
RenderChildren (inherited from Control) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client.
RenderWebPart |
RenderWorkItemTimeout (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
SaveViewState (inherited from Control) | Saves any server control view-state changes that have occurred since the time the page was posted back to the server.
TrackViewState (inherited from Control) | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property.

Protected Internal Instance Properties

SaveProperties (inherited from Microsoft.SharePoint.WebPartPages.WebPart)
ShouldValidate (inherited from Microsoft.SharePoint.WebPartPages.WebPart)
WebPartMenu (inherited from Microsoft.SharePoint.WebPartPages.WebPart)

Protected Internal Instance Methods

AddedControl (inherited from Control) | Called after a control is added to the Controls collection of another control.
RemovedControl (inherited from Control) | Called after a control is removed from the Controls collection of another control.
ReplaceTokens (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |

See Also

PREPProjectAdmin20 Class | PREPWebPartLibrary20 Namespace

Generated from assembly PREPWebPartLibrary20 [2.0.0.0]


PREPProjectAdmin20 Constructor

Initializes a new instance of the PREPProjectAdmin20 class.

public PREPProjectAdmin20();

See Also

PREPProjectAdmin20 Class | PREPWebPartLibrary20 Namespace

Generated from assembly PREPWebPartLibrary20 [2.0.0.0]


PREPProjectAdmin20 Methods

The methods of the PREPProjectAdmin20 class are listed below. For a complete list of PREPProjectAdmin20 class members, see the PREPProjectAdmin20 Members topic.

Public Instance Methods

AfterDeserialize (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
CanRunAt (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
CreateWebPartMenu (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
DataBind (inherited from Control) | Binds a data source to the invoked server control and all its child controls.
Dispose (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
EnsureInterfaces (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindControl (inherited from Control) | Overloaded. Searches the current naming container for a server control with the specified id parameter.
GetData (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
GetDesignTimeFooter (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
GetDesignTimeHeader (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetInitEventArgs (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
GetRequiresData (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
GetToolParts (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
GetType (inherited from Object) | Gets the Type of the current instance.
HasControls (inherited from Control) | Determines if the server control contains any child controls.
LoadResource (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
PartCacheInvalidate (inherited from Microsoft.SharePoint.WebPartPages.WebPart) | Overloaded.
PartCommunicationConnect (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
PartCommunicationInit (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
PartCommunicationMain (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
RenderControl (inherited from Control) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
ResolveUrl (inherited from Control) | Converts a URL into one that is usable on the requesting client.
SetRenderMethodDelegate (inherited from Control) |
ShouldSerializeAllowMinimize (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializeAllowRemove (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializeAllowZoneChange (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializeConnectionID (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializeConnections (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializeDescription (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializeDetailLink (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializeDir (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializeExportControlledProperties (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializeFrameState (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializeFrameType (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializeHeight (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializeHelpLink (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializeIsIncluded (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializeIsIncludedFilter (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializeIsVisible (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializeMissingAssembly (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializePartImageLarge (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializePartImageSmall (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializePartOrder (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializeTitle (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializeWidth (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializeZoneID (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

AddParsedSubObject (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
BuildProfileTree (inherited from Control) |
ClearChildViewState (inherited from Control) | Deletes the view-state information for all the server control's child controls.
CreateChildControls |
CreateControlCollection (inherited from Control) | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control.
EnsureChildControls (inherited from Control) | Determines whether the server control contains child controls. If it does not, it creates child controls.
Finalize (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
FindControl (inherited from Control) | Overloaded.
GetCustomBuilder (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
IsLiteralContent (inherited from Control) | Determines if the server control holds only literal content.
LoadViewState (inherited from Control) | Restores view-state information from a previous page request that was saved by the SaveViewState method.
MapPathSecure (inherited from Control) | Retrieves the physical path that a virtual path, either absolute or relative, maps to.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyWorkItemComplete (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
OnBubbleEvent (inherited from Control) | Determines whether the event for the server control is passed up the page's UI server control hierarchy.
OnDataBinding (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
OnInit |
OnLoad (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
OnPreRender (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
OnUnload (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
PartCacheInvalidate (inherited from Microsoft.SharePoint.WebPartPages.WebPart) | Overloaded.
PartCacheRead (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
PartCacheWrite (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
RaiseBubbleEvent (inherited from Control) | Assigns any sources of the event and its information to the control's parent.
RegisterInterface (inherited from Microsoft.SharePoint.WebPartPages.WebPart) | Overloaded.
RegisterWorkItem (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
RegisterWorkItemCallback (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
Render (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
RenderChildren (inherited from Control) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client.
RenderWebPart |
RenderWorkItemTimeout (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
SaveViewState (inherited from Control) | Saves any server control view-state changes that have occurred since the time the page was posted back to the server.
TrackViewState (inherited from Control) | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property.

Protected Internal Instance Methods

AddedControl (inherited from Control) | Called after a control is added to the Controls collection of another control.
RemovedControl (inherited from Control) | Called after a control is removed from the Controls collection of another control.
ReplaceTokens (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |

See Also

PREPProjectAdmin20 Class | PREPWebPartLibrary20 Namespace

Generated from assembly PREPWebPartLibrary20 [2.0.0.0]


PREPProjectAdmin20.CreateChildControls Method

protected override void CreateChildControls();

See Also

PREPProjectAdmin20 Class | PREPWebPartLibrary20 Namespace

Generated from assembly PREPWebPartLibrary20 [2.0.0.0]


PREPProjectAdmin20.OnInit Method

protected override void OnInit(
EventArgs e
);

See Also

PREPProjectAdmin20 Class | PREPWebPartLibrary20 Namespace

Generated from assembly PREPWebPartLibrary20 [2.0.0.0]


PREPProjectAdmin20.RenderWebPart Method

protected override void RenderWebPart(
HtmlTextWriter output
);

See Also

PREPProjectAdmin20 Class | PREPWebPartLibrary20 Namespace

Generated from assembly PREPWebPartLibrary20 [2.0.0.0]


RepeaterColumn Class

For a list of all members of this type, see RepeaterColumn Members.

System.Object
PREPWebPartLibrary20.RepeaterColumn

public class RepeaterColumn : ITemplate

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: PREPWebPartLibrary20

Assembly: PREPWebPartLibrary20 (in PREPWebPartLibrary20.dll)

See Also

RepeaterColumn Members | PREPWebPartLibrary20 Namespace

Generated from assembly PREPWebPartLibrary20 [2.0.0.0]


RepeaterColumn Members

RepeaterColumn overview

Public Instance Constructors

RepeaterColumn Constructor Initializes a new instance of the RepeaterColumn class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
InstantiateIn |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RepeaterColumn Class | PREPWebPartLibrary20 Namespace

Generated from assembly PREPWebPartLibrary20 [2.0.0.0]


RepeaterColumn Constructor

Initializes a new instance of the RepeaterColumn class.

public RepeaterColumn();

See Also

RepeaterColumn Class | PREPWebPartLibrary20 Namespace

Generated from assembly PREPWebPartLibrary20 [2.0.0.0]


RepeaterColumn Methods

The methods of the RepeaterColumn class are listed below. For a complete list of RepeaterColumn class members, see the RepeaterColumn Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
InstantiateIn |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RepeaterColumn Class | PREPWebPartLibrary20 Namespace

Generated from assembly PREPWebPartLibrary20 [2.0.0.0]


RepeaterColumn.InstantiateIn Method

public void InstantiateIn(
Control container
);

Implements

ITemplate.InstantiateIn

See Also

RepeaterColumn Class | PREPWebPartLibrary20 Namespace

Generated from assembly PREPWebPartLibrary20 [2.0.0.0]


RepeaterFooter Class

For a list of all members of this type, see RepeaterFooter Members.

System.Object
PREPWebPartLibrary20.RepeaterFooter

public class RepeaterFooter : ITemplate

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: PREPWebPartLibrary20

Assembly: PREPWebPartLibrary20 (in PREPWebPartLibrary20.dll)

See Also

RepeaterFooter Members | PREPWebPartLibrary20 Namespace

Generated from assembly PREPWebPartLibrary20 [2.0.0.0]


RepeaterFooter Members

RepeaterFooter overview

Public Instance Constructors

RepeaterFooter Constructor Initializes a new instance of the RepeaterFooter class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
InstantiateIn |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RepeaterFooter Class | PREPWebPartLibrary20 Namespace

Generated from assembly PREPWebPartLibrary20 [2.0.0.0]


RepeaterFooter Constructor

Initializes a new instance of the RepeaterFooter class.

public RepeaterFooter();

See Also

RepeaterFooter Class | PREPWebPartLibrary20 Namespace

Generated from assembly PREPWebPartLibrary20 [2.0.0.0]


RepeaterFooter Methods

The methods of the RepeaterFooter class are listed below. For a complete list of RepeaterFooter class members, see the RepeaterFooter Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
InstantiateIn |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RepeaterFooter Class | PREPWebPartLibrary20 Namespace

Generated from assembly PREPWebPartLibrary20 [2.0.0.0]


RepeaterFooter.InstantiateIn Method

public void InstantiateIn(
Control container
);

Implements

ITemplate.InstantiateIn

See Also

RepeaterFooter Class | PREPWebPartLibrary20 Namespace

Generated from assembly PREPWebPartLibrary20 [2.0.0.0]


RepeaterHeader Class

For a list of all members of this type, see RepeaterHeader Members.

System.Object
PREPWebPartLibrary20.RepeaterHeader

public class RepeaterHeader : ITemplate

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: PREPWebPartLibrary20

Assembly: PREPWebPartLibrary20 (in PREPWebPartLibrary20.dll)

See Also

RepeaterHeader Members | PREPWebPartLibrary20 Namespace

Generated from assembly PREPWebPartLibrary20 [2.0.0.0]


RepeaterHeader Members

RepeaterHeader overview

Public Instance Constructors

RepeaterHeader Constructor Initializes a new instance of the RepeaterHeader class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
InstantiateIn |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RepeaterHeader Class | PREPWebPartLibrary20 Namespace

Generated from assembly PREPWebPartLibrary20 [2.0.0.0]


RepeaterHeader Constructor

Initializes a new instance of the RepeaterHeader class.

public RepeaterHeader();

See Also

RepeaterHeader Class | PREPWebPartLibrary20 Namespace

Generated from assembly PREPWebPartLibrary20 [2.0.0.0]


RepeaterHeader Methods

The methods of the RepeaterHeader class are listed below. For a complete list of RepeaterHeader class members, see the RepeaterHeader Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
InstantiateIn |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RepeaterHeader Class | PREPWebPartLibrary20 Namespace

Generated from assembly PREPWebPartLibrary20 [2.0.0.0]


RepeaterHeader.InstantiateIn Method

public void InstantiateIn(
Control container
);

Implements

ITemplate.InstantiateIn

See Also

RepeaterHeader Class | PREPWebPartLibrary20 Namespace

Generated from assembly PREPWebPartLibrary20 [2.0.0.0]


UserAlerts Class

For a list of all members of this type, see UserAlerts Members.

System.Object
System.Web.UI.Control
Microsoft.SharePoint.WebPartPages.WebPart
PREPWebPartLibrary20.UserAlerts

public class UserAlerts : WebPart

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: PREPWebPartLibrary20

Assembly: PREPWebPartLibrary20 (in PREPWebPartLibrary20.dll)

See Also

UserAlerts Members | PREPWebPartLibrary20 Namespace

Generated from assembly PREPWebPartLibrary20 [2.0.0.0]


UserAlerts Members

UserAlerts overview

Public Instance Constructors

UserAlerts Constructor Initializes a new instance of the UserAlerts class.

Public Instance Properties

AllowMinimize (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
AllowRemove (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
AllowZoneChange (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
BindingContainer (inherited from Control) |
BrowserDesignMode (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
Caption (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ClientID (inherited from Control) | Gets the server control identifier generated by ASP.NET.
ClientName (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ConnectionID (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
Connections (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
Controls (inherited from Control) | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy.
Description (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
DetailLink (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
Dir (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
EffectiveFrameType (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
EffectiveStorage (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
EffectiveTitle (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
EnableViewState (inherited from Control) | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client.
ExportControlledProperties (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
FrameState (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
FrameType (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
Height (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
HelpLink (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ID (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
IsIncluded (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
IsIncludedFilter (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
IsVisible (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
MissingAssembly (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
NamingContainer (inherited from Control) | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value.
Page (inherited from Control) | Gets a reference to the Page instance that contains the server control.
Parent (inherited from Control) | Gets a reference to the server control's parent control in the page control hierarchy.
PartImageLarge (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
PartImageSmall (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
PartOrder (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
Permissions (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
Qualifier (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
Site (inherited from Control) | Gets information about the Web site to which the server control belongs.
StorageKey (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
TemplateSourceDirectory (inherited from Control) | Gets the virtual directory of the Page or UserControl that contains the current server control.
Title (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
UniqueID (inherited from Control) | Gets the unique, hierarchically-qualified identifier for the server control.
UnknownXmlElements (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
UseDefaultStyles (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
Visible (inherited from Control) | Gets or sets a value that indicates whether a server control is rendered as UI on the page.
Width (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ZoneID (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |

Public Instance Methods

AfterDeserialize (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
CanRunAt (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
CreateWebPartMenu (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
DataBind (inherited from Control) | Binds a data source to the invoked server control and all its child controls.
Dispose (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
EnsureInterfaces (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindControl (inherited from Control) | Overloaded. Searches the current naming container for a server control with the specified id parameter.
GetData (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
GetDesignTimeFooter (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
GetDesignTimeHeader (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetInitEventArgs (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
GetRequiresData (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
GetToolParts (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
GetType (inherited from Object) | Gets the Type of the current instance.
HasControls (inherited from Control) | Determines if the server control contains any child controls.
LoadResource (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
PartCacheInvalidate (inherited from Microsoft.SharePoint.WebPartPages.WebPart) | Overloaded.
PartCommunicationConnect (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
PartCommunicationInit (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
PartCommunicationMain (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
RenderControl (inherited from Control) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
ResolveUrl (inherited from Control) | Converts a URL into one that is usable on the requesting client.
SetRenderMethodDelegate (inherited from Control) |
ShouldSerializeAllowMinimize (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializeAllowRemove (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializeAllowZoneChange (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializeConnectionID (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializeConnections (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializeDescription (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializeDetailLink (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializeDir (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializeExportControlledProperties (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializeFrameState (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializeFrameType (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializeHeight (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializeHelpLink (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializeIsIncluded (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializeIsIncludedFilter (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializeIsVisible (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializeMissingAssembly (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializePartImageLarge (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializePartImageSmall (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializePartOrder (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializeTitle (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializeWidth (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializeZoneID (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

DataBinding (inherited from Control) | Occurs when the server control binds to a data source.
Disposed (inherited from Control) | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested.
Init (inherited from Control) | Occurs when the server control is initialized, which is the first step in the its lifecycle.
Load (inherited from Control) | Occurs when the server control is loaded into the Page object.
PreRender (inherited from Control) | Occurs when the server control is about to render to its containing Page object.
Unload (inherited from Control) | Occurs when the server control is unloaded from memory.

Protected Instance Properties

CacheType (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ChildControlsCreated (inherited from Control) | Gets a value that indicates whether the server control's child controls have been created.
ClassResourcePath (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ContainerWidth (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
Context (inherited from Control) | Gets the HttpContext object associated with the server control for the current Web request.
Events (inherited from Control) | Gets a list of event handler delegates for the control. This property is read-only.
HasChildViewState (inherited from Control) | Gets a value indicating whether the current server control's child controls have any saved view-state settings.
IsTrackingViewState (inherited from Control) | Gets a value that indicates whether the server control is saving changes to its view state.
OverflowAuto (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
SerializeAll (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ViewState (inherited from Control) | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page.
ViewStateIgnoresCase (inherited from Control) | Gets a value that indicates whether the StateBag object is case-insensitive.
WorkItemTimeout (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |

Protected Instance Methods

AddParsedSubObject (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
BuildProfileTree (inherited from Control) |
ClearChildViewState (inherited from Control) | Deletes the view-state information for all the server control's child controls.
CreateChildControls |
CreateControlCollection (inherited from Control) | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control.
EnsureChildControls (inherited from Control) | Determines whether the server control contains child controls. If it does not, it creates child controls.
Finalize (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
FindControl (inherited from Control) | Overloaded.
GetCustomBuilder (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
IsLiteralContent (inherited from Control) | Determines if the server control holds only literal content.
LoadViewState (inherited from Control) | Restores view-state information from a previous page request that was saved by the SaveViewState method.
MapPathSecure (inherited from Control) | Retrieves the physical path that a virtual path, either absolute or relative, maps to.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyWorkItemComplete (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
OnBubbleEvent (inherited from Control) | Determines whether the event for the server control is passed up the page's UI server control hierarchy.
OnDataBinding (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
OnInit (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
OnLoad (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
OnPreRender (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
OnUnload (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
PartCacheInvalidate (inherited from Microsoft.SharePoint.WebPartPages.WebPart) | Overloaded.
PartCacheRead (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
PartCacheWrite (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
RaiseBubbleEvent (inherited from Control) | Assigns any sources of the event and its information to the control's parent.
RegisterInterface (inherited from Microsoft.SharePoint.WebPartPages.WebPart) | Overloaded.
RegisterWorkItem (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
RegisterWorkItemCallback (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
Render (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
RenderChildren (inherited from Control) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client.
RenderWebPart |
RenderWorkItemTimeout (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
SaveViewState (inherited from Control) | Saves any server control view-state changes that have occurred since the time the page was posted back to the server.
TrackViewState (inherited from Control) | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property.

Protected Internal Instance Properties

SaveProperties (inherited from Microsoft.SharePoint.WebPartPages.WebPart)
ShouldValidate (inherited from Microsoft.SharePoint.WebPartPages.WebPart)
WebPartMenu (inherited from Microsoft.SharePoint.WebPartPages.WebPart)

Protected Internal Instance Methods

AddedControl (inherited from Control) | Called after a control is added to the Controls collection of another control.
RemovedControl (inherited from Control) | Called after a control is removed from the Controls collection of another control.
ReplaceTokens (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |

See Also

UserAlerts Class | PREPWebPartLibrary20 Namespace

Generated from assembly PREPWebPartLibrary20 [2.0.0.0]


UserAlerts Constructor

Initializes a new instance of the UserAlerts class.

public UserAlerts();

See Also

UserAlerts Class | PREPWebPartLibrary20 Namespace

Generated from assembly PREPWebPartLibrary20 [2.0.0.0]


UserAlerts Methods

The methods of the UserAlerts class are listed below. For a complete list of UserAlerts class members, see the UserAlerts Members topic.

Public Instance Methods

AfterDeserialize (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
CanRunAt (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
CreateWebPartMenu (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
DataBind (inherited from Control) | Binds a data source to the invoked server control and all its child controls.
Dispose (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
EnsureInterfaces (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindControl (inherited from Control) | Overloaded. Searches the current naming container for a server control with the specified id parameter.
GetData (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
GetDesignTimeFooter (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
GetDesignTimeHeader (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetInitEventArgs (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
GetRequiresData (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
GetToolParts (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
GetType (inherited from Object) | Gets the Type of the current instance.
HasControls (inherited from Control) | Determines if the server control contains any child controls.
LoadResource (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
PartCacheInvalidate (inherited from Microsoft.SharePoint.WebPartPages.WebPart) | Overloaded.
PartCommunicationConnect (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
PartCommunicationInit (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
PartCommunicationMain (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
RenderControl (inherited from Control) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
ResolveUrl (inherited from Control) | Converts a URL into one that is usable on the requesting client.
SetRenderMethodDelegate (inherited from Control) |
ShouldSerializeAllowMinimize (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializeAllowRemove (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializeAllowZoneChange (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializeConnectionID (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializeConnections (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializeDescription (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializeDetailLink (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializeDir (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializeExportControlledProperties (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializeFrameState (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializeFrameType (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializeHeight (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializeHelpLink (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializeIsIncluded (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializeIsIncludedFilter (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializeIsVisible (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializeMissingAssembly (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializePartImageLarge (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializePartImageSmall (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializePartOrder (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializeTitle (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializeWidth (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ShouldSerializeZoneID (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

AddParsedSubObject (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
BuildProfileTree (inherited from Control) |
ClearChildViewState (inherited from Control) | Deletes the view-state information for all the server control's child controls.
CreateChildControls |
CreateControlCollection (inherited from Control) | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control.
EnsureChildControls (inherited from Control) | Determines whether the server control contains child controls. If it does not, it creates child controls.
Finalize (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
FindControl (inherited from Control) | Overloaded.
GetCustomBuilder (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
IsLiteralContent (inherited from Control) | Determines if the server control holds only literal content.
LoadViewState (inherited from Control) | Restores view-state information from a previous page request that was saved by the SaveViewState method.
MapPathSecure (inherited from Control) | Retrieves the physical path that a virtual path, either absolute or relative, maps to.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyWorkItemComplete (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
OnBubbleEvent (inherited from Control) | Determines whether the event for the server control is passed up the page's UI server control hierarchy.
OnDataBinding (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
OnInit (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
OnLoad (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
OnPreRender (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
OnUnload (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
PartCacheInvalidate (inherited from Microsoft.SharePoint.WebPartPages.WebPart) | Overloaded.
PartCacheRead (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
PartCacheWrite (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
RaiseBubbleEvent (inherited from Control) | Assigns any sources of the event and its information to the control's parent.
RegisterInterface (inherited from Microsoft.SharePoint.WebPartPages.WebPart) | Overloaded.
RegisterWorkItem (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
RegisterWorkItemCallback (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
Render (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
RenderChildren (inherited from Control) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client.
RenderWebPart |
RenderWorkItemTimeout (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |
SaveViewState (inherited from Control) | Saves any server control view-state changes that have occurred since the time the page was posted back to the server.
TrackViewState (inherited from Control) | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property.

Protected Internal Instance Methods

AddedControl (inherited from Control) | Called after a control is added to the Controls collection of another control.
RemovedControl (inherited from Control) | Called after a control is removed from the Controls collection of another control.
ReplaceTokens (inherited from Microsoft.SharePoint.WebPartPages.WebPart) |

See Also

UserAlerts Class | PREPWebPartLibrary20 Namespace

Generated from assembly PREPWebPartLibrary20 [2.0.0.0]


UserAlerts.CreateChildControls Method

protected override void CreateChildControls();

See Also

UserAlerts Class | PREPWebPartLibrary20 Namespace

Generated from assembly PREPWebPartLibrary20 [2.0.0.0]


UserAlerts.RenderWebPart Method

protected override void RenderWebPart(
HtmlTextWriter output
);

See Also

UserAlerts Class | PREPWebPartLibrary20 Namespace

Generated from assembly PREPWebPartLibrary20 [2.0.0.0]


PREPWorkflow

SharePoint PREP 2.0

PREPWorkflow Namespace

Namespace hierarchy

Classes

Class | Description
BaseEventSink | Base class for cached event sinks. Handles impersonation and caching event sink classes to handle multiple events on the same list. This class is part of the Windows SharePoint Services SDK Code Samples. Copyright (C) Microsoft Corporation. All rights reserved.
HTMLTools | Building blocks for manual HTML construction.
PREPAssignment | Class which represents a PREP Assignment. A PREP Assignment is persisted in SharePoint as three Events on the Events List: Assignment Given, Ideas Due, and Reviews Due.
PREPDocument | Class which represents a PREP Document.
PREPEventSink | The main class for the PREP Event Handler
PREPFields | Class which standardizes the string representation of various PREP fields
PREPImpersonation | Allows code to impersonate a Windows user that is different from the logged-in user. Typically this is used to execute code that requires a higher level of privilege than the user posesses (e.g. somethine that requires an Administrator).
PREPRole | Custom SPRole object for PREP. Each PREP Assignment has a custom role, with the same name, which contains the set of users who are included in the assignment. This class is a workaround to address the problem where the SharePoint Object Model only allows Administrator access to the SPRole object. This problem cannot be addressed through impersonation because SharePoint only considers the original user context when evaluating security for SPRole. This class is intended only for non-administrators to be able to read the user collections in the role object (e.g., in the PREP Matrix). Therefore, there are no add or update methods. These will be done using the normal SPRole object by an administrator.
PREPTask | Class which represents a PREP Task
PREPUploadDownloadHandler | This handler intercepts clicks from the PREPWebPartMatrix Web Part. Depending on the context (user and document), it will download or upload a document.
Utilities | Utility class containing methods to log errors, send email, encrypt and decrypt strings, manipulate strings, etc.

Structures

Structure | Description
PREPDocument.DocInfo | Structure which contains information about a PREP Document.


BaseEventSink Class

Base class for cached event sinks. Handles impersonation and caching event sink classes to handle multiple events on the same list. This class is part of the Windows SharePoint Services SDK Code Samples. Copyright (C) Microsoft Corporation. All rights reserved.

For a list of all members of this type, see BaseEventSink Members.

System.Object
PREPWorkflow.BaseEventSink
PREPWorkflow.PREPEventSink

public abstract class BaseEventSink : IListEventSink

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: PREPWorkflow

Assembly: PREPWorkflow (in PREPWorkflow.dll)

See Also

BaseEventSink Members | PREPWorkflow Namespace

Generated from assembly PREPWorkflow [2.0.0.0]


BaseEventSink Members

BaseEventSink overview

Public Static Methods

CreateIdentity Helper method to handle creating a WindowsIdentity object from a username / domain / password.

Protected Static Fields

SinkCache SinkCache

Public Instance Constructors

BaseEventSink Constructor Default Constructor

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
OnEvent | Implementation of the OnEvent method. Windows SharePoint Services will call this method when an event occurs.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Fields

m_ListEvent Cached List Event

Protected Instance Properties

Data | Sink Data
EventFileUrl | The url of the file the event occured on. Equals UrlAfter if UrlAfter is not empty. Otherwise equals UrlBefore.
EventInfo | The SPListEvent object that describes the current event.
EventList | The SPList object for the list the event occured on.
EventWeb | The SPWeb object for the web site that contains the list that the event occured on.
HandlerIdentity | The WindowsIdentity class of the identity the Event Sink should impersonate.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
HandleEvent | HandleEvent is called when an event occurs. Child classes should perform the main event handling actions here.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BaseEventSink Class | PREPWorkflow Namespace


BaseEventSink Constructor

Default Constructor

public BaseEventSink();

See Also

BaseEventSink Class | PREPWorkflow Namespace


BaseEventSink Fields

The fields of the BaseEventSink class are listed below. For a complete list of BaseEventSink class members, see the BaseEventSink Members topic.

Protected Static Fields

SinkCache SinkCache

Protected Instance Fields

m_ListEvent Cached List Event

See Also

BaseEventSink Class | PREPWorkflow Namespace


BaseEventSink.m_ListEvent Field

Cached List Event

protected SPListEvent m_ListEvent;

See Also

BaseEventSink Class | PREPWorkflow Namespace


BaseEventSink.SinkCache Field

SinkCache

protected static Hashtable SinkCache;

See Also

BaseEventSink Class | PREPWorkflow Namespace


BaseEventSink Properties

The properties of the BaseEventSink class are listed below. For a complete list of BaseEventSink class members, see the BaseEventSink Members topic.

Protected Instance Properties

Data | Sink Data
EventFileUrl | The url of the file the event occured on. Equals UrlAfter if UrlAfter is not empty. Otherwise equals UrlBefore.
EventInfo | The SPListEvent object that describes the current event.
EventList | The SPList object for the list the event occured on.
EventWeb | The SPWeb object for the web site that contains the list that the event occured on.
HandlerIdentity | The WindowsIdentity class of the identity the Event Sink should impersonate.

See Also

BaseEventSink Class | PREPWorkflow Namespace


BaseEventSink.Data Property

Sink Data

protected string Data {get;}

See Also

BaseEventSink Class | PREPWorkflow Namespace


BaseEventSink.EventFileUrl Property

The url of the file the event occured on. Equals UrlAfter if UrlAfter is not empty. Otherwise equals UrlBefore.

protected string EventFileUrl {get;}

See Also

BaseEventSink Class | PREPWorkflow Namespace


BaseEventSink.EventInfo Property

The SPListEvent object that describes the current event.

protected virtual Microsoft.SharePoint.SPListEvent EventInfo {get; set;}

See Also

BaseEventSink Class | PREPWorkflow Namespace


BaseEventSink.EventList Property

The SPList object for the list the event occured on.

protected virtual Microsoft.SharePoint.SPList EventList {get;}

See Also

BaseEventSink Class | PREPWorkflow Namespace


BaseEventSink.EventWeb Property

The SPWeb object for the web site that contains the list that the event occured on.

protected virtual Microsoft.SharePoint.SPWeb EventWeb {get;}

See Also

BaseEventSink Class | PREPWorkflow Namespace


BaseEventSink.HandlerIdentity Property

The WindowsIdentity class of the identity the Event Sink should impersonate.

protected virtual System.Security.Principal.WindowsIdentity HandlerIdentity {get;}

See Also

BaseEventSink Class | PREPWorkflow Namespace


BaseEventSink Methods

The methods of the BaseEventSink class are listed below. For a complete list of BaseEventSink class members, see the BaseEventSink Members topic.

Public Static Methods

CreateIdentity Helper method to handle creating a WindowsIdentity object from a username / domain / password.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
OnEvent | Implementation of the OnEvent method. Windows SharePoint Services will call this method when an event occurs.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
HandleEvent | HandleEvent is called when an event occurs. Child classes should perform the main event handling actions here.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BaseEventSink Class | PREPWorkflow Namespace


BaseEventSink.CreateIdentity Method

Helper method to handle creating a WindowsIdentity object from a username / domain / password.

public static WindowsIdentity CreateIdentity(
string User,
string Domain,
string Password
);

Parameters

User
The username of the account to impersonate.
Domain
The domain of the account to impersonate.
Password
The password of the account to impersonate.

Return Value

See Also

BaseEventSink Class | PREPWorkflow Namespace


BaseEventSink.HandleEvent Method

HandleEvent is called when an event occurs. Child classes should perform the main event handling actions here.

protected abstract void HandleEvent();

See Also

BaseEventSink Class | PREPWorkflow Namespace


BaseEventSink.OnEvent Method

Implementation of the OnEvent method. Windows SharePoint Services will call this method when an event occurs.

public virtual void OnEvent(
SPListEvent listEvent
);

Parameters

listEvent
The SPListEvent object that describes the event which occured.

Implements

IListEventSink.OnEvent

See Also

BaseEventSink Class | PREPWorkflow Namespace


HTMLTools Class

Building blocks for manual HTML construction.

For a list of all members of this type, see HTMLTools Members.

System.Object
PREPWorkflow.HTMLTools

public class HTMLTools

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: PREPWorkflow

Assembly: PREPWorkflow (in PREPWorkflow.dll)

See Also

HTMLTools Members | PREPWorkflow Namespace


HTMLTools Members

HTMLTools overview

Public Static Methods

Break | Creates a line break (BR)
Comment | Creates an HTML comment
EmptyLine | Creates an empty paragraph.
EndBody | Ends the body of a page
EndCol | Ends a table column
EndForm | Ends a FORM tag
EndHead | Ends a HEAD tag
EndPage | Ends an HTML page
EndRow | Ends a table row
EndSpan | Ends a SPAN tag
EndStyle | Ends a STYLE tag
EndTable | Ends a Table.
HorozontalRule | Overloaded. Creates a horozontal rule (HR)
Image | Emits an image tag
Input | Outputs an INPUT tag with attributes.
Literal | Outputs literal text with a line break
StartBody | Overloaded. Begins the body of a page (BODY)
StartCol | Overloaded. Starts a table column
StartForm | Creates a FORM tag with attributes
StartHead | Begins a HEAD tag
StartPage | Begins an HTML page
StartRow | Overloaded. Starts a table row, with no attributes
StartSpan | Creates a Span tag (SPAN) with attributes
StartStyle | Begins a STYLE tag
StartTable | Overloaded. Begins a table
Title | Outputs a TITLE tag

Public Instance Constructors

HTMLTools Constructor Default Constructor

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

HTMLTools Class | PREPWorkflow Namespace


HTMLTools Constructor

Default Constructor

public HTMLTools();

See Also

HTMLTools Class | PREPWorkflow Namespace


HTMLTools Methods

The methods of the HTMLTools class are listed below. For a complete list of HTMLTools class members, see the HTMLTools Members topic.

Public Static Methods

Break | Creates a line break (BR)
Comment | Creates an HTML comment
EmptyLine | Creates an empty paragraph.
EndBody | Ends the body of a page
EndCol | Ends a table column
EndForm | Ends a FORM tag
EndHead | Ends a HEAD tag
EndPage | Ends an HTML page
EndRow | Ends a table row
EndSpan | Ends a SPAN tag
EndStyle | Ends a STYLE tag
EndTable | Ends a Table.
HorozontalRule | Overloaded. Creates a horozontal rule (HR)
Image | Emits an image tag
Input | Outputs an INPUT tag with attributes.
Literal | Outputs literal text with a line break
StartBody | Overloaded. Begins the body of a page (BODY)
StartCol | Overloaded. Starts a table column
StartForm | Creates a FORM tag with attributes
StartHead | Begins a HEAD tag
StartPage | Begins an HTML page
StartRow | Overloaded. Starts a table row, with no attributes
StartSpan | Creates a Span tag (SPAN) with attributes
StartStyle | Begins a STYLE tag
StartTable | Overloaded. Begins a table
Title | Outputs a TITLE tag

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

HTMLTools Class | PREPWorkflow Namespace


HTMLTools.Break Method

Creates a line break (BR)

public static string Break();

Return Value

See Also

HTMLTools Class | PREPWorkflow Namespace


HTMLTools.Comment Method

Creates an HTML comment

public static string Comment(
string commentText
);

Return Value

See Also

HTMLTools Class | PREPWorkflow Namespace


HTMLTools.EmptyLine Method

Creates an empty paragraph.

public static string EmptyLine();

Return Value

See Also

HTMLTools Class | PREPWorkflow Namespace


HTMLTools.EndBody Method

Ends the body of a page

public static string EndBody();

Return Value

See Also

HTMLTools Class | PREPWorkflow Namespace


HTMLTools.EndCol Method

Ends a table column

public static string EndCol();

Return Value

See Also

HTMLTools Class | PREPWorkflow Namespace


HTMLTools.EndForm Method

Ends a FORM tag

public static string EndForm();

Return Value

See Also

HTMLTools Class | PREPWorkflow Namespace


HTMLTools.EndHead Method

Ends a HEAD tag

public static string EndHead();

Return Value

See Also

HTMLTools Class | PREPWorkflow Namespace


HTMLTools.EndPage Method

Ends an HTML page

public static string EndPage();

Return Value

See Also

HTMLTools Class | PREPWorkflow Namespace


HTMLTools.EndRow Method

Ends a table row

public static string EndRow();

Return Value

See Also

HTMLTools Class | PREPWorkflow Namespace


HTMLTools.EndSpan Method

Ends a SPAN tag

public static string EndSpan();

Return Value

See Also

HTMLTools Class | PREPWorkflow Namespace


HTMLTools.EndStyle Method

Ends a STYLE tag

public static string EndStyle();

Return Value

See Also

HTMLTools Class | PREPWorkflow Namespace


HTMLTools.EndTable Method

Ends a Table.

public static string EndTable();

Return Value

See Also

HTMLTools Class | PREPWorkflow Namespace


HorozontalRule Method

SharePoint PREP 2.0

HTMLTools.HorozontalRule Method

Creates a horozontal rule (HR)

Overload List

Creates a horozontal rule (HR)

public static string HorozontalRule();

Creates a horozontal rule (HR) with attributes

public static string HorozontalRule(string);

See Also

HTMLTools Class | PREPWorkflow Namespace


HTMLTools.HorozontalRule Method ()

Creates a horozontal rule (HR)

public static string HorozontalRule();

Return Value

See Also

HTMLTools Class | PREPWorkflow Namespace | HTMLTools.HorozontalRule Overload List


HTMLTools.HorozontalRule Method (String)

Creates a horozontal rule (HR) with attributes

public static string HorozontalRule(
string attrs
);

Return Value

See Also

HTMLTools Class | PREPWorkflow Namespace | HTMLTools.HorozontalRule Overload List


HTMLTools.Image Method

Emits an image tag

public static string Image(
string imgSrc,
string altTag
);

Parameters

imgSrc
File name w/o path (path is handled in the method)
altTag
Alt text for the image

Return Value

See Also

HTMLTools Class | PREPWorkflow Namespace


HTMLTools.Input Method

Outputs an INPUT tag with attributes.

public static string Input(
string attrs
);

Parameters

attrs
Attributes for the INPUT tag

Return Value

See Also

HTMLTools Class | PREPWorkflow Namespace


HTMLTools.Literal Method

Outputs literal text with a line break

public static string Literal(
string literalText
);

Return Value

See Also

HTMLTools Class | PREPWorkflow Namespace


StartBody Method

SharePoint PREP 2.0

HTMLTools.StartBody Method

Begins the body of a page (BODY)

Overload List

Begins the body of a page (BODY)

public static string StartBody();

Begins the body of a page (BODY)

public static string StartBody(string);

See Also

HTMLTools Class | PREPWorkflow Namespace


HTMLTools.StartBody Method ()

Begins the body of a page (BODY)

public static string StartBody();

Return Value

See Also

HTMLTools Class | PREPWorkflow Namespace | HTMLTools.StartBody Overload List


HTMLTools.StartBody Method (String)

Begins the body of a page (BODY)

public static string StartBody(
string attrs
);

Parameters

attrs
Attributes for the BODY tag

Return Value

See Also

HTMLTools Class | PREPWorkflow Namespace | HTMLTools.StartBody Overload List


StartCol Method

SharePoint PREP 2.0

HTMLTools.StartCol Method

Starts a table column, with no attributes

Overload List

Starts a table column, with no attributes

public static string StartCol();

Starts a table column

public static string StartCol(string);

See Also

HTMLTools Class | PREPWorkflow Namespace


HTMLTools.StartCol Method ()

Starts a table column, with no attributes

public static string StartCol();

Return Value

See Also

HTMLTools Class | PREPWorkflow Namespace | HTMLTools.StartCol Overload List


HTMLTools.StartCol Method (String)

Starts a table column

public static string StartCol(
string attrs
);

Parameters

attrs
Attributes for the TD tag

Return Value

See Also

HTMLTools Class | PREPWorkflow Namespace | HTMLTools.StartCol Overload List


HTMLTools.StartForm Method

Creates a FORM tag with attributes

public static string StartForm(
string method,
string action
);

Parameters

method
The method: POST or GET
action
The target URL of the FORM post

Return Value

See Also

HTMLTools Class | PREPWorkflow Namespace


HTMLTools.StartHead Method

Begins a HEAD tag

public static string StartHead();

Return Value

See Also

HTMLTools Class | PREPWorkflow Namespace


HTMLTools.StartPage Method

Begins an HTML page

public static string StartPage();

Return Value

See Also

HTMLTools Class | PREPWorkflow Namespace


StartRow Method

SharePoint PREP 2.0

HTMLTools.StartRow Method

Starts a table row, with no attributes

Overload List

Starts a table row, with no attributes

public static string StartRow();

Begins a Table Row

public static string StartRow(string);

See Also

HTMLTools Class | PREPWorkflow Namespace


HTMLTools.StartRow Method ()

Starts a table row, with no attributes

public static string StartRow();

Return Value

See Also

HTMLTools Class | PREPWorkflow Namespace | HTMLTools.StartRow Overload List


HTMLTools.StartRow Method (String)

Begins a Table Row

public static string StartRow(
string attrs
);

Parameters

attrs
Attributes for the TR tag

Return Value

See Also

HTMLTools Class | PREPWorkflow Namespace | HTMLTools.StartRow Overload List


HTMLTools.StartSpan Method

Creates a Span tag (SPAN) with attributes

public static string StartSpan(
string attrs
);

Return Value

See Also

HTMLTools Class | PREPWorkflow Namespace


HTMLTools.StartStyle Method

Begins a STYLE tag

public static string StartStyle();

Return Value

See Also

HTMLTools Class | PREPWorkflow Namespace


StartTable Method

SharePoint PREP 2.0

HTMLTools.StartTable Method

Begins a table

Overload List

Begins a table

public static string StartTable();

Begins a table

public static string StartTable(string);

See Also

HTMLTools Class | PREPWorkflow Namespace


HTMLTools.StartTable Method ()

Begins a table

public static string StartTable();

Return Value

See Also

HTMLTools Class | PREPWorkflow Namespace | HTMLTools.StartTable Overload List


HTMLTools.StartTable Method (String)

Begins a table

public static string StartTable(
string attrs
);

Parameters

attrs
Attributes for the TABLE tag

Return Value

See Also

HTMLTools Class | PREPWorkflow Namespace | HTMLTools.StartTable Overload List


HTMLTools.Title Method

Outputs a TITLE tag

public static string Title(
string titleText
);

Return Value

See Also

HTMLTools Class | PREPWorkflow Namespace


PREPAssignment Class

Class which represents a PREP Assignment. A PREP Assignment is persisted in SharePoint as three Events on the Events List: Assignment Given, Ideas Due, and Reviews Due.

For a list of all members of this type, see PREPAssignment Members.

System.Object
PREPWorkflow.PREPAssignment

public class PREPAssignment

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: PREPWorkflow

Assembly: PREPWorkflow (in PREPWorkflow.dll)

See Also

PREPAssignment Members | PREPWorkflow Namespace


PREPAssignment Members

PREPAssignment overview

Public Static Methods

Create | Creates a PREP Assignment and returns the number of Events that were created. A PREP Assignment consists of three Events on the Events List: Assignment Given, Ideas Due, and Reviews Due.
Delete | Deletes a PREP Assignment and returns the number of Events that were deleted. A PREP Assignment consists of three Events on the Events List: Assignment Given, Ideas Due, and Reviews Due.
IsComplete | Loops through the PREP Tasks associated with an assignment, and returns true if all tasks are completed.
PREPAssignment_Collection | Returns an ArrayList of PREPAssignment objects representing all of the valid PREP Assignments for this site. These objects are created by reading the Events list, looking for PREP Assignment events. PREP Assignment events are identified by having a value in the Assignment Name field.
StatusReport | Dumps the title and status of all tasks related to an assignment.

Public Instance Constructors

PREPAssignment Overloaded. Initializes a new instance of the PREPAssignment class.

Public Instance Properties

AssignedDate | Date this PREP Assignment begins.
AssignmentName | The PREP Assignment name
Description | PREP Assignment description.
HasData | Returns true if there are any tasks or documents associated with this PREP Assignment.
IdeasDueDate | Date on which an Ideas document is due for this PREP Assignment.
ReviewsDueDate | Date on which the Review documents are due for this PREP Assignment.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PREPAssignment Class | PREPWorkflow Namespace


PREPAssignment Constructor

Default constructor

Overload List

Default constructor

public PREPAssignment();

Constructor which populates a PREPAssignment object by doing a lookup on a persisted assignment using the assignment name.

public PREPAssignment(SPWeb,string);

See Also

PREPAssignment Class | PREPWorkflow Namespace


PREPAssignment Constructor ()

Default constructor

public PREPAssignment();

See Also

PREPAssignment Class | PREPWorkflow Namespace | PREPAssignment Constructor Overload List


PREPAssignment Constructor (SPWeb, String)

Constructor which populates a PREPAssignment object by doing a lookup on a persisted assignment using the assignment name.

public PREPAssignment(
SPWeb PREPWeb,
string PREPAssignment_Key
);

Parameters

PREPWeb
The SharePoint Web object
PREPAssignment_Key
The key is the assignment name

See Also

PREPAssignment Class | PREPWorkflow Namespace | PREPAssignment Constructor Overload List


PREPAssignment Properties

The properties of the PREPAssignment class are listed below. For a complete list of PREPAssignment class members, see the PREPAssignment Members topic.

Public Instance Properties

AssignedDate | Date this PREP Assignment begins.
AssignmentName | The PREP Assignment name
Description | PREP Assignment description.
HasData | Returns true if there are any tasks or documents associated with this PREP Assignment.
IdeasDueDate | Date on which an Ideas document is due for this PREP Assignment.
ReviewsDueDate | Date on which the Review documents are due for this PREP Assignment.

See Also

PREPAssignment Class | PREPWorkflow Namespace


PREPAssignment.AssignedDate Property

Date this PREP Assignment begins.

public System.DateTime AssignedDate {get; set;}

See Also

PREPAssignment Class | PREPWorkflow Namespace


PREPAssignment.AssignmentName Property

The PREP Assignment name

public string AssignmentName {get; set;}

See Also

PREPAssignment Class | PREPWorkflow Namespace


PREPAssignment.Description Property

PREP Assignment description.

public string Description {get; set;}

See Also

PREPAssignment Class | PREPWorkflow Namespace


PREPAssignment.HasData Property

Returns true if there are any tasks or documents associated with this PREP Assignment.

public bool HasData {get; set;}

See Also

PREPAssignment Class | PREPWorkflow Namespace


PREPAssignment.IdeasDueDate Property

Date on which an Ideas document is due for this PREP Assignment.

public System.DateTime IdeasDueDate {get; set;}

See Also

PREPAssignment Class | PREPWorkflow Namespace


PREPAssignment.ReviewsDueDate Property

Date on which the Review documents are due for this PREP Assignment.

public System.DateTime ReviewsDueDate {get; set;}

See Also

PREPAssignment Class | PREPWorkflow Namespace


PREPAssignment Methods

The methods of the PREPAssignment class are listed below. For a complete list of PREPAssignment class members, see the PREPAssignment Members topic.

Public Static Methods

Create | Creates a PREP Assignment and returns the number of Events that were created. A PREP Assignment consists of three Events on the Events List: Assignment Given, Ideas Due, and Reviews Due.
Delete | Deletes a PREP Assignment and returns the number of Events that were deleted. A PREP Assignment consists of three Events on the Events List: Assignment Given, Ideas Due, and Reviews Due.
IsComplete | Loops through the PREP Tasks associated with an assignment, and returns true if all tasks are completed.
PREPAssignment_Collection | Returns an ArrayList of PREPAssignment objects representing all of the valid PREP Assignments for this site. These objects are created by reading the Events list, looking for PREP Assignment events. PREP Assignment events are identified by having a value in the Assignment Name field.
StatusReport | Dumps the title and status of all tasks related to an assignment.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PREPAssignment Class | PREPWorkflow Namespace


PREPAssignment.Create Method

Creates a PREP Assignment and returns the number of Events that were created. A PREP Assignment consists of three Events on the Events List: Assignment Given, Ideas Due, and Reviews Due.

public static int Create(
SPWeb web,
PREPAssignment assignment
);

Return Value

The number of Events that were created.

See Also

PREPAssignment Class | PREPWorkflow Namespace


PREPAssignment.Delete Method

Deletes a PREP Assignment and returns the number of Events that were deleted. A PREP Assignment consists of three Events on the Events List: Assignment Given, Ideas Due, and Reviews Due.

public static int Delete(
SPWeb web,
string assignmentName
);

Return Value

The number of Events that were deleted.

See Also

PREPAssignment Class | PREPWorkflow Namespace


PREPAssignment.IsComplete Method

Loops through the PREP Tasks associated with an assignment, and returns true if all tasks are completed.

public static bool IsComplete(
SPWeb PREPWeb,
string assignmentName
);

Return Value

true if the assignment is complete for all users.

See Also

PREPAssignment Class | PREPWorkflow Namespace


PREPAssignment.PREPAssignment_Collection Method

Returns an ArrayList of PREPAssignment objects representing all of the valid PREP Assignments for this site. These objects are created by reading the Events list, looking for PREP Assignment events. PREP Assignment events are identified by having a value in the Assignment Name field.

public static ArrayList PREPAssignment_Collection(
SPWeb web
);

Parameters

web
The current SharePoint web

Return Value

See Also

PREPAssignment Class | PREPWorkflow Namespace


PREPAssignment.StatusReport Method

Dumps the title and status of all tasks related to an assignment.

public static string StatusReport(
SPWeb PREPWeb,
string assignmentName,
string newLine
);

Parameters

PREPWeb
A SharePoint SPWeb (site) object set to the current site context.
assignmentName
The PREP Assignment name.
newLine
The newline character. Use a br tag for html pages, Environment.Newline for emails.

Return Value

See Also

PREPAssignment Class | PREPWorkflow Namespace


PREPDocument Class

Class which represents a PREP Document.

For a list of all members of this type, see PREPDocument Members.

System.Object
PREPWorkflow.PREPDocument

public class PREPDocument

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: PREPWorkflow

Assembly: PREPWorkflow (in PREPWorkflow.dll)

See Also

PREPDocument Members | PREPWorkflow Namespace


PREPDocument Members

PREPDocument overview

Public Static Methods

GetDocInfoFromURL | Takes a URL and returns a DocInfo object. This object breaks the URL out into the parts of the DocInfo object: IdeasAuthorLoginName, AssignmentName, and FileName. Additionally, there is a boolean IsValid which is set to false if the URL is not in the proper format. It does not check the validity of any of the data (i.e. it doesn't know if the user does not exist or the assignment name does not exist).
GetIdeasDoc | Returns the PREP Document object representing the Ideas Document for a given user (passed in as userLoginName) for a given assignment (assignmentName). If no such document can be found, Boolean field Exists is set to false.
GetReviewDoc | Returns the PREP Document object representing the Review Document for a given reviewer (reviewAuthorLoginName), reviewing the ideas of a given author (ideasAuthorLoginName), for a given assignment (assignmentName). If no such document can be found, Boolean field Exists is set to false.
IsNewPREPDocument | Returns true if the author of the passed-in file does not already have a PREP file in the current folder. Used in the Event Handler to make sure that each user has only one PREP document in a given folder.
IsPREPFolder | Validates the following: 1) The folder structure is in the correct format (PREP Documents/userName/assignmentName) 2) The assignment exists 3) The userName exists 4) The userName belongs to the assignment
PREPDocument_Collection | Returns an ArrayList of all PREPDocument objects in a folder.

Public Instance Constructors

PREPDocument Overloaded. Initializes a new instance of the PREPDocument class.

Public Instance Properties

AssignmentName | The PREP Assignment name
DocType | The PREP Document Type. May be one of two values: Ideas or Review.
EventUserLogin | Login Name of the user whose action triggered the event on the document library
EventUserName | Display Name of the user whose action triggered the event on the document library
Exists | True if a document exists for a given user and assignment.
FileName | The file name of the PREP document that triggered the event
Folder | The folder where the document resides (e.g. PREPDocuments/UserID/AssignmentName)
IdeasAuthorLogin | Login Name of the author of the ideas document that this document pertains to
PREP | PREP Bit. If True, this is a PREP Document. if PREP == true AND the document author userID == the folder name, it is an ideas document. if PREP == true AND the document author userID != the folder name, it is a review. if PREP == false, it is an extra document uploaded to the folder.
SPFileObject | The complete SPFile object

Public Instance Methods

CopyToNewName | Copies the current document to a new name based on a passed-in identifier. New file name will be in the form "originalfileName_identifier_random8CharString.ext" e.g. "Asbestos Canoe.doc" becomes "Asbestos Canoe_mike_32CCD49F.doc". This method was intended to rename and copy files to avoid unintentional overwrites, in the Update event in the Event Handler. Currently it is not in use.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PREPDocument Class | PREPWorkflow Namespace


PREPDocument Constructor

Default Constructor

Overload List

Default Constructor

public PREPDocument();

Constructor which populates a PREPDocument object from an SPFile object

public PREPDocument(SPFile);

Constructor which populates an instance of the PREPDocument object with data from an event in the document library

public PREPDocument(SPWeb,SPListEvent);

See Also

PREPDocument Class | PREPWorkflow Namespace


PREPDocument Constructor ()

Default Constructor

public PREPDocument();

See Also

PREPDocument Class | PREPWorkflow Namespace | PREPDocument Constructor Overload List


PREPDocument Constructor (SPFile)

Constructor which populates a PREPDocument object from an SPFile object

public PREPDocument(
SPFile thisFile
);

Parameters

thisFile
A SharePoint SPFile object representing the PREP file to be constructed.

See Also

PREPDocument Class | PREPWorkflow Namespace | PREPDocument Constructor Overload List


PREPDocument Constructor (SPWeb, SPListEvent)

Constructor which populates an instance of the PREPDocument object with data from an event in the document library

public PREPDocument(
SPWeb EventWeb,
SPListEvent theEvent
);

Parameters

EventWeb
The SharePoint Web object on which the Event occurred.
theEvent
The Event object. Contains information about the Event, such as which document was affected and which user triggered it.

Return Value

See Also

PREPDocument Class | PREPWorkflow Namespace | PREPDocument Constructor Overload List


PREPDocument Properties

The properties of the PREPDocument class are listed below. For a complete list of PREPDocument class members, see the PREPDocument Members topic.

Public Instance Properties

AssignmentName | The PREP Assignment name
DocType | The PREP Document Type. May be one of two values: Ideas or Review.
EventUserLogin | Login Name of the user whose action triggered the event on the document library
EventUserName | Display Name of the user whose action triggered the event on the document library
Exists | True if a document exists for a given user and assignment.
FileName | The file name of the PREP document that triggered the event
Folder | The folder where the document resides (e.g. PREPDocuments/UserID/AssignmentName)
IdeasAuthorLogin | Login Name of the author of the ideas document that this document pertains to
PREP | PREP Bit. If True, this is a PREP Document. if PREP == true AND the document author userID == the folder name, it is an ideas document. if PREP == true AND the document author userID != the folder name, it is a review. if PREP == false, it is an extra document uploaded to the folder.
SPFileObject | The complete SPFile object

See Also

PREPDocument Class | PREPWorkflow Namespace


PREPDocument.AssignmentName Property

The PREP Assignment name

public string AssignmentName {get; set;}

See Also

PREPDocument Class | PREPWorkflow Namespace


PREPDocument.DocType Property

The PREP Document Type. May be one of two values: Ideas or Review.

public string DocType {get; set;}

See Also

PREPDocument Class | PREPWorkflow Namespace


PREPDocument.EventUserLogin Property

Login Name of the user whose action triggered the event on the document library

public string EventUserLogin {get; set;}

See Also

PREPDocument Class | PREPWorkflow Namespace


PREPDocument.EventUserName Property

Display Name of the user whose action triggered the event on the document library

public string EventUserName {get; set;}

See Also

PREPDocument Class | PREPWorkflow Namespace


PREPDocument.Exists Property

True if a document exists for a given user and assignment.

public bool Exists {get; set;}

See Also

PREPDocument Class | PREPWorkflow Namespace


PREPDocument.FileName Property

The file name of the PREP document that triggered the event

public string FileName {get; set;}

See Also

PREPDocument Class | PREPWorkflow Namespace


PREPDocument.Folder Property

The folder where the document resides (e.g. PREPDocuments/UserID/AssignmentName)

public string Folder {get; set;}

See Also

PREPDocument Class | PREPWorkflow Namespace


PREPDocument.IdeasAuthorLogin Property

Login Name of the author of the ideas document that this document pertains to

public string IdeasAuthorLogin {get; set;}

See Also

PREPDocument Class | PREPWorkflow Namespace


PREPDocument.PREP Property

PREP Bit. If True, this is a PREP Document. if PREP == true AND the document author userID == the folder name, it is an ideas document. if PREP == true AND the document author userID != the folder name, it is a review. if PREP == false, it is an extra document uploaded to the folder.

public bool PREP {get; set;}

See Also

PREPDocument Class | PREPWorkflow Namespace


PREPDocument.SPFileObject Property

The complete SPFile object

public Microsoft.SharePoint.SPFile SPFileObject {get; set;}

See Also

PREPDocument Class | PREPWorkflow Namespace


PREPDocument Methods

The methods of the PREPDocument class are listed below. For a complete list of PREPDocument class members, see the PREPDocument Members topic.

Public Static Methods

GetDocInfoFromURL | Takes a URL and returns a DocInfo object. This object breaks the URL out into the parts of the DocInfo object: IdeasAuthorLoginName, AssignmentName, and FileName. Additionally, there is a boolean IsValid which is set to false if the URL is not in the proper format. It does not check the validity of any of the data (i.e. it doesn't know if the user does not exist or the assignment name does not exist).
GetIdeasDoc | Returns the PREP Document object representing the Ideas Document for a given user (passed in as userLoginName) for a given assignment (assignmentName). If no such document can be found, Boolean field Exists is set to false.
GetReviewDoc | Returns the PREP Document object representing the Review Document for a given reviewer (reviewAuthorLoginName), reviewing the ideas of a given author (ideasAuthorLoginName), for a given assignment (assignmentName). If no such document can be found, Boolean field Exists is set to false.
IsNewPREPDocument | Returns true if the author of the passed-in file does not already have a PREP file in the current folder. Used in the Event Handler to make sure that each user has only one PREP document in a given folder.
IsPREPFolder | Validates the following: 1) The folder structure is in the correct format (PREP Documents/userName/assignmentName) 2) The assignment exists 3) The userName exists 4) The userName belongs to the assignment
PREPDocument_Collection | Returns an ArrayList of all PREPDocument objects in a folder.

Public Instance Methods

CopyToNewName | Copies the current document to a new name based on a passed-in identifier. New file name will be in the form "originalfileName_identifier_random8CharString.ext" e.g. "Asbestos Canoe.doc" becomes "Asbestos Canoe_mike_32CCD49F.doc". This method was intended to rename and copy files to avoid unintentional overwrites, in the Update event in the Event Handler. Currently it is not in use.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PREPDocument Class | PREPWorkflow Namespace


PREPDocument.CopyToNewName Method

Copies the current document to a new name based on a passed-in identifier. New file name will be in the form "originalfileName_identifier_random8CharString.ext" e.g. "Asbestos Canoe.doc" becomes "Asbestos Canoe_mike_32CCD49F.doc". This method was intended to rename and copy files to avoid unintentional overwrites, in the Update event in the Event Handler. Currently it is not in use.

public string CopyToNewName(
string identifier
);

Parameters

identifier
A string to be appended to the copied document file name.

Return Value

The new file URL

See Also

PREPDocument Class | PREPWorkflow Namespace


PREPDocument.GetDocInfoFromURL Method

Takes a URL and returns a DocInfo object. This object breaks the URL out into the parts of the DocInfo object: IdeasAuthorLoginName, AssignmentName, and FileName. Additionally, there is a boolean IsValid which is set to false if the URL is not in the proper format. It does not check the validity of any of the data (i.e. it doesn't know if the user does not exist or the assignment name does not exist).

public static DocInfo GetDocInfoFromURL(
string url
);

Parameters

url
A SharePoint Document URL

Return Value

A DocInfo object containing IdeasAuthorLoginName, AssignmentName, and FileName.

See Also

PREPDocument Class | PREPWorkflow Namespace


PREPDocument.GetIdeasDoc Method

Returns the PREP Document object representing the Ideas Document for a given user (passed in as userLoginName) for a given assignment (assignmentName). If no such document can be found, Boolean field Exists is set to false.

public static PREPDocument GetIdeasDoc(
SPWeb PREPWeb,
string assignmentName,
string userLoginName
);

Parameters

PREPWeb
The current SharePoint site
assignmentName
PREP Assignment name
userLoginName
The User Login name of the user whose PREP ideas document is to be retrieved.

Return Value

PREPDocument object containing the user's Ideas Document.

See Also

PREPDocument Class | PREPWorkflow Namespace


PREPDocument.GetReviewDoc Method

Returns the PREP Document object representing the Review Document for a given reviewer (reviewAuthorLoginName), reviewing the ideas of a given author (ideasAuthorLoginName), for a given assignment (assignmentName). If no such document can be found, Boolean field Exists is set to false.

public static PREPDocument GetReviewDoc(
SPWeb PREPWeb,
string assignmentName,
string ideasAuthorLoginName,
string reviewAuthorLoginName
);

Parameters

PREPWeb
The current SharePoint site
assignmentName
PREP Assignment name
ideasAuthorLoginName
Login Name of the author of the Ideas Document which is the subject of this Review document
reviewAuthorLoginName
Login Name of the author of this Review Document

Return Value

A PREP Review Document

See Also

PREPDocument Class | PREPWorkflow Namespace


PREPDocument.IsNewPREPDocument Method

Returns true if the author of the passed-in file does not already have a PREP file in the current folder. Used in the Event Handler to make sure that each user has only one PREP document in a given folder.

public static bool IsNewPREPDocument(
SPWeb PREPWeb,
PREPDocument prepDoc
);

Parameters

PREPWeb
A SharePoint site object (SPWeb) set to the current site context.
prepDoc
A PREP Document object

Return Value

Returns true if the author of the passed-in file does not already have a PREP file in the current folder.

See Also

PREPDocument Class | PREPWorkflow Namespace


PREPDocument.IsPREPFolder Method

Validates the following: 1) The folder structure is in the correct format (PREP Documents/userName/assignmentName) 2) The assignment exists 3) The userName exists 4) The userName belongs to the assignment

public static bool IsPREPFolder(
SPWeb PREPWeb,
string folderName
);

Parameters

PREPWeb
A SharePoint site object (SPWeb) set to the current site context.
folderName
The folder to be checked.

Return Value

true if it is a valid PREP folder.

See Also

PREPDocument Class | PREPWorkflow Namespace


PREPDocument.PREPDocument_Collection Method

Returns an ArrayList of all PREPDocument objects in a folder.

public static ArrayList PREPDocument_Collection(
SPFolder folder
);

Parameters

folder
The folder containing the PREP Documents to return

Return Value

See Also

PREPDocument Class | PREPWorkflow Namespace


PREPDocument.DocInfo Structure

Structure which contains information about a PREP Document.

For a list of all members of this type, see PREPDocument.DocInfo Members.

System.Object
System.ValueType
PREPWorkflow.PREPDocument.DocInfo

public struct PREPDocument.DocInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: PREPWorkflow

Assembly: PREPWorkflow (in PREPWorkflow.dll)

See Also

PREPDocument.DocInfo Members | PREPWorkflow Namespace


PREPDocument.DocInfo Members

PREPDocument.DocInfo overview

Public Instance Fields

AssignmentName | The PREP Assignment name.
FileName | The PREP Document filename and extension.
IdeasAuthorLoginName | The author of the Ideas Document the current document pertains to. This is equal to the author of this document if this is an Ideas document, but not if this is a Review document.
IsValid | Returns true if this DocInfo structure contains information about a valid PREP Document.

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

PREPDocument.DocInfo Class | PREPWorkflow Namespace


PREPDocument.DocInfo Fields

The fields of the PREPDocument.DocInfo structure are listed below. For a complete list of PREPDocument.DocInfo structure members, see the PREPDocument.DocInfo Members topic.

Public Instance Fields

AssignmentName | The PREP Assignment name.
FileName | The PREP Document filename and extension.
IdeasAuthorLoginName | The author of the Ideas Document the current document pertains to. This is equal to the author of this document if this is an Ideas document, but not if this is a Review document.
IsValid | Returns true if this DocInfo structure contains information about a valid PREP Document.

See Also

PREPDocument.DocInfo Class | PREPWorkflow Namespace


PREPDocument.DocInfo.AssignmentName Field

The PREP Assignment name.

public string AssignmentName;

See Also

PREPDocument.DocInfo Class | PREPWorkflow Namespace


PREPDocument.DocInfo.FileName Field

The PREP Document filename and extension.

public string FileName;

See Also

PREPDocument.DocInfo Class | PREPWorkflow Namespace


PREPDocument.DocInfo.IdeasAuthorLoginName Field

The author of the Ideas Document the current document pertains to. This is equal to the author of this document if this is an Ideas document, but not if this is a Review document.

public string IdeasAuthorLoginName;

See Also

PREPDocument.DocInfo Class | PREPWorkflow Namespace


PREPDocument.DocInfo.IsValid Field

Returns true if this DocInfo structure contains information about a valid PREP Document.

public bool IsValid;

See Also

PREPDocument.DocInfo Class | PREPWorkflow Namespace


PREPEventSink Class

The main class for the PREP Event Handler

For a list of all members of this type, see PREPEventSink Members.

System.Object
PREPWorkflow.BaseEventSink
PREPWorkflow.PREPEventSink

public class PREPEventSink : BaseEventSink

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: PREPWorkflow

Assembly: PREPWorkflow (in PREPWorkflow.dll)

See Also

PREPEventSink Members | PREPWorkflow Namespace


PREPEventSink Members

PREPEventSink overview

Public Instance Constructors

PREPEventSink Constructor Initializes a new instance of the PREPEventSink class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
OnEvent (inherited from BaseEventSink) | Implementation of the OnEvent method. Windows SharePoint Services will call this method when an event occurs.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Fields

m_ListEvent (inherited from BaseEventSink) Cached List Event

Protected Instance Properties

Data (inherited from BaseEventSink) | Sink Data
EventFileUrl (inherited from BaseEventSink) | The url of the file the event occured on. Equals UrlAfter if UrlAfter is not empty. Otherwise equals UrlBefore.
EventInfo (inherited from BaseEventSink) | The SPListEvent object that describes the current event.
EventList (inherited from BaseEventSink) | The SPList object for the list the event occured on.
EventWeb (inherited from BaseEventSink) | The SPWeb object for the web site that contains the list that the event occured on.
HandlerIdentity | Windows HandlerIdentity

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
HandleEvent | Handle the event from the PREP Document Library
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PREPEventSink Class | PREPWorkflow Namespace


PREPEventSink Constructor

Initializes a new instance of the PREPEventSink class.

public PREPEventSink();

See Also

PREPEventSink Class | PREPWorkflow Namespace


PREPEventSink Properties

The properties of the PREPEventSink class are listed below. For a complete list of PREPEventSink class members, see the PREPEventSink Members topic.

Protected Instance Properties

Data (inherited from BaseEventSink) | Sink Data
EventFileUrl (inherited from BaseEventSink) | The url of the file the event occured on. Equals UrlAfter if UrlAfter is not empty. Otherwise equals UrlBefore.
EventInfo (inherited from BaseEventSink) | The SPListEvent object that describes the current event.
EventList (inherited from BaseEventSink) | The SPList object for the list the event occured on.
EventWeb (inherited from BaseEventSink) | The SPWeb object for the web site that contains the list that the event occured on.
HandlerIdentity | Windows HandlerIdentity

See Also

PREPEventSink Class | PREPWorkflow Namespace


PREPEventSink.HandlerIdentity Property

Windows HandlerIdentity

protected override System.Security.Principal.WindowsIdentity HandlerIdentity {get;}

See Also

PREPEventSink Class | PREPWorkflow Namespace


PREPEventSink Methods

The methods of the PREPEventSink class are listed below. For a complete list of PREPEventSink class members, see the PREPEventSink Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
OnEvent (inherited from BaseEventSink) | Implementation of the OnEvent method. Windows SharePoint Services will call this method when an event occurs.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
HandleEvent | Handle the event from the PREP Document Library
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PREPEventSink Class | PREPWorkflow Namespace


PREPEventSink.HandleEvent Method

Handle the event from the PREP Document Library

protected override void HandleEvent();

See Also

PREPEventSink Class | PREPWorkflow Namespace


PREPFields Class

Class which standardizes the string representation of various PREP fields

For a list of all members of this type, see PREPFields Members.

System.Object
PREPWorkflow.PREPFields

public class PREPFields

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: PREPWorkflow

Assembly: PREPWorkflow (in PREPWorkflow.dll)

See Also

PREPFields Members | PREPWorkflow Namespace


PREPFields Members

PREPFields overview

Public Static Fields

CheckedOutTo | Used for PREP Documents
Completed | Used for PREP Tasks.
DocTypeIdeas | Used for PREP Document metadata
DocTypeReview | Used for PREP Document metadata
InProgress | Used for PREP Tasks.
NotStarted | Used for PREP Tasks.

Public Instance Constructors

PREPFields Constructor Default Constructor

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PREPFields Class | PREPWorkflow Namespace


PREPFields Constructor

Default Constructor

public PREPFields();

See Also

PREPFields Class | PREPWorkflow Namespace


PREPFields Fields

The fields of the PREPFields class are listed below. For a complete list of PREPFields class members, see the PREPFields Members topic.

Public Static Fields

CheckedOutTo | Used for PREP Documents
Completed | Used for PREP Tasks.
DocTypeIdeas | Used for PREP Document metadata
DocTypeReview | Used for PREP Document metadata
InProgress | Used for PREP Tasks.
NotStarted | Used for PREP Tasks.

See Also

PREPFields Class | PREPWorkflow Namespace


PREPFields.CheckedOutTo Field

Used for PREP Documents

public const string CheckedOutTo = "Checked Out To";

See Also

PREPFields Class | PREPWorkflow Namespace


PREPFields.Completed Field

Used for PREP Tasks.

public const string Completed = "Completed";

See Also

PREPFields Class | PREPWorkflow Namespace


PREPFields.DocTypeIdeas Field

Used for PREP Document metadata

public const string DocTypeIdeas = "Ideas";

See Also

PREPFields Class | PREPWorkflow Namespace


PREPFields.DocTypeReview Field

Used for PREP Document metadata

public const string DocTypeReview = "Review";

See Also

PREPFields Class | PREPWorkflow Namespace


PREPFields.InProgress Field

Used for PREP Tasks.

public const string InProgress = "In Progress";

See Also

PREPFields Class | PREPWorkflow Namespace


PREPFields.NotStarted Field

Used for PREP Tasks.

public const string NotStarted = "Not Started";

See Also

PREPFields Class | PREPWorkflow Namespace


PREPImpersonation Class

Allows code to impersonate a Windows user that is different from the logged-in user. Typically this is used to execute code that requires a higher level of privilege than the user posesses (e.g. somethine that requires an Administrator).

For a list of all members of this type, see PREPImpersonation Members.

System.Object
PREPWorkflow.PREPImpersonation

public class PREPImpersonation

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: PREPWorkflow

Assembly: PREPWorkflow (in PREPWorkflow.dll)

See Also

PREPImpersonation Members | PREPWorkflow Namespace


PREPImpersonation Members

PREPImpersonation overview

Public Instance Constructors

PREPImpersonation Overloaded. Initializes a new instance of the PREPImpersonation class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Impersonate | Begins impersonating the user specified in the constructor.
ToString (inherited from Object) | Returns a String that represents the current Object.
UnImpersonate | Stops impersonating the user specified in the constructor.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PREPImpersonation Class | PREPWorkflow Namespace


PREPImpersonation Constructor

Default constructor.

Overload List

Default constructor.

public PREPImpersonation();

Instantiates the object with a set of credentials which will be used for Windows Impersonation.

public PREPImpersonation(string,string,string);

See Also

PREPImpersonation Class | PREPWorkflow Namespace


PREPImpersonation Constructor ()

Default constructor.

public PREPImpersonation();

See Also

PREPImpersonation Class | PREPWorkflow Namespace | PREPImpersonation Constructor Overload List


PREPImpersonation Constructor (String, String, String)

Instantiates the object with a set of credentials which will be used for Windows Impersonation.

public PREPImpersonation(
string user,
string domain,
string password
);

Parameters

user
domain
password

See Also

PREPImpersonation Class | PREPWorkflow Namespace | PREPImpersonation Constructor Overload List


PREPImpersonation Methods

The methods of the PREPImpersonation class are listed below. For a complete list of PREPImpersonation class members, see the PREPImpersonation Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Impersonate | Begins impersonating the user specified in the constructor.
ToString (inherited from Object) | Returns a String that represents the current Object.
UnImpersonate | Stops impersonating the user specified in the constructor.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PREPImpersonation Class | PREPWorkflow Namespace


PREPImpersonation.Impersonate Method

Begins impersonating the user specified in the constructor.

public void Impersonate();

See Also

PREPImpersonation Class | PREPWorkflow Namespace


PREPImpersonation.UnImpersonate Method

Stops impersonating the user specified in the constructor.

public void UnImpersonate();

See Also

PREPImpersonation Class | PREPWorkflow Namespace


PREPRole Class

Custom SPRole object for PREP. Each PREP Assignment has a custom role, with the same name, which contains the set of users who are included in the assignment. This class is a workaround to address the problem where the SharePoint Object Model only allows Administrator access to the SPRole object. This problem cannot be addressed through impersonation because SharePoint only considers the original user context when evaluating security for SPRole. This class is intended only for non-administrators to be able to read the user collections in the role object (e.g., in the PREP Matrix). Therefore, there are no add or update methods. These will be done using the normal SPRole object by an administrator.

For a list of all members of this type, see PREPRole Members.

System.Object
PREPWorkflow.PREPRole

public class PREPRole

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: PREPWorkflow

Assembly: PREPWorkflow (in PREPWorkflow.dll)

See Also

PREPRole Members | PREPWorkflow Namespace


PREPRole Members

PREPRole overview

Public Static Methods

SendMailToMembers Sends an email message to each member of a custom Role.

Public Instance Constructors

PREPRole Overloaded. Initializes a new instance of the PREPRole class.

Public Instance Properties

Description | Role Description.
Exists | True if the Role name requested in the constructor actually exists in the site (i.e, has been persisted in the database).
ID | Database unique identifier for this SPRole
Name | Role Name.
Users | ArrayList of UserInfo structs, containing User LoginName, email, etc.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PREPRole Class | PREPWorkflow Namespace


PREPRole Constructor

Default constructor.

Overload List

Default constructor.

public PREPRole();

Populates a PREPRole object, given the web and role name

public PREPRole(SPWeb,string);

See Also

PREPRole Class | PREPWorkflow Namespace


PREPRole Constructor ()

Default constructor.

public PREPRole();

See Also

PREPRole Class | PREPWorkflow Namespace | PREPRole Constructor Overload List


PREPRole Constructor (SPWeb, String)

Populates a PREPRole object, given the web and role name

public PREPRole(
SPWeb PREPWeb,
string PREPRole_Key
);

Parameters

PREPWeb
A SharePoint site object (SPWeb) set to the current site context.
PREPRole_Key
The name of the PREP Role. These names are equal to assignment names; each assignment has a corresponding role which contains the set of users who belong to the assignment.

See Also

PREPRole Class | PREPWorkflow Namespace | PREPRole Constructor Overload List


PREPRole Properties

The properties of the PREPRole class are listed below. For a complete list of PREPRole class members, see the PREPRole Members topic.

Public Instance Properties

Description | Role Description.
Exists | True if the Role name requested in the constructor actually exists in the site (i.e, has been persisted in the database).
ID | Database unique identifier for this SPRole
Name | Role Name.
Users | ArrayList of UserInfo structs, containing User LoginName, email, etc.

See Also

PREPRole Class | PREPWorkflow Namespace


PREPRole.Description Property

Role Description.

public string Description {get; set;}

See Also

PREPRole Class | PREPWorkflow Namespace


PREPRole.Exists Property

True if the Role name requested in the constructor actually exists in the site (i.e, has been persisted in the database).

public bool Exists {get;}

See Also

PREPRole Class | PREPWorkflow Namespace


PREPRole.ID Property

Database unique identifier for this SPRole

public int ID {get; set;}

See Also

PREPRole Class | PREPWorkflow Namespace


PREPRole.Name Property

Role Name.

public string Name {get; set;}

See Also

PREPRole Class | PREPWorkflow Namespace


PREPRole.Users Property

ArrayList of UserInfo structs, containing User LoginName, email, etc.

public System.Collections.ArrayList Users {get; set;}

See Also

PREPRole Class | PREPWorkflow Namespace


PREPRole Methods

The methods of the PREPRole class are listed below. For a complete list of PREPRole class members, see the PREPRole Members topic.

Public Static Methods

SendMailToMembers Sends an email message to each member of a custom Role.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PREPRole Class | PREPWorkflow Namespace


PREPRole.SendMailToMembers Method

Sends an email message to each member of a custom Role.

public static void SendMailToMembers(
SPWeb PREPWeb,
string roleName,
string subject,
string message
);

Parameters

PREPWeb
A SharePoint site object (SPWeb) set to the current site context.
roleName
The role name. This will correspond to an Assignment Name.
subject
Subject of the email to send.
message
Body of the email to send.

See Also

PREPRole Class | PREPWorkflow Namespace


PREPTask Class

Class which represents a PREP Task

For a list of all members of this type, see PREPTask Members.

System.Object
PREPWorkflow.PREPTask

public class PREPTask

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: PREPWorkflow

Assembly: PREPWorkflow (in PREPWorkflow.dll)

See Also

PREPTask Members | PREPWorkflow Namespace


PREPTask Members

PREPTask overview

Public Static Methods

Create | This method will create a PREP Task, assigned to one user, for the passed in assignmentName. The docAuthorLogin is the login of the author of the Ideas Document this task pertains to. The user is the user who the task is assigned to. If the docAuthorLogin == the user, this is the user's task to upload an ideas document. If the docAuthorLogin != the user, this is the user's task to review the docAuthor's ideas document.
DeleteTasksAssignedToUser | This will delete all tasks for one user for one assignment. This should be run if a user is removed from an assignment.
DeleteTasksRelatedToDocument | Deletes all PREP Tasks pertaining to a document, meaning the document's name is in the PREPTask object's DocumentName field. The DocumentName field holds the name of the Ideas Document the task pertains to. The ideas task will be left in place, and its status will be reset to "Not Started".
DeleteTasksRelatedToUser | This will delete all tasks related to a user's Ideas Document for one assignment. It will include the user's own task to create an Ideas Document, as well as other assignment members tasks to review that Ideas Document. This should be run if a user is removed from an assignment.
GetIdeasTask | Returns a user's (represented as userLoginName) "ideas" task - a task obligating them to create and upload an ideas document. If no such task exists, the boolean "Exists" is set to false.
GetReviewTask | Returns a "review" task directing userLoginName to review ideasAuthorLoginName's ideas document. Boolean "Exists" is set to false if no such task exists.
PREPTask_Collection | Overloaded. A Collection of PREPTask objects containing all of the PREP Tasks for a site

Public Instance Constructors

PREPTask Overloaded. Initializes a new instance of the PREPTask class.

Public Instance Properties

AssignedTo | Login Name of the User the task is assigned to.
AssignmentName | The PREP Assignment Name.
DocumentAuthor | Ideas Document Author. This field names the Ideas Document Author, regardless of whether the task is an Ideas Task (an obligation to upload an Ideas Document) or a Review Task (an obligation to Review an Ideas Document).
DocumentName | Ideas Document Name. This field names the Ideas Document, regardless of whether the task is an Ideas Task (an obligation to upload an Ideas Document) or a Review Task (an obligation to Review an Ideas Document).
DueDate | Date the Task is due.
Exists | Returns true if the constructor for the current instance was able to locate a persisted record corresponding to the requested key.
SPListItemObject | The complete SPList object taken from the SharePoint list. This has all of the properties, as well as the Update() method.
StartDate | Date the Task is assigned.
Status | Task Status: Not Started, In Progress, or Completed
Title | Task title. Contains information about the ideas document author, the assignment name, and the user it is assigned to.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PREPTask Class | PREPWorkflow Namespace


PREPTask Constructor

Default constructor

Overload List

Default constructor

public PREPTask();

Populates a PREPTask object from a a SharePoint List item, taken from the PREP Task list.

public PREPTask(SPListItem);

See Also

PREPTask Class | PREPWorkflow Namespace


PREPTask Constructor ()

Default constructor

public PREPTask();

See Also

PREPTask Class | PREPWorkflow Namespace | PREPTask Constructor Overload List


PREPTask Constructor (SPListItem)

Populates a PREPTask object from a a SharePoint List item, taken from the PREP Task list.

public PREPTask(
SPListItem listItem
);

Parameters

listItem
The SharePoint SPListItem object from which to construct this PREPTask object.

See Also

PREPTask Class | PREPWorkflow Namespace | PREPTask Constructor Overload List


PREPTask Properties

The properties of the PREPTask class are listed below. For a complete list of PREPTask class members, see the PREPTask Members topic.

Public Instance Properties

AssignedTo | Login Name of the User the task is assigned to.
AssignmentName | The PREP Assignment Name.
DocumentAuthor | Ideas Document Author. This field names the Ideas Document Author, regardless of whether the task is an Ideas Task (an obligation to upload an Ideas Document) or a Review Task (an obligation to Review an Ideas Document).
DocumentName | Ideas Document Name. This field names the Ideas Document, regardless of whether the task is an Ideas Task (an obligation to upload an Ideas Document) or a Review Task (an obligation to Review an Ideas Document).
DueDate | Date the Task is due.
Exists | Returns true if the constructor for the current instance was able to locate a persisted record corresponding to the requested key.
SPListItemObject | The complete SPList object taken from the SharePoint list. This has all of the properties, as well as the Update() method.
StartDate | Date the Task is assigned.
Status | Task Status: Not Started, In Progress, or Completed
Title | Task title. Contains information about the ideas document author, the assignment name, and the user it is assigned to.

See Also

PREPTask Class | PREPWorkflow Namespace


PREPTask.AssignedTo Property

Login Name of the User the task is assigned to.

public string AssignedTo {get; set;}

See Also

PREPTask Class | PREPWorkflow Namespace


PREPTask.AssignmentName Property

The PREP Assignment Name.

public string AssignmentName {get; set;}

See Also

PREPTask Class | PREPWorkflow Namespace


PREPTask.DocumentAuthor Property

Ideas Document Author. This field names the Ideas Document Author, regardless of whether the task is an Ideas Task (an obligation to upload an Ideas Document) or a Review Task (an obligation to Review an Ideas Document).

public string DocumentAuthor {get; set;}

See Also

PREPTask Class | PREPWorkflow Namespace


PREPTask.DocumentName Property

Ideas Document Name. This field names the Ideas Document, regardless of whether the task is an Ideas Task (an obligation to upload an Ideas Document) or a Review Task (an obligation to Review an Ideas Document).

public string DocumentName {get; set;}

See Also

PREPTask Class | PREPWorkflow Namespace


PREPTask.DueDate Property

Date the Task is due.

public System.DateTime DueDate {get; set;}

See Also

PREPTask Class | PREPWorkflow Namespace


PREPTask.Exists Property

Returns true if the constructor for the current instance was able to locate a persisted record corresponding to the requested key.

public bool Exists {get; set;}

See Also

PREPTask Class | PREPWorkflow Namespace


PREPTask.SPListItemObject Property

The complete SPList object taken from the SharePoint list. This has all of the properties, as well as the Update() method.

public Microsoft.SharePoint.SPListItem SPListItemObject {get; set;}

See Also

PREPTask Class | PREPWorkflow Namespace


PREPTask.StartDate Property

Date the Task is assigned.

public System.DateTime StartDate {get; set;}

See Also

PREPTask Class | PREPWorkflow Namespace


PREPTask.Status Property

Task Status: Not Started, In Progress, or Completed

public string Status {get; set;}

See Also

PREPTask Class | PREPWorkflow Namespace


PREPTask.Title Property

Task title. Contains information about the ideas document author, the assignment name, and the user it is assigned to.

public string Title {get; set;}

See Also

PREPTask Class | PREPWorkflow Namespace


PREPTask Methods

The methods of the PREPTask class are listed below. For a complete list of PREPTask class members, see the PREPTask Members topic.

Public Static Methods

Create | This method will create a PREP Task, assigned to one user, for the passed in assignmentName. The docAuthorLogin is the login of the author of the Ideas Document this task pertains to. The user is the user who the task is assigned to. If the docAuthorLogin == the user, this is the user's task to upload an ideas document. If the docAuthorLogin != the user, this is the user's task to review the docAuthor's ideas document.
DeleteTasksAssignedToUser | This will delete all tasks for one user for one assignment. This should be run if a user is removed from an assignment.
DeleteTasksRelatedToDocument | Deletes all PREP Tasks pertaining to a document, meaning the document's name is in the PREPTask object's DocumentName field. The DocumentName field holds the name of the Ideas Document the task pertains to. The ideas task will be left in place, and its status will be reset to "Not Started".
DeleteTasksRelatedToUser | This will delete all tasks related to a user's Ideas Document for one assignment. It will include the user's own task to create an Ideas Document, as well as other assignment members tasks to review that Ideas Document. This should be run if a user is removed from an assignment.
GetIdeasTask | Returns a user's (represented as userLoginName) "ideas" task - a task obligating them to create and upload an ideas document. If no such task exists, the boolean "Exists" is set to false.
GetReviewTask | Returns a "review" task directing userLoginName to review ideasAuthorLoginName's ideas document. Boolean "Exists" is set to false if no such task exists.
PREPTask_Collection | Overloaded. A Collection of PREPTask objects containing all of the PREP Tasks for a site

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PREPTask Class | PREPWorkflow Namespace


PREPTask.Create Method

This method will create a PREP Task, assigned to one user, for the passed in assignmentName. The docAuthorLogin is the login of the author of the Ideas Document this task pertains to. The user is the user who the task is assigned to. If the docAuthorLogin == the user, this is the user's task to upload an ideas document. If the docAuthorLogin != the user, this is the user's task to review the docAuthor's ideas document.

public static void Create(
SPWeb PREPWeb,
SPList PREPList,
string assignmentName,
string docName,
string docAuthorLoginName,
SPUser user
);

Parameters

PREPWeb
A SharePoint site object (SPWeb) set to the current site context.
PREPList
The PREP Task List.
assignmentName
The name of the PREP assignment.
docName
The name of the Ideas Document associated with a PREP task.
docAuthorLoginName
The login name of the user whose Ideas Document this task pertains to.
user
The user this task is assigned to.

See Also

PREPTask Class | PREPWorkflow Namespace


PREPTask.DeleteTasksAssignedToUser Method

This will delete all tasks for one user for one assignment. This should be run if a user is removed from an assignment.

public static void DeleteTasksAssignedToUser(
SPWeb PREPWeb,
string assignmentName,
string currentUserLoginName
);

Parameters

PREPWeb
A SharePoint site object (SPWeb) set to the current site context.
assignmentName
The PREP Assignment name
currentUserLoginName
Name of the user whose tasks are to be deleted

See Also

PREPTask Class | PREPWorkflow Namespace


PREPTask.DeleteTasksRelatedToDocument Method

Deletes all PREP Tasks pertaining to a document, meaning the document's name is in the PREPTask object's DocumentName field. The DocumentName field holds the name of the Ideas Document the task pertains to. The ideas task will be left in place, and its status will be reset to "Not Started".

public static void DeleteTasksRelatedToDocument(
SPWeb PREPWeb,
string assignmentName,
string documentName,
string ideasAuthorLoginName
);

Parameters

PREPWeb
A SharePoint site object (SPWeb) set to the current site context.
assignmentName
The PREP Assignment name.
documentName
The PREP Ideas document which is the object of the tasks to be deleted.
ideasAuthorLoginName
The Login Name of the Author of the PREP Ideas document which is the object of the tasks to be deleted.

See Also

PREPTask Class | PREPWorkflow Namespace


PREPTask.DeleteTasksRelatedToUser Method

This will delete all tasks related to a user's Ideas Document for one assignment. It will include the user's own task to create an Ideas Document, as well as other assignment members tasks to review that Ideas Document. This should be run if a user is removed from an assignment.

public static void DeleteTasksRelatedToUser(
SPWeb PREPWeb,
string assignmentName,
string currentUserLoginName
);

Parameters

PREPWeb
A SharePoint site object (SPWeb) set to the current site context.
assignmentName
PREP Assignment name for which tasks should be deleted.
currentUserLoginName
Login Name of the author of the Ideas Document which is the object of the tasks to be deleted.

See Also

PREPTask Class | PREPWorkflow Namespace


PREPTask.GetIdeasTask Method

Returns a user's (represented as userLoginName) "ideas" task - a task obligating them to create and upload an ideas document. If no such task exists, the boolean "Exists" is set to false.

public static PREPTask GetIdeasTask(
ArrayList prepTasks,
string assignmentName,
string userLoginName
);

Parameters

prepTasks
ArrayList of PREPTask objects
assignmentName
The assignment name to check
userLoginName
The user whose ideas task will be sought.

Return Value

See Also

PREPTask Class | PREPWorkflow Namespace


PREPTask.GetReviewTask Method

Returns a "review" task directing userLoginName to review ideasAuthorLoginName's ideas document. Boolean "Exists" is set to false if no such task exists.

public static PREPTask GetReviewTask(
ArrayList prepTasks,
string assignmentName,
string ideasAuthorLoginName,
string reviewAuthorLoginName
);

Parameters

prepTasks
An ArrayList of PREPTask objects to search for a task.
assignmentName
The name of the assignment whose tasks are to be queried.
ideasAuthorLoginName
The login name of the author of the ideas document referenced on the task.
reviewAuthorLoginName
The login name of the user who the task is assigned to.

Return Value

A PREPTask object containing a Review Task. If the sought-after task could not be found, this object will have its "Exists" property set to false.

See Also

PREPTask Class | PREPWorkflow Namespace


PREPTask_Collection Method

SharePoint PREP 2.0

PREPTask.PREPTask_Collection Method

A Collection of PREPTask objects containing all of the PREP Tasks for a site

Overload List

A Collection of PREPTask objects containing all of the PREP Tasks for a site

public static ArrayList PREPTask_Collection(SPList);

A Collection of PREPTask objects containing all of the PREP Tasks for a given assignment

public static ArrayList PREPTask_Collection(SPList,string);

See Also

PREPTask Class | PREPWorkflow Namespace


PREPTask.PREPTask_Collection Method (SPList)

A Collection of PREPTask objects containing all of the PREP Tasks for a site

public static ArrayList PREPTask_Collection(
SPList prepTaskList
);

Parameters

prepTaskList
The SharePoint list object for the PREP Review Task list.

Return Value

An ArrayList of PREPTask objects.

See Also

PREPTask Class | PREPWorkflow Namespace | PREPTask.PREPTask_Collection Overload List


PREPTask.PREPTask_Collection Method (SPList, String)

A Collection of PREPTask objects containing all of the PREP Tasks for a given assignment

public static ArrayList PREPTask_Collection(
SPList prepTaskList,
string assignmentName
);

Parameters

prepTaskList
The SharePoint list object for the PREP Review Task list.
assignmentName
The assignment to return tasks for

Return Value

An ArrayList of PREPTask objects.

See Also

PREPTask Class | PREPWorkflow Namespace | PREPTask.PREPTask_Collection Overload List


PREPUploadDownloadHandler Class

This handler intercepts clicks from the PREPWebPartMatrix Web Part. Depending on the context (user and document), it will download or upload a document.

For a list of all members of this type, see PREPUploadDownloadHandler Members.

System.Object
PREPWorkflow.PREPUploadDownloadHandler

public class PREPUploadDownloadHandler : IHttpHandler

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: PREPWorkflow

Assembly: PREPWorkflow (in PREPWorkflow.dll)

See Also

PREPUploadDownloadHandler Members | PREPWorkflow Namespace


PREPUploadDownloadHandler Members

PREPUploadDownloadHandler overview

Public Instance Constructors

PREPUploadDownloadHandler Constructor Default Constructor.

Public Instance Properties

IsReusable Property to indicate class reuse state Part of IHttpHandler

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ProcessRequest | Process the HTTP request called by the application process Part of IHttpHandler.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PREPUploadDownloadHandler Class | PREPWorkflow Namespace


PREPUploadDownloadHandler Constructor

Default Constructor.

public PREPUploadDownloadHandler();

See Also

PREPUploadDownloadHandler Class | PREPWorkflow Namespace


PREPUploadDownloadHandler Properties

The properties of the PREPUploadDownloadHandler class are listed below. For a complete list of PREPUploadDownloadHandler class members, see the PREPUploadDownloadHandler Members topic.

Public Instance Properties

IsReusable Property to indicate class reuse state Part of IHttpHandler

See Also

PREPUploadDownloadHandler Class | PREPWorkflow Namespace


PREPUploadDownloadHandler.IsReusable Property

Property to indicate class reuse state Part of IHttpHandler

public bool IsReusable {get;}

Implements

IHttpHandler.IsReusable

See Also

PREPUploadDownloadHandler Class | PREPWorkflow Namespace


PREPUploadDownloadHandler Methods

The methods of the PREPUploadDownloadHandler class are listed below. For a complete list of PREPUploadDownloadHandler class members, see the PREPUploadDownloadHandler Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ProcessRequest | Process the HTTP request called by the application process Part of IHttpHandler.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PREPUploadDownloadHandler Class | PREPWorkflow Namespace


PREPUploadDownloadHandler.ProcessRequest Method

Process the HTTP request called by the application process Part of IHttpHandler.

public void ProcessRequest(
HttpContext context
);

Parameters

context

Implements

IHttpHandler.ProcessRequest

See Also

PREPUploadDownloadHandler Class | PREPWorkflow Namespace


Utilities Class

Utility class containing methods to log errors, send email, encrypt and decrypt strings, manipulate strings, etc.

For a list of all members of this type, see Utilities Members.

System.Object
PREPWorkflow.Utilities

public class Utilities

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: PREPWorkflow

Assembly: PREPWorkflow (in PREPWorkflow.dll)

See Also

Utilities Members | PREPWorkflow Namespace


Utilities Members

Utilities overview

Public Static Fields

MachineKey Provides encryption keys for values stored in the appSettings section of machine.config.

Public Static Methods

Decrypt | Decrypts cipherText Uses a hard-coded IV and Key
Encrypt | Encrypts plainTextToEncrypt Uses a hard-coded IV and Key
GetFileExt | Returns the extension of a file.
GetFileName | Strips off the path component of a file name
GetLoginName | Strips off the path domain component of a login name. This method is used frequently in order to make sure that comparisons of login names do not fail because they are in different formats.
GetRandomString | Returns a random character string.
GetUserNameFromListItemField | Returns only the string user name from a User Name field in a list item. Strips off ";#" sections as well as domain sections.
LogError | Overloaded. Generic error logging mechanism. Writes an error to the Event Log, and dispatches an email.
SendEmail | Generic email routine. Sends an email message. Handles the mail object and error checking.

Public Instance Constructors

Utilities Constructor Default Constructor.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Utilities Class | PREPWorkflow Namespace


Utilities Constructor

Default Constructor.

public Utilities();

See Also

Utilities Class | PREPWorkflow Namespace


Utilities Fields

The fields of the Utilities class are listed below. For a complete list of Utilities class members, see the Utilities Members topic.

Public Static Fields

MachineKey Provides encryption keys for values stored in the appSettings section of machine.config.

See Also

Utilities Class | PREPWorkflow Namespace


Utilities.MachineKey Field

Provides encryption keys for values stored in the appSettings section of machine.config.

public static string MachineKey;

See Also

Utilities Class | PREPWorkflow Namespace


Utilities Methods

The methods of the Utilities class are listed below. For a complete list of Utilities class members, see the Utilities Members topic.

Public Static Methods

Decrypt | Decrypts cipherText Uses a hard-coded IV and Key
Encrypt | Encrypts plainTextToEncrypt Uses a hard-coded IV and Key
GetFileExt | Returns the extension of a file.
GetFileName | Strips off the path component of a file name
GetLoginName | Strips off the path domain component of a login name. This method is used frequently in order to make sure that comparisons of login names do not fail because they are in different formats.
GetRandomString | Returns a random character string.
GetUserNameFromListItemField | Returns only the string user name from a User Name field in a list item. Strips off ";#" sections as well as domain sections.
LogError | Overloaded. Generic error logging mechanism. Writes an error to the Event Log, and dispatches an email.
SendEmail | Generic email routine. Sends an email message. Handles the mail object and error checking.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Utilities Class | PREPWorkflow Namespace


Utilities.Decrypt Method

Decrypts cipherText Uses a hard-coded IV and Key

public static string Decrypt(
string cipherText
);

Parameters

cipherText
base 64 string of cipher text to decode

Return Value

the original string unencrypted

See Also

Utilities Class | PREPWorkflow Namespace


Utilities.Encrypt Method

Encrypts plainTextToEncrypt Uses a hard-coded IV and Key

public static string Encrypt(
string plainTextToEncrypt
);

Parameters

plainTextToEncrypt
text to encrypt

Return Value

base 64 string of cipher text

See Also

Utilities Class | PREPWorkflow Namespace


Utilities.GetFileExt Method

Returns the extension of a file.

public static string GetFileExt(
string fileNameIn
);

Parameters

fileNameIn
The file name in the form "filename.ext". This method does not expect to see any path components.

Return Value

Just the file extension

See Also

Utilities Class | PREPWorkflow Namespace


Utilities.GetFileName Method

Strips off the path component of a file name

public static string GetFileName(
string fileNameIn
);

Parameters

fileNameIn
A file name complete with path.

Return Value

Just the file name

See Also

Utilities Class | PREPWorkflow Namespace


Utilities.GetLoginName Method

Strips off the path domain component of a login name. This method is used frequently in order to make sure that comparisons of login names do not fail because they are in different formats.

public static string GetLoginName(
string loginNameIn
);

Parameters

loginNameIn
The SharePoint login name, which typically contains an identifier and a domain component. Example: "1;#DOMAINNAME\username"/

Return Value

Just the login name, e.g. "username".

See Also

Utilities Class | PREPWorkflow Namespace


Utilities.GetRandomString Method

Returns a random character string.

public static string GetRandomString(
int numCharacters
);

Parameters

numCharacters
The number of characters to return. The maximum value for this is 32.

Return Value

See Also

Utilities Class | PREPWorkflow Namespace


Utilities.GetUserNameFromListItemField Method

Returns only the string user name from a User Name field in a list item. Strips off ";#" sections as well as domain sections.

public static string GetUserNameFromListItemField(
SPListItem item,
string fieldName
);

Parameters

item
The SharePoint ListItem object
fieldName
The name of the field on the ListItem object.

Return Value

See Also

Utilities Class | PREPWorkflow Namespace


LogError Method

SharePoint PREP 2.0

Utilities.LogError Method

Generic error logging mechanism. Writes an error to the Event Log, and dispatches an email. This version returns info about the SharePoint web where it originated.

Overload List

Generic error logging mechanism. Writes an error to the Event Log, and dispatches an email. This version returns info about the SharePoint web where it originated.

public static void LogError(SPWeb,string,Exception);

Generic error logging mechanism. Writes an error to the Event Log, and dispatches an email.

public static void LogError(string,Exception);

See Also

Utilities Class | PREPWorkflow Namespace


Utilities.LogError Method (SPWeb, String, Exception)

Generic error logging mechanism. Writes an error to the Event Log, and dispatches an email. This version returns info about the SharePoint web where it originated.

public static void LogError(
SPWeb PREPWeb,
string message,
Exception ex
);

Parameters

PREPWeb
A SharePoint site object (SPWeb) set to the current site context. This will enable our log to know which virtual SharePoint site originated the exception.
message
Message which should accompany the exception.
ex
The exception.

See Also

Utilities Class | PREPWorkflow Namespace | Utilities.LogError Overload List


Utilities.LogError Method (String, Exception)

Generic error logging mechanism. Writes an error to the Event Log, and dispatches an email.

public static void LogError(
string message,
Exception ex
);

Parameters

message
Message which should accompany the exception.
ex
The exception.

See Also

Utilities Class | PREPWorkflow Namespace | Utilities.LogError Overload List


Utilities.SendEmail Method

Generic email routine. Sends an email message. Handles the mail object and error checking.

public static void SendEmail(
string subject,
string message,
string emailAddress
);

Parameters

subject
Subject of the email.
message
Body of the email.
emailAddress
The email address to send a message to. This string can be specified in the form of a list delimited by either commas or semi-colons, which allows for multiple recipients.

See Also

Utilities Class | PREPWorkflow Namespace


PREPWebPartLibrary20Hierarchy

SharePoint PREP 2.0

PREPWebPartLibrary20 Hierarchy

System.Object
PREPWebPartLibrary20.RepeaterColumn ---- System.Web.UI.ITemplate
PREPWebPartLibrary20.RepeaterFooter ---- System.Web.UI.ITemplate
PREPWebPartLibrary20.RepeaterHeader ---- System.Web.UI.ITemplate
System.ValueType
PREPWebPartLibrary20.PREPMatrixWebPart20.PREPImages
System.Web.UI.Control ---- System.ComponentModel.IComponent, System.IDisposable, System.Web.UI.IDataBindingsAccessor, System.Web.UI.IParserAccessor
Microsoft.SharePoint.WebPartPages.WebPart ---- System.Web.UI.INamingContainer
PREPWebPartLibrary20.PREPMatrixWebPart20
PREPWebPartLibrary20.PREPProjectAdmin20
PREPWebPartLibrary20.UserAlerts

See Also

PREPWebPartLibrary20 Namespace


PREPWorkflowHierarchy

SharePoint PREP 2.0

PREPWorkflow Hierarchy

System.Object
PREPWorkflow.BaseEventSink ---- Microsoft.SharePoint.IListEventSink
PREPWorkflow.PREPEventSink
PREPWorkflow.HTMLTools
PREPWorkflow.PREPAssignment
PREPWorkflow.PREPDocument
PREPWorkflow.PREPFields
PREPWorkflow.PREPImpersonation
PREPWorkflow.PREPRole
PREPWorkflow.PREPTask
PREPWorkflow.PREPUploadDownloadHandler ---- System.Web.IHttpHandler
PREPWorkflow.Utilities
System.ValueType
PREPWorkflow.PREPDocument.DocInfo

See Also

PREPWorkflow Namespace