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What Is Leash and When To Use It?

Leash isagraphical ticket manager for Kerberos on Microsoft Windows. Leash isused to obtain Kerberos
tickets and change your Kerberos password.

L eash combines the functionality of several command line tools a user would use to manage Kerberos
functions: kinit, klist, kdestroy, ms2mit, passwd or kpasswd. Leash combines all of these functionsinto one
user interface and supports auto-renewal or user notification when tickets are approaching expiration.

There are many ways to execute Leash. In addition to clicking on the Leash icon, you can start Leash from
the Windows command Prompt or Run... option. Here, you can specify command-line options as well; if
you run Leash with the options-i or -kinit, it will display theticket initialization dialog and exit; -m or —
ms2mit or —import will import tickets from the Microsoft Windows logon session (if available) and exit; -d
or -destroy will destroy all existing tickets and exit; -r or —renew will renew existing Kerberos tickets (if
possible) and exit; -aor —autoinit will display the ticket initialization dialog if you have no Kerberos
tickets.

Y ou may create a shortcut to Leash within your Windows Startup folder (Start M enu->Programs->Startup).
A shortcut to “Leash32.exe —autoinit” ensures that Kerberos tickets are available for the use of Kerberized
applications throughout your Windows logon session.

If Leash is not executed before using a Kerberized application, the application may prompt you for your
password. Some applications, like Ipr, never prompt you for a password. These applications simply
terminate with a message indicating that you are not authenticated. Before these applications can
successfully be used a separate program, such as L eash or kinit, must be used to first authenticate you using
Kerberos.

L eash does not perform alogon in the sense of the Windows Logon Service. A logon service would do
more than manage Kerberostickets. A logon service would authenticate you to the local machine, validate
access to your local file system and performs additional set-up tasks. These are beyond the scope of Leash.
L eash simply allows you to manage Kerberos ticketson behalf of compatible applicationsand to change
your Kerberos password.
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Leash Screen Display (Kerberometer and Dash Notification)

The window title contains the name “Leash” followed by the current date and time. Below thetitleare a
menu bar; atool bar (optional); atree view; and a status bar (optional).

2 Leash - Thursday, August 07, 2003 15:31 E]@

File Acton View Options Help
22 % @

Your Kerberos Tickets [lzsued/Expires/[Renew]/Principal]

= méialtman@ATHENﬁ.MlT.EDué
=] M K.erberos Four Tickets

Aug 07 1429 Aug0302:04  kibtgt ATHEMAMIT.EDUEATHENAMIT.EDU

=/ M Kerberas Five Tickets
I

DAUQ 071523 Aug0312:44  [Aug1412:23]  kibtgt/ATHENAMIT EDUGATHENS MIT.EDU [FRN

= D Aug 071529 Aug 021244 [Aug141229]  host/department-of-alchermy. mit edul@ATHEMA, MIT.EDL [FR]
Ticket Encrpption Type: DES-CEBC-CRC

Seszion Key Type: DES-CBC-CRC

For Help, press F1 Kerb-4 Ticket Life: 10:33  |Kerb-5 Ticket Life: 21:13

Theroot of the Leash tree view shows the active user principal name (user@REALM). Thisentry appears
witha"+" icon and aKerberosicon toitsleft. Click on this plusicon of aline to expand the branch,
displayinga"-" icon. To retract the branch click on the minussign.

Below user principal, the tree contains ticket categories. Below each ticket category are the current tickets
belonging to the group. Each ticket entry contains the current ticket status, the time it was issued, the time
it will expire, and the service principal and flags. For Kerberos 5 tickets, encryption types and network
addressinformation are listed below each ticket.

Thetree updates once per minute. If you need an immediate update of your ticket status, you can either
click in thewindow or the press the Update Display button on the toolbar.

On theright of the status bar is adisplay of the remaining time of your tickets (both Kerberos 4 and
Kerberos 5, as some programs obtain only Kerberos 4 tickets, these are not necessarily the same) in hours,
minutes, and seconds. This used to be known as the K er ber ometer

Each ticket is described and represented by an icon of alittleticket. The color of the ticket changes based
on itsviability:

green = normal

yellow = tickets are within 15 minutes of expiration

red = tickets have expired, or you have no tickets

gray = thesetickets are not available to you

At 15, 10, and 5 minutes before your Kerberos tickets expire, a screen pops up to warn that your Kerberos

tickets will expire soon and to give you the opportunity to renew them. This used to be known as Dash-
stylenotification.
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Leash Command Line Options

When Leash is executed from the command line one of the following command line options may be
specified:

-kinit, -i performs aKerberosticket initialization (and exits)

-ms2mit, -import, -m imports credentials from the Windows L ogon Session (and exits)
-renew, -r renews credentials (and exits)

-destroy, -d destroys credentials (and exits)

-autoinit, -aperformsticket initialization only if the credential cache is empty
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Leash Commands

File:
File Action View Options Help

%

From the File menu, you can use this command to exit the Leash program.

Lmportant Note..,

Exiting the Leash program will not destroy your current Kerberos tickets. Unless you have selected thisin
the options menu, you need to use the destroy tickets command.

Action:

File = Action View Options Help
Get Ticket(s) Cirl+T
Renew Ticket(s) Cirl+R
Import Ticket(s)/Token(s) Ctrl+I
Destroy Ticket(s) Ctrl+D

Change Password. ..

Reset Window Size/FPos
Synchronize Time
IUpdate Display F5

+
This command is found under the Action menu; it is also the first button (from the left) in the toolbar. Use
this command to obtain new Kerberos tickets (and perhaps AFS tokens).
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Initialize Ticket

é You are reguired to type your Kerberos Password

Mame: ]ialtmam|
Realm: [ATHENAMIT.EDU ]
Password: l

Ticket Lifetime: 1 dayis) 0 hour(z) 0 minute(s)

Kerberos 5 Options:
Iv Get tickets that can be forwarded to other machines
Iv Get tickets that can be renewed faor:

Renew Till: 6 dayiz) 21 haurs) 0 minute(s)
|
= D
Hide Options Cancel QK |
Wersion 2.5.0.1 Pt |

Copyright (C) 1953-2003 by the Massachusetts Institute of Technology

When you select this command, Leash displays a dialog requesting your Username, K erberos Realm, and
Password; if these are correct, Leash will obtain tickets for you. You may optionally specify aticket
lifetime and various Kerberos 5 ticket options: ticket forwarding, addressless tickets, and renewabl e ticket
times.

Renew Ticket(s)/Token(s) Command, Ctil+R

This command is found on the Action menu; it is also the second button (from the left) in the toolbar. Use
this command to renew the Kerberos tickets (and perhaps AFS tokens) on your local machine without
requiring the use of apassword. If your existing tickets cannot be renewed the ticket initialization dialog
will be displayed allowing you to request new tickets.

Note: Thiscommand isonly availableif your existing Kerberos tickets are renewable.

+
This command is found on the Action menu; it is also the third button (from the left) in the toolbar. Use
this command to import Kerberos tickets from your Windows Logon Session. Importing tickets will result
in the destruction of existing tickets. Leash will confirm the operation if necessary.

Note: Thiscommand isonly availableif your Windows Logon Session is authenticated using Kerberos.

Destroy Ticket(s)/Token(s) Command, Ctrl+D

This command is found on the Action menu; it is also the fourth button (from the | eft) in the toolbar. Use
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this command to destroy all of the Kerberostickets (and perhaps AFS tokens) on your local machine.
L eash confirms your intentions before completing the request. Tickets for individual services may not be
destroyed by the L eash application.

Oncetickets are destroyed, you must Get or Import new tickets before Kerberized applications can once
again access network services.

This command is found on the Action menu; it is also the fifth button (from the left) in the toolbar. This
command changes your Kerberos password.

-

C hange Password

% Change your Kerberos password or phrase

Mame: liahﬂarﬂ
Realm: |ATHENAMIT.EDU |

Old Password: I

Mew Password: ]

MNew Password {again): ]

Version 25.0.1 Cancel J ok |

Copyright {C) 1353-2003 by the Massachusetts Institute of Technology

Note: This command will not change your local machine password unless your Windows Logon Session is
authenticated using Kerberos.
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Y our passwords are the keys to many computers, from a bank machine to a multiuser mainframeto a
server on anetwork. Y our password helpsto prove that you are who you say you are, and ensures your
privacy.
Compromised passwords are the means by which most unauthorized (and unscrupul ous) people gain
access to a system. Someone logging on under your name has access not only to your computer files,
but to most of the facilities of the computer system. Since tampering can have far-reaching and serious
consequences, it's important to take to heart the following guidelines for choosing a password.
Do choose
* Something easy for you to remember with at least six characters.
* Something obscure. For instance, you might deliberately misspell aterm or use
an odd character in an otherwise familiar term, such as "phnybon" instead of
"funnybone." Or use a combination of two unrelated words or a combination of
letters and numbers.

* A combination of letters and numbers, or a phrase like "many colors" and then
use only the consonants "mnY c0l0rz."

* An acronym for your favorite saying, for example, "Llisn!" (Live! It's Saturday
Night!)

Don't choose:

* Your name in any form - first, middle, last, maiden, spelled backwards, nickname
or initials.

* Y our userid or your userid spelled backwards.

* Part of your userid or name.

* Any common name, such as Joe.

* The name of acloserelative, friend, or pet.

* Y our phone or office number, address, birthday, or anniversary.

*

Y our license-plate number, your social-security number, or any all numeral
password.

* Names from popular culture, e.g., spock, sleepy.

* Any word in adictionary.

* Passwords of fewer than four characters.
Mum'sthe Word

Never tell anyone your password -- not even your system administrator or account manager -- and don't
write it down. Make sure you have chosen a password that you can remember. And, finally, change
your password at regular intervals

Reprinted from i/s, Val. 4, No. 9,
May 1989. Revised March 1993.
Copyright C 1993 MIT Information Systems

Before You Begin...
Remember that passwords are case-sensitive, and note whether your keyboard has Caps Lock on. Leashis
not programmed to inform you about the state of your Caps Lock key.

How To Use Change Password..,
1. In Leash, click on the Change Password button (the one that has “***” and an arrow), type your
usernamein thefirst field of the dial ogue box.
Type your current password in the Old Password field.
Type your new password in the New Password field.
Retype your new password in the New Password (again) field to verify it
Press Enter or click OK.
The program checks the username and password you entered and notifiesyou if either isinvalid.

agrwN
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If you have entered the new password twice with consistent spellings, L eash replaces your old
password with the new, if it isa strong password. If Kerberos determines the password isweak, a
message notifies you, and you need to repeat steps 1 through 4 with a strong password, as
described by the "How To Choose a Password" guidelines above.

When you type into the password fields of the dialog boxcharacters are replaced with bullets. The program
accepts only printable characters for new passwords, i.e., characters between ASCII codes 0x20 and OX7E.

When you have entered the new password twice consistently, the program attempts to change the password
viaadialogue with the Kerberos administrative server. Some Kerberos sites, including MIT's Athena
environment, check the password's strength before allowing the change to take place and notifiesyouif it
determines that the password is weak.

When you select this from the Options menu, the Leash window movesto its default size and position, near
the upper left corner of the screen.

This command is found on the Action menu; it is also the sixth button (from the |eft) in the toolbar. When
you select this command, Leash synchronizes the local machine time with the time server specified in the
L eash Properties dialog.

Note: Kerberos authentication protocol requires loosely synchronized time between computers. The local
machine clock and the Kerberos server clock need to be within five minutes of each other for Kerberos to
function properly. This function can also be performed with the clock icon on the toolbar and has no
keyboard equivalent.

Use this command (in the Actions menu, or the black rectangular icon) to update the display of your current
Kerberostickets. You can also perform this function by clicking in the main Leash window.

Why Uselt.,

Although most end users will likely find this L eash feature irrelevant, application developers and support
staff may occasionally find it to be useful. For example, you may want an immediate status check of
Kerberosticketsif you have just used command-linekinit or kdestroy and want to check that they have
functioned successfully.

How It Works..,
While Leash automatically checks the status of your Kerberos tickets every 30 seconds, the Update Display

command forces an immediate status check.

View:
File Action Miew Options Help
v Large Icons
v Toolbar
v Status Bar
Debug Windaow

When this option is checked on the View menu, the icons and fonts in the main window (such as the picture
of Kerberos) will be about twice as big as the minimal icon and font size. Naturally, smaller icons allow
many more tickets to fit into a nonscrolling window. The default setting of Leashis Large Icons.
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Joolbar
By default, this option on the View menu is selected. When it is checked, the toolbar containing icons for
commonly used commandsisvisible. Otherwise, Leash hidesit.

Status Bar
The Status Bar is on by default; turning it off causes the bar at the bottom of the Leash window (with the
time remaining on any tickets that you might have) to disappear.

Debug Window

Leash Debug Window

Lag File Location: C:ADOCURE ~1%jaltmansLOCALS Copyral To Clipboard Cancel

When thisitem (found under the View menu) is checked, the Leash Debug Window appears. From this
window, commands that L eash issues to the Kerberos server are visible. Here, you can see exactly what
Leashisdoing. Thisaction isuseful if you are having a problem with Leash and want to see more exactly

what isgoing on, or if you are writing Kerberized applications dependent on Kerberos tickets or the actions
of Leash.

Note: Debugging is only supported by Kerberos 4 and AFS. Kerberos 5 protocol operations cannot be
debugged using L eash.

Options:
File Action View Options Help |
v Upper Case Realm Mame k
v Automatic Ticket Renewal

v Expiration Alarm
Destroy Tickets Tokens on Exit

Leash Properties... Cirl+L
Kerberos Properties. .. Cirl -+
Kerberos v4 Properties. .. Ctrl+4
Kerberos v5 Properties. ., Ctrl+5
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Upper Case Realm Name

The default for this (accessible from the Options menu) is on; when this option is selected, the Kerberos
realm name that you type (such as ATHENA.MIT.EDU) is converted to upper case regardless of how you

typeit.

ic Tict
When Automatic Ticket Renewal ison, whenever ticket are near expiration (within 15 minutes) Leash
will attempt to extend the ticket lifetime either viaticket renewal or ticket importation. If these attempts
fail, Leash will display the ticket initialization dialog. In thisway, Leash ensures that there are always
valid Kerberos tickets.

Leash will always pop up windows with warnings that your tickets are about to expire, beginning 15
minutes before the time of expiration and continuing every 5 minutes. However, when this option is
selected under the Options menu, abell will ring as well.

When you view your tickets and tokens, those shown in yellow are due to expire in less than 15 minutes,
those in green have 15 minutes or greater. (A red ticket is one you have but is expired; gray tickets are not
available to you at the current time, because Leash or your machine is missing arequisite module or piece
of functionality.)

ickets/ .
If this option is selected under the Options menu, L eash destroys your tickets and tokens when you shut
down L eash; otherwise, the tickets remain. This option isturned off by default.

+
The Leash Properties dialog, located on the Options menu, allows you to configure operational properties
specific to the L eash application which are not accessible directly via the Options menu.

-

Leash Properties

i~ Time Server

M arne: |time. mit, eduy

izcellaneous Dptions
[ Create Mizzsing Configuration Files

v Reguest Kerberos 4 credentialz

Bestore Leash Defaults ‘

Help Cancel | )%

Here you can set atime server from which Leash will obtain the correct time. Leash needs the correct time
because of the time dependenciesin Kerberostickets. When you specify atime server, Leash triesto get
the time from that server when you next run the Synchronize Time command. The default value for the
time server is"time". If accessto atime server wereto fail, Leash would notify you, and revert to the
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server "time". Whichever server succeeds, Leash would tell you whereit found thetime. Seethe
Synchronize Time command for more information.

The Kerberos libraries depend on configuration files for their proper operation. When Create Missing
Configuration Files is checked, Leash will construct replacements for missing configuration files upon
startup. Thisis performed by extracting Kerberos configuration information from the local Windows
registry and the Domain Name System. The contents of the created file may then be edited using the
Kerberos Properties Dialog.

When Request Kerberos 4 credentials is checked, Leash will attempt to retrieve Kerberos 4 credentials
when ticket initialization, renewal, or importation is performed. Leash will attempt a Kerberos 5 to
Kerberos 4 conversion and if that fails an initial Kerberos 4 ticket request will be generated. Kerberos
realms areincreasingly configured to support on Kerberos 5. If the realms you use do not support Kerberos
4 it is suggested that this button be unchecked.

The Restor e L eash Defaults button is used to restore user configurable Leash settings to the defaults as
configured either by the local machine system administrator or by the Kerberos for Windows distribution.

+
When you select this from the Options menu, Leash will bring up atabbed window. The box within this
window has four tabs: Default Realm Configuration; Ticket Lifetime; Realm/Server Mapping; and
DNS/Realm Mapping.

Default Realm Configuration

Kerberos Properties

Default Realm Corfiguration | Ticket Lfetime | Realm / Server Mapping | DNS / Realm Mapping ]
Kerberos Realm./Host Server
four Kerberos Realm:
ATHENAMITEDU |

four Kerberos Server:
|I-:erberos.m'rt.edu:EE

- Computer Host/Domain Name
four Computer’s Host Mame
[OMNIBOOK2

Your Computer's Domain Mame:
|.KH BS.COLUMEIAEDL

QK | Cancel ol Help W

Page 12



L eash User Documentation Release 2.5.0

There are two groups, the Kerberos Realm/Host Server and the Computer

Host/Domain Name.

Kerberos Realm/Host Server: Inthe Your Kerberos Realmfield, select a Kerberos
realm from the dropdown list. Thelist is editable using the Realm/Server Mapping tab,
below. Leash automatically fillsin your Kerberos server with the first server in the
“Servers Hosting aKDC” list on the Realm/Server M appings tab.

Computer Host/Domain Name: The field labeled Your Computer's Host Name displays
the name of your local machine. The Your Computer's Domain Name field displays
the domain to which your local machine currently belongs.

Ticket Lifetime

Kerberos Properties

Default Ticket Lifetime

Default Ticket Renewable Lifetime

Defautt Realm Corfiguration  Ticket Lifetime l Realm / Server Mapping ] DS / Realm Mapping ]

| Bd | Oh | Om | 75 OEN] O
i Ticket Lifetime Range Ticket Renew Till Range

~ Minimum Lifetime Minimum Renewable Lifetime

| 04 | 0h 5 m ] 0d | 104 | i
Maximum Lifetime Madmum Renewable Lifetime

] 14 ] 0h 0 m ] g ] 0h ] 0m

R

oK | Cancel | Help |

There are two expiration times associated with Kerberos tickets. Thefirst specifiesthe
length of the time period during which thetickets are valid for use. The second specifies
the length of the renewable lifetime. Valid Kerberostickets may have their valid use
lifetime repeatedly extended up until the renewable lifetime expires. The settings on this
page are used to configure default lifetime values for Leash to use when requesting
Kerberos tickets from the Kerberos server (key distribution center). The Kerberos server
may issue tickets with shorter lifetimes than were requested.

The minimum and maximum values are used by the ticket initialization dialog box when
constructing the Lifetime and Renewable Lifetime sliders. These sliders can be used to
modify the requested ticket lifetimes when Kerberos tickets are initialized.
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Real mv/Server Mapping

-,

Kerberos Properties

Defautt Realm Corfiguration 1 Ticket Lifetime  Realm # Server Mapping | DMS / Realm Mapping ]

Kerberos Realms Servers Hosting a KDC
ATHEMAMIT.EDU kerberos.mit.edu 88
CC.COLUMBIAEDU kerberos-1.mit 2du:38
KRBS.COLUMBIA.EDU kerberos-2 mit.edu:38
MEDIA-LAB MIT.EDU kerberos-3 mit edu:88
WIN.MIT.EDU

¥ Use DNS KDC Lookup

Bemove l Rename ‘

oK | Cancel Apphy Help

The Kerberos Realms list box is used to add, remove or rename realms from the local
Kerberos configuration files. To add anew realm, click on the Insert button beneath the
Kerberos Realms list box. In the dialog, type the name of the new realm and click OK.
However, for the realm to be inserted, it needs one or more servers. Immediately after
you enter the new realm name, you will be prompted for the names of one Kerberos
server in that realm. If you do not enter a server name, Leash will not insert the realm.

To add serversto an existing realm, select the realm from the Kerberos Realms list box
and click the Insert button under Servers Hosting aKDC list box. You will be prompted
for the name of the new server. Y ou can also remove servers, and designate either one or
none as the administrative server. (The administrative server isthe preferred server for
performing password changes.)

By clicking and dragging on the server that you want to move, you can change their
order; thisisimportant because the server listed at the top appearsin this window under
the Default Realm Configuration tab asthe valuefor Your Kerberos Server.

The Use DNS KDC L ookup checkbox is used to specify whether or not Kerberos should

utilize the domain name service to attempt to find Kerberos Servers when the existing
listed servers are not available.
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DNSRealm Mapping

-

Kerberos Properties

Defautt Realm Corfiguration i Ticket Lifetime | Realm / Server Mapping DNS / Realm Mapping I

cc.columbia.edu CC.COLUMBIAEDL

kemit .columbia edu KRBS COLUMBIA.EDU
media.mit. edu MEDIA-LAB.MIT.EDU
mit.edu ATHENAMIT.EDU

cc.columbia .edu CC.COLUMBIAEDU

media mit.edu MEDIA-LAB.MIT EDU

mit.edu ATHEMA.MIT.EDU

oK | Cancdl |  mpy | Hep

Each entry here consists of two portions: the domain name (such as.mit.edu) or hostname
(such as dialup.athena.mit.edu) followed by a space and the Kerberos realm (such as
ATHENA.MIT.EDU) which is used by that domain or machine. Y ou can insert new
entries, edit existing ones, or delete old entries.

+
The Kerberos v4 Properties dialog is accessible from the Options menu.
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(s T—
Kerberos Four Properties

Cliert File Location l

— Ticket File
MName: |APldrbdcc]

— Configuration File{s) Path

Corfig.:  |C:AWINNTerb.con Browse |

Realms:  [CAWINNT \krbrealm con Erowse

oK I Cancel aEply Help

Here, you can specify the name of the in-memory cache used to store the Kerberos 4 tickets. The format of
the nameis“API:” followed by the cache name. Disk caches are not supported by Kerberos for Windows.

The paths to the Kerberos 4 configuration files: krb.con and krbrealm.con may be changed from this dialog
if necessary. The default isto store the configuration filesin the Windows directory.

Kerberos v5 Properties Dialog, Ctrl+5
The Kerberos v5 Properties dialog is accessible from the Options menu. This dialog has two tabs: File
L ocation and Configuration Options.
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Kerberos Five Properties

File Location ]Cnrrfigumtiun Options 1

-Ticket File -
AP krb5ec]

Corfiguration File -

|C:"-.winnt"-J-:r|:- Bini Browse |

| [¥ Confirm that new configuration file exists.

QK | Cancel Spply Help

TheFile Location tab allows you to specify the location of the Kerberos 5 ticket cache and configuration
file. The Ticket Filefield specifies the name of the in-memory cache (Ticket File) used to store the
Kerberos 5 tickets. The format of the nameis“API:” followed by the cache name. Disk caches are not
supported by Kerberos for Windows. The Configuration Filefield specifiesthe path to the Kerberos 5
configuration file, krb5.ini. If Confirm that new configuration file exists is checked when the
configuration file location is changed, then Leash will not accept values which are not pre-existing
Kerberos 5 configuration files.
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o =,

Kerberos Five Properties =

File Location Configuration Options

Ticket Options

| Proxiable ¥ Fenewabls ¥ MNo Addresses

QK | Cancel iy Help

Iy

On the Configuration Options page, you provide default attribute val ues to be used when requesting
Kerberos 5 tickets from the Kerberos server.

When Forwar dable tickets are received from the Kerberos Server, these tickets can be forwarded to a
remote host when you connect viatelnet, ssh, ftp, rlogin, or similar applications. When tickets are
forwarded, there is no need to obtain Kerberos tickets again to access K erberized services on the remote
host.

When Proxiabletickets are received from the Kerberos Server, these tickets can be passed onto Kerberized
services which can in turn act on your behalf.

When Renewable tickets are received from the Kerberos Server, the ticket lifetimes may be renewed
without prompting the user for her password. This allows Kerberos tickets to be issued with short lifetimes
allowing compromised accounts to be disabled on short notice without requiring the user to enter a
password every few hours. When combined with Automatic Ticket Renewal (Option menu), Leash can
maintain valid tickets for aweek, a month, or longer by automatically renewing tickets prior to their
expiration. The ability to renew tickets without a password is limited by the ticket’s renewable lifetime as
issued by the Kerberos Server.

Traditionally, Kerberostickets have included alist of network addresses within the tickets. This address
list restricts the use of the tickets to the computers which are assigned those addresses. The use of address
lists has become a headache for many users of Kerberos on network connections which use either Network
Address Translation (Cable/DSL routers) or Network Address Hiding (VPN) capabilities. On these
networks the address of the client machine appears to be different to the network service than it does to the
client. Theresult isthe Kerberosticket is deemed to beinvalid by the service even though it has been
stolen. When No Addresses is checked, Kerberoswill not insert an address list into the Kerberos tickets.
For Kerberized services which do not require address lists, thiswill enable Kerberos to be used across NAT
and VPN based connections.
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Note 1: Asof Kerberos5 release 1.3, the library default isto disable the use of addresslists. Leash will
detect the setting from the Kerberos 5 configuration and check the No Addresses box. If you attempt to re-
enable address lists while the library is configured to disable them , Leash will warn you that the Kerberos
5 configuration file must be altered.

Note 2: Distributed Comp uting Environment (DCE) servers require the use of address lists.

+
The AFS Propertiesdialog can be found on the Options menu when AFSis available.

AFS Properties E|

" AFS Enabled " AFS Disabled

%)

AFS Properties Help Cancel | ]

Thereisaradio button pair to enable or disabletheretrieval of AFStickets. Thereisalso an AFS
Properties button to bring up the AFS Client Configuration program in order to alter settings for Client
Properties, Cell Hosts, and Submounts.

Help:

File Action View Options Help |
About Leash N

About Leash

When you access this window from the Help menu, you see aModulelist, three radio buttons, and a
Properties button. Modules are executables and dil files that L eash may require.

The radio buttons et you choose to view alist of:
- Leash Modules- displays the modules that L eash currently has loaded for its own use;
- All Modules- displays L eash modules aswell as those loaded by the OS;
- Missing Modules - displays modules that L eash needs for complete functionality but that are not
found. (Leash can still function with some modules missing.). Thisisuseful if part of Leashis

missing; you can find which files are needed to restore full functionality.

If you select amodule and click on the Properties button, L eash displays the properties of the selected
module - both the general properties and those of this particular version.
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Toolbar
e e 5 @)

The Leash Toolbar contains buttons which act as shortcuts to the most frequently used Actions found on
the Menubar. From left to right:

Get Tickets

Renew Tickets

Import Tickets

Destroy Tickets

Change Password

Update Display

Synchronize Time

Noahk~kwbdE
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Copyrights

L eash Copyright

This software is being provided to you, the LICENSEE, by the Massachusetts I nstitute of Technology
(M.1.T) under the following license. By obtaining, using and/or copyingthis software, you agree that you
have read, understood, and will comply with these terms and conditions:

Permission to use, copy, modify and distribute this software and its documentation for any purpose and
without fee or royalty is hereby granted, provided that you agree to comply with the following copyright
notice and statements, including the disclaimer, and that the same appear on ALL copies of the software
and documentation, including modifications that you make for internal use or for distribution:

Copyright 1992-2003 by the Massachusetts I nstitute of Technology. All rights reserved.

THIS SOFTWARE ISPROVIDED "ASIS", AND M.I.T. MAKES NO REPRESENTATIONS OR
WARRANTIES, EXPRESS OR IMPLIED. By way of example, but not limitation, M.I.T. MAKES NO
REPRESENTATIONS OR WARRANTIES OF MERCHANTABILITY OR FITNESS FOR ANY
PARTICULAR PURPOSE OR THAT THE USE OF THE LICENSED SOFTWARE OR
DOCUMENTATION WILL NOT INFRINGE ANY THIRD PARTY PATENTS, COPYRIGHTS,
TRADEMARKS OR OTHER RIGHTS.

The name of the Massachusetts I nstitute of Technology or M.1.T. may NOT be used in advertising or
publicity pertaining to distribution of the software. Title to copyright in this software and any associated
documentation shall at all timesremain with M.I.T., and USER agreesto preserve same.

Project Athena, Athena, Athena MUSE, Discuss, Hesiod, Kerberos, Moira, OLC, X Window System, and
Zephyr are trademarks of the Massachusetts I nstitute of Technology (MIT). No commercial use of these
trademarks may be made without prior written permission of MIT.

Kerberos Copyright

This software is being provided to you, the LICENSEE, by the Massachusetts I nstitute of Technology
(M.1.T.) under the following license. By obtaining, using and/or copying this software, you agree that you
have read, understood, and will comply with these terms and conditions:

Permission to use, copy, modify and distribute this software and its documentation for any purpose and
without fee or royalty is hereby granted, provided that you agree to comply with the following copyright
notice and statements, including the disclaimer, and that the same appear on ALL copies of the software
and documentation, including modifications that you make for internal use or for distribution:

Copyright 1992-2003 by the Massachusetts I nstitute of Technology. All rights reserved.

THIS SOFTWARE ISPROVIDED "ASI1S", AND M.I.T. MAKES NO REPRESENTATIONS OR
WARRANTIES, EXPRESS OR IMPLIED. By way of example, but not limitation, M.I.T. MAKES NO
REPRESENTATIONS OR WARRANTIES OF MERCHANTABILITY OR FITNESS FOR ANY
PARTICULAR PURPOSE OR THAT THE USE OF THE LICENSED SOFTWARE OR
DOCUMENTATION WILL NOT INFRINGE ANY THIRD PARTY PATENTS, COPYRIGHTS,
TRADEMARKS OR OTHER RIGHTS.

The name of the Massachusetts I nstitute of Technology or M.I.T. may NOT be used in advertising or

publicity pertaining to distribution of the software. Title to copyright in this software and any associated
documentation shall at all timesremain with M.I.T., and USER agreesto preserve same.
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Project Athena, Athena, AthenaM USE, Discuss, Hesiod, Kerberos, Moira, OLC, X Window System, and
Zephyr are trademarks of the Massachusetts Institute of Technology (MIT). No commercial use of these
trademarks may be made without prior written permission of MIT.

Kerberos Export Restrictions and Sour ce Code Access
Copyright (C) 1989-2003 by the Massachusetts I nstitute of Technology

Export of this software from the United States of America may require a specific license from the
United States Government. It isthe responsibility of any person or organization contemplating
export to obtain such alicense before exporting.

WITHIN THAT CONSTRAINT, permission to use, copy, modify, and distribute this software and its
documentation for any purpose and without fee is hereby granted, provided that the above copyright notice
appear in all copies and that both that copyright notice and this permission notice appear in supporting
documentation, and that the name of M.1.T. not be used in advertising or publicity pertaining to distribution
of the software without specific, written prior permission. M.I1.T. makes no representations about the
suitability of this software for any purpose. It is provided "asis" without express or implied warranty.

Export of the documentation is not restricted.
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Reporting Bugs and Requesting Assistance

If you find bugs, please mail them tokrb5-bugs@MIT.EDU.

kerberos@MIT.EDU isamailing list set up for discussing Kerberosissues. It is gatewayed to the Usenet
newsgroup ‘comp.protocols.kerberos.. If you prefer to read it viamail, send areguest to kerberos-
request@MIT.EDU to get added or subscribe viathe web page:

http://mailman.mit.edu/mailman/listinfo/kerberos
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Obtaining Kerberos for Windows Source Code and SDK

To retrieve the source code distribution or software development kit for Kerberos for Windows follow the
link to Download: Souces and binariesfrom MIT via authorization formfrom the web page
http://web.mit.edu/kerberos/.
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