# GUI_missileFlyout v2.01: User’s Guide

Geoff Forden  
30 May 2007

## Table of Contents

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Introduction</td>
<td>3</td>
</tr>
<tr>
<td>Installing GUI_missileFlyout</td>
<td>3</td>
</tr>
<tr>
<td>Using this Guide</td>
<td>3</td>
</tr>
<tr>
<td>Starting GUI_Missile_Flyout</td>
<td>4</td>
</tr>
<tr>
<td>A note of warning:</td>
<td>5</td>
</tr>
<tr>
<td><strong>File</strong></td>
<td>5</td>
</tr>
<tr>
<td>Save Trajectory</td>
<td>5</td>
</tr>
<tr>
<td>File → Save Trajectory → M File Output</td>
<td>5</td>
</tr>
<tr>
<td>File → Save Trajectory → Excel File</td>
<td>5</td>
</tr>
<tr>
<td>File → Save Trajectory → Google Earth File (.kml)</td>
<td>5</td>
</tr>
<tr>
<td>File → Input → Load Missile M File</td>
<td>6</td>
</tr>
<tr>
<td><strong>Help</strong></td>
<td>6</td>
</tr>
<tr>
<td>Help → About GUI_missileFlyout</td>
<td>6</td>
</tr>
<tr>
<td>Help → Help for GUI_missileFlyout</td>
<td>6</td>
</tr>
<tr>
<td><strong>Analysis</strong></td>
<td>6</td>
</tr>
<tr>
<td>Analysis → Maximize Range</td>
<td>6</td>
</tr>
<tr>
<td>Aim at Targets</td>
<td>6</td>
</tr>
<tr>
<td>Analysis → Aim at Target → Aim at Target in Space</td>
<td>7</td>
</tr>
<tr>
<td>Make a 2-D Plot</td>
<td>8</td>
</tr>
<tr>
<td>Analysis → Make a 2-D Plot → Make a 2-D Plot → Append Trajectory to Existing Polar Plot</td>
<td>8</td>
</tr>
<tr>
<td>Analysis → Make a 2-D Plot → Altitude vs Range</td>
<td>9</td>
</tr>
<tr>
<td>Analysis → Make a 2-D Plot → Plot Variable vs Time</td>
<td>9</td>
</tr>
<tr>
<td>Analysis → Make a 2-D Plot → Plot Variable vs Range</td>
<td>9</td>
</tr>
<tr>
<td>Analysis → Create a New 3D Plot</td>
<td>9</td>
</tr>
<tr>
<td><strong>Missile</strong></td>
<td>9</td>
</tr>
<tr>
<td>Flight Characteristics</td>
<td>9</td>
</tr>
<tr>
<td>Drag</td>
<td>9</td>
</tr>
<tr>
<td>Missile → Flight Characteristics → Drag → Enter a New Drag vs Mach Curve From Excel File</td>
<td>9</td>
</tr>
<tr>
<td>Missile → Flight Characteristics → Drag → Select Drag Coefficient</td>
<td>11</td>
</tr>
<tr>
<td>Lift</td>
<td>11</td>
</tr>
<tr>
<td><strong>Set Trajectory Integration Parameters</strong></td>
<td>11</td>
</tr>
<tr>
<td>Missile → Flight Characteristics → Set Trajectory Integration Parameters → Setup Earth Thrust Termination</td>
<td>11</td>
</tr>
<tr>
<td>Missile → Flight Characteristics → Set Trajectory Integration Parameters → Set Time for Integration</td>
<td>12</td>
</tr>
<tr>
<td><strong>Plot Aerodynamic Quantities</strong></td>
<td>13</td>
</tr>
</tbody>
</table>
Missile ➔ Flight Characteristics ➔ Plot Aerodynamic Quantities ➔ Plot Standard Drag Coefficients.......................................................................................... 13
Current Missile.................................................................................................................. 13

Save Current Trajectory ........................................................................................................ 14

Missile ➔ Current Missile ➔ Save Current Trajectory ➔ M File Output .............. 14
Missile ➔ Current Missile ➔ Save Current Trajectory ➔ Excel File ............. 14
Missile ➔ Current Missile ➔ Save Current Trajectory ➔ Google Earth File (.kml).................................................................................................................. 14
Missile ➔ Current Missile ➔ Save Current Trajectory ➔ Google Earth File Upto Time N ........................................................................................................ 15
Missile ➔ Current Missile ➔ Rename Current Missile ............................................... 15
Missile ➔ Current Missile ➔ Copy Current Missile to a New Name...................... 16

Reference Material........................................................................................................ 17

Missile ➔ Current Missile ➔ Reference Material ➔ Input Missile Model References........................................................................................................ 17
Missile ➔ Current Missile ➔ Reference Material ➔ Display Reference......... 18
Missile ➔ Current Missile ➔ Reference Material ➔ Print Missile Parameters to Text File ........................................................................................................ 18

New Missile .................................................................................................................. 20

Missile ➔ New Missile ➔ Create New Missile From Panel................................. 20
Missile ➔ New Missile ➔ Load Missile M File ...................................................... 20

Tools............................................................................................................................. 21

Convert Degrees Minutes Seconds to Decimal Degrees........................................ 21

Tools ➔ Convert Degrees Minutes Seconds to Deg ➔ Launch Site Latitude .... 21
Tools ➔ Convert Degrees Minutes Seconds to Deg ➔ Launch Site Longitude.... 22
Tools ➔ Convert Degrees Minutes Seconds to Deg ➔ Target Latitude............ 22
Tools ➔ Convert Degrees Minutes Seconds to Deg ➔ Target Longitude......... 22
Tools ➔ Convert Degrees Minutes Seconds to Deg ➔ Find Range and Azimuth (use Decimal Deg.)............................................................ 22
Tools ➔ Convert Degrees Minutes Seconds to Deg ➔ Find X,Y,Z given latitude/longitude .......................................................................................... 22

Launch Site................................................................................................................. 23
Launch Site ➔ Load Launch Site............................................................................... 23
Launch Site ➔ Save Launch Site ............................................................................... 24
Launch Site ➔ Input Launch Site in Deg-min-seconds ........................................ 24

Changes from Previous Versions................................................................................. 24

Changes from v2.0........................................................................................................ 24
**Introduction**

This file represents a user guide for the current version of GUI_missileFlyout. It was written by a physicist and not a computer scientist so it might not be written in the optimal computer language. It should be viewed more as a confidence building measure than a true reference. When you try something in the program, and trying different things is the best way of learning what it does, you might feel reassured by seeing similar screens reproduced here. More detail on the physics being simulated by the program can be found in the paper “GUI_Missile_Flyout: A General Program for Simulating Ballistic Missiles” by Geoffrey Forden, to be published in Science and Global Security.

**Installing GUI_missileFlyout**

GUI_missileFlyout is contained in a self-extracting file that can be downloaded from [http://mit.edu/stgs/downloads](http://mit.edu/stgs/downloads). This file is called GUI_missileFlyout_x_pkg.exe. When this program is run, it extracts four files:

- GUI_missileFlyout_x.exe (the application itself)
- GUI_missileFlyout_x.ctf
- MCRInstaller.exe

You should also download the data file landareas.shp from the same website. This file, which contains the outlines of the continents for plotting polar plots of the trajectories, should be placed in the same directory as the application file.

The install program, MCRInstaller.exe, is also automatically run and sets up the MATLAB directories needed in the program GUI_missileFlyout_x. The file GUI_missileFlyout_x.ctf must be placed in the same path as the executable image (the easiest solution is to keep it in the same directory as the program is being run).

**Using this Guide**

Most of this guide goes through the different commands available on the tool bar menu, command by command. To indicate which command is being discussed, the notation File ➔ Save Trajectory ➔ M File Output is used to indicate that inside the pull down menu “File,” select the “Save Trajectory” option that in turn allows you to select the “M File Output” command. This is illustrated below:
Starting GUI_Missile_Flyout

When GUI_Missile_Flyout starts, by for instance double clicking on the icon, then it opens two windows: a dos or command prompt window and a Graphical User Interface (GUI). Closing either window shuts down the program. The dos window is an artifact of running standalone MATLAB programs though it does display some information generated during the integration of the equations of motion.
Data used to parameterize the missiles, stage and fuel weights, engine Isp etc, can be inputted in the GUI. These are grouped according to stages, the payload, and the launch site. Also, four missiles (a Soviet SCUD-B, an Iraqi Al Hussein, a North Korean Nodong and Taepodong I missiles) are preloaded and can be selected from the pulldown menu at the top left (see Figure 2). Until a simulation is run, by pressing the “Launch Missile” button, the select plot pull-down menu (in the Results plot panel) is disabled and the range is blank. Once a simulation has been run, then different plots can be selected and a range is shown just above the “launch missile” button.

A note of warning:
This program can appear fairly slow on some computers. Do not get overly worried if it takes a few minutes to start up the program, especially the first time.

File
Save Trajectory

File ➔ Save Trajectory ➔ M File Output
A number of important quantities calculated during the missile simulation are saved to an M-file that can be further analyzed in MATLAB.

File ➔ Save Trajectory ➔ Excel File
A number of important quantities calculated during the missile simulation are saved to an M-file that can be further analyzed in EXCEL.

File ➔ Save Trajectory ➔ Google Earth File (.kml)
The trajectory (latitude, longitude, and altitude) are saved in a format that Google Earth can read and display. This option is used for visualization purposes. Once the file has been created, enter Google Earth and then open the file just created (ctrl+o in Google
Earth will bring up a dialog box to browse for the file you created in GUI_missileFlyout_x.exe.

File ➔ Input ➔ Load Missile M File
If you, or a colleague, have previously saved a missile parameterization generated by this program, you can read it in using this command. A “find file” dialog box appears that lets you select the file.

Help

Help ➔ About GUI_missileFlyout
Gives a very brief note about this program

Help ➔ Help for GUI_missileFlyout
Refers the reader to this User Guide

Analysis

Analysis ➔ Maximize Range
Once the missile model has been inputted, its trajectory must be optimized for maximum range (alternatively, it can be aimed at a specific target location on or above the Earth’s surface, see below). The program maximizes the range for a given launch azimuth (which is entered on the panel) by varying the “loft angle” (basically, the angle the thrust makes with the vertical) and the “loft angle rate” (how quickly the missile pitches over from vertical flight). When the command is selected, a warning box appears reminding the user that this will take a long time. The range is maximized by a brute force method of varying the two parameters and performing a complete trajectory integration for each set of parameters. Thus, the amount of time it takes to maximize the range increases with increasing range.

Aim at Targets
Analysis ➔ Aim at Target ➔ Aim at Target on the Ground
This command will allow you to aim the missile at a target on the ground. The program will determine the appropriate “launch azimuth”, “loft angle”, and “loft angle rate.” When selected, the command produces a dialog box where you can enter the latitude and longitude of the target. These have to be entered in decimal degrees and not degrees, minutes, and seconds. If it is easier to enter these in degrees, minutes, and seconds, use the appropriate command under the Tool menu. The program does not adjust the burn time so the resulting trajectory is guaranteed to be either lofted or depressed; which will be determined by the initial trajectory. However, if your target is greater than the maximum range of the missile, the program will only get as close as possible in the maximum allowed number of iterations (currently set to 30).

Analysis ➔ Aim at Target ➔ Aim at Target in Space
There are often times when it is interesting to aim at a fixed point in space (for simulating missile defense engagements or anti-satellite weapons, for instance). This command allows you to do that. Pressing this command, does a very similar optimization as in aiming for a target on the ground (with some of the same idiosyncrasies as that command has). This time, however, the dialog box has a slot for target altitude, which should be entered in kilometers. Note that if you intend to visualize this trajectory using Google Earth, you might find it more visually effective to use this command even when aiming at a point on the surface of the Earth. Otherwise, it is possible that the trajectory will appear to miss the target because Google Earth represents 3-D terrain.
Make a 2-D Plot
Analysis ➔ Make a 2-D Plot ➔ Make a 2-D Plot ➔ Polar Plots of Trajectories
This command shows the trajectory as a track in a polar plot (gnomic projection). You must have the file `landareas.shp` in the same directory that you are running the program in.

Trajectory plotted in a polar projection.

Analysis ➔ Make a 2-D Plot ➔ Make a 2-D Plot ➔ Append Trajectory to Existing Polar Plot
If you have already plotted a trajectory on the polar plot and want to superimpose a
different trajectory on the same plot (to show, for instance, a large scale missile attack),
then you need to use this command to plot additional trajectories on the same polar plot.
If you use the “Polar Plots of Trajectories” a second time, the program creates a second
polar plot with only the current trajectory on it.

Analysis ➔ Make a 2-D Plot ➔ Altitude vs Range
This plot is used often enough that it gets its own easy-access command.

Analysis ➔ Make a 2-D Plot ➔ Plot Variable vs Time
A number of trajectory quantities can be plotted vs time after liftoff. These variables are:
altitude, acceleration, missile mass, missile speed, that part of the acceleration caused by
aerodynamic drag, and range.

Analysis ➔ Make a 2-D Plot ➔ Plot Variable vs Range
A number of trajectory quantities can be plotted vs time after liftoff. These variables are:
altitude, acceleration, missile speed, and that part of the acceleration caused by
aerodynamic drag.

Analysis ➔ Create a New 3D Plot
Not yet implemented.

**Missile**

**Flight Characteristics**
The default flight characteristics of the missile, zero angle of attack (i.e. no lift) and a
simplified drag vs. Mach number behavior, can be changed. The simplest change is to
give a new and less idealized drag response to speed. This is supplied via two equal size
arrays; one containing the speed points and the other the Cd corresponding to each speed
point. Since this is a three degree of freedom calculation

**Drag**

Missile ➔ Flight Characteristics ➔ Drag ➔ Enter a New Drag vs Mach Curve ➔ From
Excel File

A user might want to use a function describing the aerodynamic drag coefficient tailored
to his specific rocket. If so, he can create an Excel file containing two columns, the first
contains the Mach numbers at which a Cd value is known. These must increase
monotonically and not contain any repeats! The second contains the corresponding Cd
number. Note that there **must** be an equal number of elements in these two columns.
(The program does not check this and will either crash or produce unreliable results if the
numbers do not agree.)
When the command is issued, a dialog box appears allowing the user to browse for the file containing the drag curve. After that is read in, another dialog box appears requesting a name for the new curve. If cancel is pressed at either of these steps, the curve is not saved and will not be available for use. The last curve read in is the new default curve for the Cd function. The program uses an interpolation between existing points on the curve. If a missile velocity is less than the lowest Mach number supplied, the Cd for that lowest point is used. If a missile velocity is greater than the largest Mach number, the Cd for the largest supplied Mach number is used.
Missile ➔ Flight Characteristics ➔ Drag ➔ Select Drag Coefficient

The user can change the drag vs. Mach curve of the missile with this command. The program comes with two pre-loaded alternative curves. By default, the program uses the “Simple Triangle Cd Function.” However, it also has pre-packaged a smoother function called “Slightly More Sophisticated Cd Curve.” If the user has loaded a custom drag curve using the command “Enter a New Drag vs Mach Curve” then that curve also appears as a possibility.

Lift

As of this version, these options, which are all related to introducing lift into the missile model or changing how lift is used, are not recommended for non-experts and are not covered in this guide. (They are also still under development.)

Set Trajectory Integration Parameters

Missile ➔ Flight Characteristics ➔ Set Trajectory Integration Parameters ➔ Setup Earth Thrust Termination
The burn time entered into the panel for each stage is assumed to be the time it takes to consume the entire amount of fuel. If the user is modeling something like a boost phase missile defense system at terminates the thrust early (when there is still fuel left in the missile) he would get the wrong answer by setting that panel burn time to the early thrust termination time (and, in fact, the program would simply continue with an upper stage). To terminate the missile early, this command needs to be invoked. When it is, a dialog box appears asking for the new thrust termination time.

A note of warning: unfortunately, this is the most user unfriendly aspect of the program since you can set this to an early thrust termination time and forget that is what is happening. This value does not appear anywhere else in the program and you need to invoke the command just to check the current value. If you set this value, it will remain in the missile when saved or when you copy the missile to a new name. So be careful!

Missile ➔ Flight Characteristics ➔ Set Trajectory Integration Parameters ➔ Set Time for Integration
The default integration time for the trajectory is 1 second. Some may view this as too long but it is a compromise (as are many things in this program) to make it more user friendly in the widest number of situations. In particular, changing this to ½ a second would double the number of integration points along the trajectory and double the computer time it takes to solve for a trajectory. In particular, it would double the (already long) time it takes to optimize the flight trajectory. However, if the user believes its important have a very accurate integration of the equations of motion, then he can use this command to change it. When the command is invoked, a dialog box appears asking for the new integration time. The only way to find out what this value is, is to invoke the command since the current value appears as the default value in the dialog box.

Missile ➔ Flight Characteristics ➔ Set Trajectory Integration Parameters ➔ Set Start Time for Pitch Program.
The default is to start the pitch-over toward the target right at launch. This, however, is not what most missiles do. Instead, they wait a fixed amount of time (10 seconds for instance) before starting the pitch-over. This allows the rocket to rise above a certain amount of the atmosphere and reduce forces ending to bend the missile. Emperically, setting this start time has little effect on most of the missile’s trajectory but could, in principle, effect characteristics close to the launch point.
Plot Aerodynamic Quantities
The program allows the user to not only input various new aerodynamic quantities (such as Cd or lift coefficients) but also to plot them.

Missile ➔ Flight Characteristics ➔ Plot Aerodynamic Quantities ➔ Plot Standard Drag Coefficients
When this is invoked, the current Cd function is plotted as a function of Mach number. The same algorithm (i.e. interpolation etc.) is used to plot the values as is used to calculate the drag.

The lift quantities can also be plotted but these commands are disabled until lift is turned on.

Current Missile
Missile ➔ Current Missile ➔ Save Current Missile
The matlab file containing the parameters needed to simulate the missile can be saved to disk. In order to organize these and not clutter up directory, the program asks the user if it can create a default subdirectory to store the models in (the name of the default directory is …/missile_models.) If this directory does not exist in the current directory,
then the program asks the user if it can create it. (Otherwise, the program skips this part and goes directly to saving the missile model in the default directory.)

If the user selects “yes” then the directory is created; if “no” is selected, then the default directory is not created and the user can save the model to an existing directory. Selecting “cancel” is the same as selecting “no.” The next dialog box to appear is a browser to save the file in.

The default name of the missile parameter file is `missileName_model.mat`, though that can of course be changed. (But leave the extension as *.mat) If that file already exists, the user will be asked if he wants to overwrite it or cancel the save.

**Save Current Trajectory**

Missile ➔ Current Missile ➔ Save Current Trajectory ➔ M File Output

A number of important quantities calculated during the missile simulation are saved to an M-file that can be further analyzed in MATLAB.

Missile ➔ Current Missile ➔ Save Current Trajectory ➔ Excel File

A number of important quantities calculated during the missile simulation are saved to an M-file that can be further analyzed in EXCEL.

Missile ➔ Current Missile ➔ Save Current Trajectory ➔ Google Earth File (.kml)
The trajectory (latitude, longitude, and altitude) are saved in a format that Google Earth can read and display. This option is used for visualization purposes. Once the file has been created, enter Google Earth and then open the file just created (crl+o in Google Earth will bring up a dialog box to browse for the file you created in GUI_missileFlyout_x.exe.)

**Missile ➔ Current Missile ➔ Save Current Trajectory ➔ Google Earth File Upto Time N**

Same as “Google Earth File (.kml)” command except it only saves the trajectory up to the Nth point along its trajectory. This can be useful for visualizing missile intercept trajectories etc. where the program continues to integrate the trajectory after a point in space of interest. (For instance, the program continues to integrate the trajectory until it intersects the surface of the Earth when aiming at a point in space. This is wasteful of computer power but less demanding of programmer time.)

When invoked, this command brings up a dialog box asking for the end point of the trajectory to be visualized in Google Earth. Note that the default value is the last point in the trajectory.

**Missile ➔ Current Missile ➔ Rename Current Missile**

The user can replace the current missile’s name with a new one. This might be useful if you make a minor change rather than make a whole new model; you could for instance change the propellant’s Isp to see what would happen if you improved the fuel mix.) When you invoke the command, a dialog box appears so you can enter a new name. The default name is the same as the old name.
Missile ➔ Current Missile ➔ Copy Current Missile to a New Name
It is sometimes desirable to copy an existing missile model into a new name. This could prove useful if you use one missile as the first stage of a new model, such as copying a Nodong to form the first stage of a Taepodong 1.
Dialog box for new name

**Reference Material**
Missile ➔ Current Missile ➔ Reference Material ➔ Input Missile Model References

This command brings up a dialog box where the creator of a missile model can explain how the parameters were created. Eventually, a website will be setup where users can exchange these models. **No one will download a missile model unless they understand how it was created so it is to the user’s own benefit that this is filled in as completely as possible.**
Missile ➔ Current Missile ➔ Reference Material ➔ Display Reference
This command displays the information the missile model creator should have inputted to explain how the parameters were.
This command prints the information about the missile’s parameters in a user-oriented fashion; including the reference material.

Here is the resulting text file for the CSS-2:

**Missile Name:** CSS_2

**Number of Stages:** 1  
**Payload:** 1000 (kg)  
**Missiles Mass Ratio:** 0.888359

**Missile References:**
- Article the model is based on: 'see description'
- Authors: 'Geoff Forden'
- Journal: 'see description'

**Description of Method for Determining Model:**
- 'From the Encycloedia Astronautica:
  - 'The DF-3 uses RFNA and UDMH
  - 'Thrust = 1,224,000 N'
- 'From Rocket propulsion Elements, 7th Edition, by Sutton and Biblarz:
  - 'Isp=279 s (for RFNA and UDMH)'
- 'calculating dw/dt from this give 460.9 kg/s'
- 'From Long March 2-C User's Guide, p. 3-1:
  - 'Burn time=120 s'
- 'This gives 55,305 kg for fuel mass.'
Assuming a mass fraction of 0.9 for the 1st stage (without the GNC etc.):

total mass = 61,450 kg

the Encyclopaedia Astronautica give the total CSS-2 mass as 64,000 kg

These give the combined mass of the guidance and control and payload for the missile as 2,550 kg.

I assume that the warhead is 1,550 kg

so the GNC should be added to the dry weight of the missile is

1,550 + 1,000 + (61,450-55,305) = 8,695

Stage 1 Parameters:
Stage Diameter (m): 2.25 (m)
Isp: 276 (s)
Propellant Mass: 56855 (kg)
Stage mass (with fuel): 63000 (kg)
Burn time 120 (s)
Mass fraction for this stage: 0.90246
Thrust 130.678 (tons)

Launch site Latitude -44.4 Longitude -2.3

Loft Angle: 47.6563 Loft Angle Rate: 1.348

New Missile
Missile ➔ New Missile ➔ Create New Missile From Panel
The command adds a new missile to the “Missile Type” pull down menu and sets it to the current missile so that its parameters can be entered manually from the panel. A dialog box appears asking for the new missile name.

Missile ➔ New Missile ➔ Load Missile M File
This command opens a dialog box to browse for pre-existing missile files. These files could have been, for instance, downloaded from the web or created by a the user and saved during a previous run of the program. If it exists in the current directory, the
program looks for the default missile model directory: 

\[ .../missile_models/*.mat \]

(The default missile file name when a missile is saved is

\[ .../missile_models/missileName_model.mat \]

Tools

Convert Degrees Minutes Seconds to Decimal Degrees

Geographic locations are often given in terms of Degrees, minutes, and seconds of arc (often written as in \(5^\circ 36' 45"\)). These tools give the user the means to easily convert those units into decimal degrees (\(5^\circ 36' 45" = 5.6125\) decimal degrees).

Tools ➔ Convert Degrees Minutes Seconds to Deg ➔ Launch Site Latitude

This command brings up a dialog box that allows the user to enter the launch site latitude in (degrees, minutes, seconds)
Tools ➔ Convert Degrees Minutes Seconds to Deg ➔ Launch Site Longitude
This command brings up a dialog box that allows the user to enter the launch site longitude in (degrees, minutes, seconds)

Tools ➔ Convert Degrees Minutes Seconds to Deg ➔ Target Latitude
This command brings up a dialog box that allows the user to enter the target latitude in (degrees, minutes, seconds)

Tools ➔ Convert Degrees Minutes Seconds to Deg ➔ Target Longitude
This command brings up a dialog box that allows the user to enter the target longitude in (degrees, minutes, seconds)

Tools ➔ Convert Degrees Minutes Seconds to Deg ➔ Find Range and Azimuth (use Decimal Deg.)
It is often helpful to know how far away a target is. This tool calculates the range (and azimuth) of a second point (as distinct to the point in the target position) from the launch site.

Tools ➔ Convert Degrees Minutes Seconds to Deg ➔ Find X,Y,Z given latitude/longitude
The program uses an internally consistent Cartesian coordinate system that is different from other systems in common use. (Latitude and longitude, which are normally how users would interface with other systems, are the same as is conventionally used.) It is sometimes useful to be able to quickly calculate the X, Y, Z coordinate of a third point, say the position of an Airborne Laser aircraft, so that distances from different points along the trajectory can be calculated (saving the trajectory to an excel file also saves the
x, y, z coordinates of the trajectory as a function of time.) Invoking the command produces a dialog box that asks for the third point’s latitude, longitude, and altitude above the Earth’s surface. When these are entered, a second dialog box appears giving the third point’s x, y, and z.

Launch Site

I have spent a considerable amount of time looking for launch sites around the world via Google Earth and entering them as launch sites usable by this program. The resulting launch sites are usually pin-pointed to an actual launch pad and can be read into the program via this command. In order to keep the directory orderly, the program first looks for the default subdirectory, …/launch_sites, if that doesn’t exist the user can use the resulting dialog box to browse for the files. These launch sites are available on the GUI_missileFlyout (http://mit.edu/stgs/downloads.html) website.
Launch Site ➔ Save Launch Site
If you create your own launch site (through the panel), you can save it to disk for future use (the current missile you are working on will also save the launch site with itself but not as a separate file).

Launch Site ➔ Input Launch Site in Deg-min-seconds
By now, you should understand what this does and how to do it.

Changes from Previous Versions

Current Version = 2.02

Changes from v2.01
1. fixed bug in aiming at a target that resulted in the error message “Input argument "handles" is undefined”

Changes from v2.0
1. fixed bug with Missile ➔ New Missile ➔ Create New Missile From Panel
2. implemented “Missile ➔ Flight Characteristics ➔ Drag ➔ Enter a New Drag vs Mach Curve” command.
3. fixed bug with inputting missile reference data.
4. added feature to include a time after launch to start the pitch-over program.