Using FrameMaker®
for your Thesis

Prerequisites:
• Introduction to FrameMaker
• and some experience using FrameMaker

Instructor:

Athena® Training Group

Copyright © 1996 the Massachusetts Institute of Technology
© Athena is a registered trademark of the Massachusetts Institute of Technology.
© FrameMaker is a registered trademark of Frame Technology Corporation.
What This Course Will Cover

- FrameMaker features for a Thesis
- Getting the Thesis template
- Using the Thesis template
- Printing a thesis
- General Thesis Hints
- Sources of Additional Help

NOTE: Even though this course is about using the MIT Thesis template files, you will learn the basics of using FrameMaker for any large document. More information sources are listed at end.
What You Should Already Know

• Starting FrameMaker

• New Files: Choosing and Using a Template

• Files:
  • Opening existing documents
  • Saving
  • Printing

• Using Simple Formatting Features
  • Footnotes
  • Inserting and modifying graphics, tables, figures, equations

• Using the On-Line Manual

These are all covered in the Introduction to Frame minicourse.
Why Use FrameMaker for your Thesis

- The MIT Thesis requirements are strict.
- FrameMaker thesis template conforms to the MIT thesis specifications.
- Lets you concentrate on content of your thesis, instead of appearance.
- Makes revisions much easier.
- Automatically provides:
  - Title and Abstract pages
  - Table of Contents
  - Lists of Figures, Tables
  - Numbering of chapters, appendices, sections, pages, figures, tables, and equations
- Assists in formatting of:
  - Footnotes
  - Bibliography
  - Quotations
  - Citations,
  - Cross-referencing of text and figures.
Getting the Thesis Files -- 1
Copy These

athena% cd

athena% mkdir thesis

athena% attach thesis


athena% cp /mit/thesis/frame/README thesis/

If you don’t understand what these commands mean, be sure to take our Working on Athena minicourse!
Getting the Thesis Files -- 2
From the Templates

`add frame; maker`
`starting maker ...`
maker: Using /mit/frame/sun4release/fminit
maker: Starting FrameMaker 4. Copyright (c) 1986-1994
Frame Technology Corp.
maker: Finished loading

`File ➔ New...`

![File New dialog box](image)

Contributed ➔ Thesis
Getting the Thesis Files -- 3
From the Templates (cont’d)

New
Use Blank Paper:
- Portrait
- Landscape
- Custom...

Use Template:
abstract.doc

../ (Go up 1 directory level)
Frame3.1/
abstract.doc
chapter.doc
cover.doc
RCS
README
thesis.book

2 Directories, 10 Files

Create
Cancel
Help

chapter.doc
cover.doc
abstract.doc

Creating a new document from a FrameMaker version
3 document: abstract.doc. OK to continue?

Choose OK
Getting the Thesis Files -- 4
What you’ll have

```
ls

README  cover.doc  thesisLOT.doc
chapter.doc  thesisLOF.doc
```

• **README** -- brief directions for getting and using these files.
• **abstract.doc** -- template for the abstract pages
• **chapter.doc** -- for body of thesis (chapters and appendices)
• **cover.doc** -- template for title page
• **thesis.book** -- holds all the pieces together

Created/Updated automatically:
• **thesisLOF.doc** -- list of figures
• **thesisLOT.doc** -- list of tables
• **thesisTOC.doc** -- table of contents
Editing a Template File

Unlike the usual templates, MIT Thesis is not empty. You can use the pre-existing fields -- DON'T start by deleting them:

- Click on a paragraph,
- Type some of your replacement text,
- THEN delete the rest of the dummy paragraph.

This will help you see how the various paragraphs formats are used.
# Paragraph Styles

## abstract.doc

<table>
<thead>
<tr>
<th>Text</th>
<th>Paragraph Format</th>
</tr>
</thead>
<tbody>
<tr>
<td>Title</td>
<td>AbstractTitle</td>
</tr>
<tr>
<td>by</td>
<td>AbstractCenter</td>
</tr>
<tr>
<td>author</td>
<td>AbstractCenter</td>
</tr>
<tr>
<td>Submitted to...</td>
<td>AbstractSub</td>
</tr>
<tr>
<td>“Abstract”</td>
<td>AbstractLabel</td>
</tr>
<tr>
<td>Actual text of abstract</td>
<td>AbstractText</td>
</tr>
<tr>
<td>Supervisor</td>
<td>AbstractSupervisor</td>
</tr>
<tr>
<td>Supervisor Title</td>
<td>AbstractSup.Title</td>
</tr>
</tbody>
</table>

**Abstract Page Paragraph Formats**
Paragraph Styles

cover.doc

<table>
<thead>
<tr>
<th>Title Page Entry</th>
<th>Paragraph Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>Title</td>
<td>ThesisTitle</td>
</tr>
<tr>
<td>by</td>
<td>centered</td>
</tr>
<tr>
<td>your name</td>
<td>Author</td>
</tr>
<tr>
<td>Submitted to...</td>
<td>Submission</td>
</tr>
<tr>
<td>Degree</td>
<td>Degree</td>
</tr>
<tr>
<td>at the</td>
<td>AtThe</td>
</tr>
<tr>
<td>MIT</td>
<td>MIT</td>
</tr>
<tr>
<td>Date</td>
<td>Date</td>
</tr>
<tr>
<td>Copyright</td>
<td>copyright</td>
</tr>
<tr>
<td>Author’s signature</td>
<td>AuthorSig</td>
</tr>
<tr>
<td>department and titles</td>
<td>Department</td>
</tr>
<tr>
<td>Supervisor</td>
<td>CertifiedBy</td>
</tr>
<tr>
<td>Department Head</td>
<td>AcceptedBy</td>
</tr>
</tbody>
</table>

Paragraph Formats for Cover Page

Unless you are in Course 6 or 8, you can just fill this in “as is” -- your thesis is Copyright MIT.

Course 6 and 8: You hold the copyright to your thesis, with some rights granted to MIT. The cover template has special “conditional text” to handle this...
Conditional cover.txt

Special ➔ Conditional Text...

Click Show/Hide... button to bring up the Show/Hide dialog box....
Using the Show/Hide Box

- Select items; move them between the **Show** and **Hide** boxes with the arrows.
- When they’ve been swapped, click on **Set**
How to Write a Thesis in Frame That Conforms to MIT Specifications

by

{Your Name Here}

Submitted to the Department of {Your Department Here}
in partial fulfillment of the requirements for the degree of

{ Your Degree Here}
at the

MASSACHUSETTS INSTITUTE OF TECHNOLOGY

{Date variable here}

© {Your Name}, 1993

The author hereby grants to MIT permission to reproduce and distribute publicly paper and electronic copies of this document in whole or in part, and to grants others the right to do so. All rights reserved.

Author

{Your Department Here}

Date Submitted

Certified by

{Advisor's Title Here}

{Advisor's Department Here}

Thesis Supervisor

Accepted by

{Name of Department Head}

{Title}
This file is for the body of your thesis. Click in a paragraph to see its name. Follow the examples in the file.
Copies of chapter.doc

Instead of changing `chapter.doc`, make copies of it and use one copy for each chapter of your thesis:

```
  athena% cp chapter.doc chapter1.doc
  athena% cp chapter.doc chapter2.doc
  athena% cp chapter.doc chapter3.doc
  ...
```

Two things to keep in mind:

- Add these new file names to the “book” file.
- `chapter1.doc` will need one small change.

We’ll cover both of these later.
An Appendix or Two

*chapter*.doc can be copied for appendix files, too:

```
athena% cp chapter.doc appendixA.doc
athena% cp chapter.doc appendixB.doc
```

...and so on

Be sure to use the *Appendix1, Appendix*, and the other appendix ¶ formats instead of the usual *Chapter* ones.

There are examples of this in *chapter*.doc.
Typical Thesis Stuff: cross-references

A “cross-reference” links a reference (eg: See “Parts List” on page 23) to other text, usually a chapter or section header.

• Start by putting the text cursor where you want the reference to appear...
Cross-References (cont’d)

...add some handy parentheses if appropriate, and then:

Special → Cross-Reference...
Cross-References (cont’d)

Use pop-up menus and scroll-bar menus to select:

1. **Source Document**: Which file contains the item being referenced? (That other file must also be open.)
2. **Source Type**: What kind of paragraph is being referenced?
3. **Reference Source**: Select the item being referenced.
4. **Format**: What should the reference look like?

Then select **Insert**

Note: You can update cross-references, define new formats and more. See Chapter 10 of the FrameMaker manual.
Typical Thesis Stuff: Bibliography

Two methods of doing a Bibliography or References page.

• Do it by hand:
  • Type in the information
  • Use the Paragraph format **Bibliography Entry**
  • For book titles, use the Character format **Emphasis**.
  • Advantage: You can get exactly what you want.
  • Disadvantage: You have to know how to format a bibliography entry. (Look at the examples in the chapter.doc template, or any appropriate style manual, or check with your advisor.)

• Automagically, using BibFrame:
  • The example in chapter.doc was done with **BibFrame**.
  • Information in On-Line Help: Consultant's Answers ➔ Frame Answers ➔ How to make a BIBLIOGRAPHY (see next page)
  • Advantage: if you have a lot of citations, it will save some work in the long run.
  • Disadvantage: it's complicated.
From On-Line Help

How to make a BIBLIOGRAPHY

MIT Academic Computing

There is no way in frame to generate an automatic bibliography for your document.

The bibliography can be done by hand, in which case you will have to add the citations yourself, or with the help of BibFrame. BibFrame will try to generate bibliographies for you, but it does not work perfectly. Once you are finished, you will want to edit the bibliography to find any mistakes that BibFrame made.

To use BibFrame, you will first need to create a .bib file with entries in it for all of the sources you would like to cite. For information on how to create this file, consult the stock answer entitled "How to make BIBLIOGRAPHIES in Latex" under the Latex topic.

Once you have a .bib file, you can create the citations by typing the key for the bibliography entry where you would like it to be cited. Then, highlight the key and hit C-r b m. After you have all the citations in your document, you need to tell frame where to look for the .bib file. You can do this by going to the menu

Special --> Variable... --> Create Variable...

Type in the name "bf-reffiles" in the "Name" field. Then type in the full path name to the .bib file in the "Definition" field, but do not type in the .bib extension on the filename. If you wish to include multiple files, separate them with commas, but no spaces. Finally, click on "Add," then click "Done" and click "Done" in the "Variable" dialog box.

For example, if you had a document named proposal.doc and a .bib file named proposal.bib in your Thesis directory, you would put

/mit/username/Thesis/proposal

in your bf-reffiles variable.

Once you have done this, you are ready to create your bibliography.

File ➔ Open...
Choose thesis.book

thesis.book lists names of all the files that make up your thesis:

- document files: cover.doc, abstract.doc, chapters, etc.
- generated lists: table of contents, lists of figures, tables

Commands from this window’s File menu will arrange and generate the whole thesis...
Generate Thesis:
Adding filenames to thesis.book

from Book window:
File → Add File...

![Add File to Book dialog box with filenames added](image)
Generate Thesis:
Re-arranging & Deleting

File → Rearrange Files...

Rearrange Files

Files:
abstract.doc
thesisTOC.doc+
thesisLOF.doc+
thesisLOT.doc+
chapter.doc
chapter1.doc
chapter2.doc

Move Up  Move Down  Delete

Done  Cancel  Help

Files in Book:
cover.doc
abstract.doc
thesisTOC.doc+
thesisLOF.doc+
thesisLOT.doc+
chapter1.doc
chapter2.doc

Help
Generate Thesis:
A change to chapter1.doc

File → Set Up File...

Page Numbering: **Continue**

Paragraph Numbering: **Restart**
Generate Thesis:
Generate/Update

File → Generate/Update...

Generate/Update Book
Update File Numbering and Cross-References

Generate:
thesisTOC.doc
thesisLOF.doc
thesisLOT.doc

Don’t Generate:

Update Cancel Help

This will let FrameMaker put all the files together, renumber each page in order, do all the cross-references, etc.
Print the Thesis -- 1

File ➤ Print...

Print Files in Book
Print:

- cover.doc
- abstract.doc
- thesisTOC.doc+
- thesisLOF.doc+
- thesisLOT.doc+
- chapter1.doc
- chapter2.doc
- appA.doc
- appB.doc
- ref.doc

Don’t Print:

Print... Cancel Help
Print the Thesis -- 2

Print

Printer Paper Size:

Width: 8.5"
Height: 11.0"

Copies: 1 Scale: 100%

Printer Name: varse

Odd-Numbered Pages
Even-Numbered Pages
Collate
Last Sheet First
Low-Resolution Images
Registration Marks

Print Only to File: /mit/joeuser/thesis/thesis.ps

Print Separations

Print Save Settings Only Cancel Help
Other Large Document Templates

Besides the MIT-specific thesis template, FrameMaker has other large document formats available:

New ➔ Reports ➔ ReportNumeric
New ➔ Reports ➔ ReportPlain
New ➔ Reports ➔ ReportSidehead
New ➔ Book

These templates are blank to start with. Try the different formats to see what’s what. (Their names are mostly self-explanatory.)

The Book and file re-arranging features work as they do with the MIT Thesis template.
**Thesis Recommendations**

- Keep backup copies on-line.
  
  `athena% cp -r ~/thesis ~/thesis_backup`

- Learn about making removable-media (diskette) copies:
  - From On-Line Help:
    see [http://web.mit.edu/olh/Account/](http://web.mit.edu/olh/Account/)
    or just start with `athena% help account`
  - You should also read the man pages on `tar` -- for making archival copies of files and directories, and the file compression utilities `compress` and `gzip`.

- If you’re still using `rm` to get rid of unwanted files:
  - Break The Habit NOW!
  - Learn to use `delete` instead.
    `athena% man delete`

- Avoid excessive printing. This is being kind to the other thesis hackers, and will save you money.

- If you must print, print only the chapters you need to see.

- Use `lpq` to guide you: Do your printing at off-peak hours, and at less-busy printers.

- Start your thesis early! As thesis deadlines approach, there is increasing contention for diskspace, printers, consultant assistance, workstations, etc.
Thesis Recommendations (cont’d)

Remember Athena’s Thesis Admonition:

ATHENA’S THESIS ADMONITION

Your thesis will take a week or two longer than you expect...
Even if you remember Athena’s Thesis Admonition.
Thesis Recommendations (cont’d)

And finally:

DON’T PANIC!

There are many sources of help available. They will be listed in the next few pages.

1. Those are the largest, friendliest-looking letters we have.
Remember This?  
The On-line Manual

Help ➔ Main Menu...

Click any main topic to bring up a list of items on that subject.

Areas to notice:

• Information area
• Online Manuals pop-up menu
• Buttons: Index, Arrows, Done, Main menu
• Topic list area
Getting More Help/Info

Besides the on-line FrameMaker manual:

- On-line help -- Athena’s own FrameMaker documents: **Text and Graphics Software → FrameMaker**
- Using FrameMaker -- Frame Technology’s manual (the X Window System version).
- Other FrameMaker books, available at the Coop, Quantum Books, etc.
- The olc stock answers
- Consultants -- via olc
**Athena: First Course (1st Course)**
Our new introduction to the Athena academic computing environment: what you can do on Athena, your account, finding help, and other basics. Also includes E-mail, Zephyr, WebSIS, and Residential Computing.
Suggested pre-requisites: None

**Working on Athena: Files and Unix (Working)**
Files, directories, setting permissions, job control, and more. What every new user should know about Unix, Athena’s operating system.
Suggested pre-requisite: 1st Course

**Word Processing Options: (WPO)**
A survey of the text-editing and word-processing packages available on Athena: FrameMaker, Latex, EZ, Emacs. Pick the right tool for the right job.
Suggested pre-requisites: 1st Course, Working

**Advanced Word Processing: EZ (EZ)**
An introduction to EZ, a combination text editor and formatter, with text-editing commands that are similar to Emacs. As a formatter, it is menu-driven and easy to learn, in the popular style of the "What You See Is (pretty much) What You Get" packages.
Suggested pre-requisites: 1st Course, Working

**Advanced Word Processing: Latex (Latex)**
An introduction to Latex, a widely-used text formatter, used for converting a text file into an attractive, professional-looking document. It is a powerful and flexible program, with the capability to typeset many foreign characters and very complex mathematical text.
Suggested pre-requisites: 1st Course, Working

**Advanced Word Processing: FrameMaker (Frame)**
FrameMaker is a powerful word-processing and document-preparation package now available on Athena.
Suggested pre-requisites: 1st Course, Working

**Latex for your Thesis (Latex Ths)**
Using the Latex text formatter to produce a fully-featured thesis that meets all MIT format requirements.
Suggested pre-requisites: Latex, some Latex experience

**FrameMaker for your Thesis (Frame Ths)**
FrameMaker, with a special template, can be used to produce an MIT thesis that meets all Institute formatting requirements.
Suggested pre-requisites: Frame, some FrameMaker experience

**HTML: Making a WWW Home Page (HTML)**
Covers the basic features of HTML ("Hyper-Text Mark-up Language") the language of the World-Wide Web, as well as the steps needed to post your own Web page on Athena.
Suggested pre-requisites: 1st Course, Working

**Information Resources on Athena (Info Res)**
A survey of the communications, help, and other resources available on Athena.
Suggested pre-requisites: 1st Course, Working

**Serious Emacs (Ser. Emacs)**
The text editor introduced in First Course has many useful features not covered in that course. This course is a must for anyone who uses Emacs more than an hour or two each week.
Suggested pre-requisites: 1st Course, Working, Emacs tutorial (on-line), some Emacs experience

**Customization on Athena (Dotfiles)**
Intended for the intermediate-level Athena user, this course will discuss the Athena login sequence and the user-configuration files (dotfiles) that affect it, as well as changes the user can make to those and other files to customize their working environment.
Suggested pre-requisites: 1st Course, Working, some Athena experience

**Math Software Overview (MSO)**
A survey of major mathematics and graphing packages available on Athena.
Suggested pre-requisites: 1st Course, Working

**Matlab (Matlab)**
An interactive program for scientific and engineering numeric calculation. Applications include: matrix manipulation, digital signal processing, and 3-dimensional graphics.
Suggested pre-requisites: 1st Course, Working

**Xess (Xess)**
A powerful and easy-to-learn spreadsheet, with a full range of mathematical, statistical, matrix, and string functions. It will be useful for scientific and engineering computations, as well as to general and financial users.
Suggested pre-requisites: 1st Course, Working

**Maple (Maple)**
A mathematics program that can perform numerical and symbolic calculations, including formal and numerical integration, solving algebraic or transcendental systems and differential equations, and series expansion and matrix manipulation. It also has extensive graphics capabilities.
Suggested pre-requisites: 1st Course, Working (or other X Windows) experience

For schedules, etc. see [http://web.mit.edu/minidev/](http://web.mit.edu/minidev/)
Minicourse Questionnaire (cont’d)

Please fill out this side of the page AFTER taking the minicourse.

5. How was the instructor’s pace? 
   Too SLOW 1 3 5 3 1 Too FAST

6. How difficult was the course material? 
   Too EASY 1 3 5 3 1 Too HARD

7. How well did you understand the instructor? 
   POORLY 1 2 3 4 5 PERFECTLY

8. How well did the instructor answer questions? 
   POORLY 1 2 3 4 5 PERFECTLY

9. Did you have any questions you didn’t ask? 
   If yes, why not? __________________________________________

10. Was any topic not covered that you had expected to learn in this course? 
    If so, what topic? __________________________________________

11. Why did you take this course? (check one)
    ❑ General Interest
    ❑ Required for a course. (Which? ________________________ )
    ❑ To be able to do something. (What? ________________________ )

12. Besides Athena, how much computer experience do you have? 
    (None) 1 2 3 4 5 (Lots)

13. How often have you used Athena in the past? (check one)
    ❑ never ❑ several times a week
    ❑ a few times ❑ daily
    ❑ once a week

14. How would you estimate your knowledge of the subject of this course...
    ...Before taking it? (None) 1 2 3 4 5 (Lots)
    ...After taking it? (None) 1 2 3 4 5 (Lots)

15. Additional comments:
Your responses to this questionnaire will help us improve our minicourses. Please take a few moments to fill it out.

Minicourse Questionnaire

Please fill out this side of the page BEFORE the class begins.

Minicourse Instructor: _________________________ Today's Date: ______________

1. MIT status (circle one): 1 2 3 4 G FACULTY STAFF OTHER

2. Is this your first Athena minicourse? (circle one): YES NO

3. If No, check (✓) those you have already taken:

- Athena: First Course
- Working on Athena
- Word processing Options
- EZ
- Latex
- Latex Thesis
- FrameMaker
- FrameMaker Thesis
- Other (please specify): _________________________

4. How did you find out about THIS minicourse? (only ONE answer, please)

- Orientation ("Hitchhiker’s") Guide
- Athena Orientation packet
- Advertisement in The Tech
- Advertisement in Voo Doo
- Flyers/Poster in hallways
- Poster in an Athena cluster
- Friend told me
- Professor or TA recommended
- Description in previous minicourse
- Other (please specify): _________________________