User Manual

Main Screen:

When you open the Shallow Red program, you are immediately given an assortment of choices.

New Game – If you click the “New Game” text area, you will be transitioned to an Options page where you may select the game you would like to play and customize other game play options.

Load Game – If you click the “Load Game” text area, the main chessboard page opens up along with a directory finder that you may select a previously saved game file (in .xml format) to load and play.

Instructions – If you click the “Instructions” text area, you will be directed to this user manual. Explanations for all game options and game play are provided here.

View Scores – If you click the “View Scores” text area, you will be directed to a table of scores for previous players that are ranked from first to last place. If you have played any ranked games, you can see how well you stack up against other players.

Exit – If you click the “Exit” text area, you will exit completely from the Shallow Red program.
The games options menu is an essential part of setting up customized game play. You, or your opponent, (if you are playing human vs. human) are allowed to set various game fields to your own preference(s).

**Game Type** – The game type combo box selects the current game type to be played for the game. You may select from any of the five game types offered:

- Standard Antichess
- Antichess + Amendment
- Standard Chess
- Variant Antichess
- Variant Chess

Antichess is a variation of chess. While all pieces still possess the same directional movements, the rules for constraining these moves have been altered. While checkmating the opponent still results in a win for you, you may also win by timing out your opponent or by losing all of your pieces (except

Chess is a universally known and played board game. While there are slight variations of chess, the general objective is to mate your opponents King before timing out. This has to be done before your opponent does this to you or you lose. More detailed instructions on the rules of Chess can be found at http://en.wikipedia.org/wiki/Chess.

All five games do include certain rules of antichess and chess that aren't always used in some games. These fringe rules consist of:

*En Passant*: If an opposing pawn has crossed the dividing row (white to row 5 or black to row 4), and you move a pawn, that hasn't moved been moved previously, two spaces ahead, and your pawn's path crosses the capturing path of the opponent's pawn, then your opponent may (or in antichess – must) capture your pawn, moving its pawn to the square one row in front of the starting position of your pawn. Based on the number of conditional statements used in simply describing this scenario, it should be apparent that this move is rarely used in chess, but occasionally becomes significant in chess due to the must capture clause. More detailed instructions on the rules of En Passant can be found at http://en.wikipedia.org/wiki/En_passant.

*Castling*: Castling occurs between a king and a castle only if they both have not moved. If both the king and castle are in their original starting positions, and the King is not in check in its current position, in its transition position (one column to the left or right), or in its final position (two columns to the left or right of its starting position), then it is allowed to move two columns towards the direction of the castle. In turn, the castle skips over the King, and finally ends up in between the King's final position and its starting position. More detailed instructions on the rules of Castling can be found at http://en.wikipedia.org/wiki/Castling.

*Pawn to Queen*: If you one of your pawns move all the way over to your opponents side (row 8 if you are playing as white, row 1 if you are playing as black), then the pawn is redeemed for a queen of the same color.

*Pieces in Game*:

*Standard Antichess*: Possesses all the same pieces as standard chess: 8 pawns, 2 rooks, 2 knights, 2 bishops, 1 queen and 1 king per player.

*Antichess + Ammendment*: Possesses all the same pieces as standard chess: 8 pawns, 2 rooks, 2 knights, 2 bishops, 1 queen and 1 king per player. Also, this game possesses three different power ups: upgrade, destroy, spawn. The game has the option of having power-ups placed on the board. When customization of powerup placement is not selected, the game automatically assigns 2 upgrade, 2 destroy and 2 spawn power ups on the board in both a random and symmetric fashion.

*Standard Chess*: Possesses all the same pieces as standard chess: 8 pawns, 2 rooks, 2 knights, 2 bishops, 1 queen and 1 king per player.

*Variant Antichess*: Possesses all the same pieces as standard chess: 8 pawns, 2 rooks, 2 knights, 2 bishops, 1 queen and 1 king per player. Also, this game possesses nine different power ups: upgrade, destroy, spawn, traitor, berlin pawn, snake, chameleon, gryphon and dragon king. Five of these
powerups, when captured, result in the creation of in a particular variant piece of the same name: berlin pawn, snake, chameleon, gryphon, dragon king. The game has the option of having power-ups placed on the board. When customization of powerup placement is not selected, the game automatically assigns any combination of 2 upgrade, 2 destroy, 2 spawn, 2 berlin pawn, 2 snake, 2 chameleon, 2 gryphon or 2 dragon king power ups on the board in both a random and symmetric fashion, so that they add up to six total power ups.

**Variant Chess:** Possesses all the same pieces as standard chess: 8 pawns, 2 rooks, 2 knights, 2 bishops, 1 queen and 1 king per player. Also, this game possesses nine different power ups: upgrade, destroy, spawn, traitor, berlin pawn, snake, chameleon, gryphon and dragon king. Five of these powerups, when captured, result in the creation of in a particular variant piece of the same name: berlin pawn, snake, chameleon, gryphon, dragon king. The game has the option of having power-ups placed on the board. When customization of powerup placement is not selected, the game automatically assigns any combination of 2 upgrade, 2 destroy, 2 spawn, 2 berlin pawn, 2 snake, 2 chameleon, 2 gryphon or 2 dragon king power ups on the board in both a random and symmetric fashion, so that they add up to six total power ups.

**Piece Movement:**

**Pawn:**

**Moves:** A pawn may move forward in the direction away from its starting side of the board (black pawn towards row 1 and white pawn towards row 8). If they have not moved in the current game, and no pieces obstruct their path, they may leap two rows forward. Otherwise, they may only move one row per move.

**Captures:** A pawn captures diagonally in a direction that leads them away from their starting row on the board.

![Pawn](image)

**Bishop:**

**Moves:** A bishop moves in all four diagonal directions. It may not leap over pieces.

**Captures:** A bishop captures by moving in any of the four diagonal directions.

![Bishop](image)

**Knight:**

**Moves:** A knight leaps to any space that can be reached by moving one space orthogonally, followed by another space diagonally outward, or vice versa.

**Captures:** A knight captures in the same way that it moves.

![Knight](image)

**Rook:**

**Moves:** A rook may only move orthogonally.

**Captures:** A rook captures orthogonally.

![Rook](image)
Queen:

Moves: A queen may move in any diagonal or orthogonal direction available to it.
Captures: A queen captures in the same way that it moves.

King:

Moves: A king may move one step in any diagonal or orthogonal direction available to it, with the condition that after the move is made, the King is not in check by the opposing piece.
Captures: A king captures under the same conditions as it moves.

Variant Pieces: These pieces aren't found in the standard antichess game and take on peculiar behaviors. They are only found in “Variant Chess” and “Variant Antichess” in the Game Type option in the Options Menu. For a better description of variant pieces found in chess and their associated properties, please see: [link to Chess Variants website].

Enjoy...

Berlin Pawn:

Moves: A berlin pawn moves one step diagonally forward (or two steps from the initial pawn row, subject to e.p. capture)
Captures: A berlin pawn captures by moving one step directly forward.

Snake:

Moves: A snake moves like a traditional pawn, except it may recoil one move backwards as well.
Captures: A snake captures diagonally, like a traditional pawn.

Chameleon:

Moves: The chameleon takes on the movement of the last piece moved by the opponent. If the last move was null, then the chameleon has no valid movements. Otherwise it mimics the other piece.
Captures: A chameleon may capture in the same way that it may move.

Gryphon:

Moves: The Gryphon moves one square diagonally in any direction, the continues away from the starting square in an orthogonal direction. Its path must be unoccupied; it can not jump over pieces.
Capture: It captures an enemy piece by moving onto the square occupied by that piece.
Dragon King:

Moves: A dragon king moves any number of spaces orthogonally, or it may step one space diagonally.

Captures: A dragon king may capture in the same way that it may move.

Power Ups: When captured, power ups always transform the game state in some way that can be both beneficial or detrimental depending on the piece type or the game type you are playing. When moving, pieces can move through or over power ups. Power ups are only captured when a piece lands directly on the square they are located at. When a power up is captured, it transforms the capturing piece and is removed from the game. Kings are not affected by power ups. For more information on the three original power ups (upgrade, spawn and destroy), please see http://www.mit.edu/~6.170/assignments/antichess/ft07-amendment.html.

Upgrade:

An upgrade turns the capturing piece into a queen piece of the same color.

Spawn:

A spawn creates a copy of the capturing piece and places it to the right of the capturing piece (with respect to White's viewpoint). If no space is available, the piece is added to the next open space in a counter clockwise direction. If no spaces are open adjacent to the power up, the copy of the spawned piece is not added to the board.

Destroy:

Destroy removes the capturing piece from the board.

Traitor:

Traitor switches the alliance/color of the capturing piece to the opponents.

Berlin Pawn:

The Berlin Pawn Power Up transforms the capturing piece into a berlin pawn piece with the same color as the capturing piece.

Snake:

The Snake Power Up transforms the capturing piece into a snake piece with the same color as the capturing piece.
Chameleon:
The Chameleon Power Up transforms the capturing piece into a chameleon piece with the same color as the capturing piece.

Gryphon:
The Gryphon Power Up transforms the capturing piece into a gryphon pawn piece with the same color as the capturing piece.

Dragon King:
The dragon Power Up transforms the capturing piece into a dragon piece with the same color as the capturing piece.

Game Theme: The “Game Theme” option allows you to customize the look and feel of the pieces used in the game. Available piece themes are:

3D: choose this to play a game using 3D pieces (Colors: white, red)

Metallic: choose this to play a game using metallic looking pieces with a Indian styled figures (Colors: white, black)

Minimalist: choose this to play game using very basic 2D pieces (Colors: white, blue)

Ranked Game: Check this box to play a ranked game. To help standardize game results, you are only allowed to play human vs. computer games for a ranked game. The computers' level of difficulty is automatically set to “expert”, which is only surpassed by “grandmaster” in difficulty. Additionally time for a ranked game is set to 10 minutes for both you and the computer. The game only records scores for Standard Antichess, so you may only play this variation for a ranked game.

White: The white player is allowed to set various settings of the game.

Name: If you choose to play as white, enter your name, or unique game name in the name text field. It is essential to have a unique game name in order to receive your own ranking if you choose to play a ranked game.

Computer: If you wish to have the computer play as White, select the computer button.

AI Level: AI Level ranges from easy difficulty level (“novice”) to increasing difficulty (“grandmaster”). Depending on how much of a challenge you desire, or your experience, you should select this level accordingly.

Mortal: If you decide to play as White, select this button.
Timed: Select the Timed button area to play a timed game for White. Enter the desired time length for white. The first text field represents hours, the second minutes, and the last box seconds. Enter any desired duration of game time, though we suggest between 5 and 10 minutes.

Untimed: An untimed game gives you unlimited time to decide on a move.

Black: The black player is allowed to set various settings of the game.

Name: If you choose to play as black, enter your name, or unique game name in the name text field. It is essential to have a unique game name in order to receive your own ranking if you choose to play a ranked game.

Computer: If you wish to have the computer play as Black, select the computer button. AI Level: AI Level ranges from easy difficulty level (“novice”) to increasing difficulty (“grandmaster”). Depending on how much of a challenge you desire, or your experience, you should select this level accordingly.

Mortal: If you decide to play as Black, select this button.

Timed: Select the Timed button area to play a timed game for Black. Enter the desired time length for black. The first text field represents hours, the second minutes, and the last box seconds. Enter any desired duration of game time, though we suggest between 5 and 10 minutes.

Untimed: An untimed game gives you unlimited time to decide on a move.

Main: This button, when clicked, will transfer you back to the Main page where you may choose to Exit, View Scores, etc...

Play: This button, when clicked, will take you to the Game page. Until this point you may update any of the options fields, but afterwards the page reads these current selections and creates a game based on your changes.
**Game Board:** The game page is where the fun begins. Here you may play the current game, start a new game, chat, and perform many other cool features.

**File:** This menu contains all functionality of the Main page.

**New game:** When New Game is selected from the File menu, the page reverts back to the Options page where you may set up a new game.

**Load game:** When Load Game is selected from the File Menu, a directory finder pops and allows you to search through your directories and load a previously saved game.

**Save game:** When Save Game is selected from the File Menu, a save file directory pops up and allows
you to save a game. All saved games must be saved in the form “filename.xml”.

**View Scores:** When View Scores is selected from the File Menu, the scores page pops up, where you can look up your score (or rivals scores) to see where you stand in ranking.

**Quit:** When Quit is selected from the File Menu, a message pops up that gives you the option to save the current game. If you select “yes” from the popup, you can save the current game. If you select “no”, the game page closes and you return the Main page. If you click “cancel” you simply close the popup and return to the current game you are playing.

**Options:** The Options Menu contains some of the must important functions that can be used during game play.

**Undo:** When Undo is selected from the Options Menu, and the current player is a mortal/human, the last two moves are undone on the board. This allows the current player to go back and redo the previous move. If the current player is a computer, than only one move is undone, which returns the move control to the human player. Note: The time of the current game is not updated to the previous game times of the players. Also, this option is discontinued during a ranked game, so make sure you make good choices the first time around.

**Pause:** When Pause is selected from the Options Menu, the times for each player (if they are playing a timed game) are halted. This allows either player to take a break from the game. A message is shown to remind players that the game has been pause, and the message must be exited to resume game play.

**Note:** This option is discontinued during a ranked game, so you should be ready to play up to 20 consecutive minutes

**Hint:** When Hint is selected from the Options Menu, a move, that for the next few immediate moves will be good for you, is returned. You may choose to make this move on the board, or ignore it. Selecting Hint multiple times may result in alternative moves. Note: This option is discontinued during a ranked game, since you are solely ranked on your own personal skill as an antichess player.

**Theme:** When Theme is selected from the Options Menu, you are given the option of selecting any of the three themes (described earlier under the Options Page section).

**Animation:** When Animation is selected from the Options Menu, you are given the option of turning Animation on or off. More specifically, this either turns on or off the coloring of legal moves and moveable pieces. The default for a new game is with the Animation turned on, since this allows you to see movable pieces during an antichess game. However, you may prefer to turn off animation while playing a variation of chess.

**Help:** This menu simply allows you to select this user manual

**Players table:** In the upper right corner of the game, a player table is provided. The “player” column of the table provides you with player colors. Also, the current player (whose turn it is to move) is denoted by a “>” next to the start of color. For example “> WHITE” would indicate that white now must move. The “name” column of the table pairs the player color with the player’s name. The last column represents the time remaining for each player. If the player is playing an untimed game, the cell will
read as “untimed”, otherwise, the players remaining time is displayed in the form minutes:seconds (ex. 4:53). When the player is expected to make a move, the time will decrement every second and be updated on the screen for the players convenience.

**Previous Moves Table:** The previous moves table displays the previous moves made by each player throughout the current game. The left column displays all moves made by white, and the right column represents black moves.

**Message Board:** The message board displays messages from the computer regarding the current game status, your game playing style, your personal hygiene, etc...

**Move Text Field:** The move text field may be used to enter moves manually. By entering a move in the form “a2-a3” (first board position, hyphen, second board position) you can update the board. After entering the desired move, you must click the “Move” button to the left of the text field to actually enter the move and update the board.

**Options Buttons:** At the bottom of the board there are five buttons that you may access quickly for convenience.

**Pass:** The “Pass” button may by the most obscure button displayed for game play. It is only activated when the current player has no legal moves and must “pass” and allow the opponent to make a move. A message should appear in message board to alert the current player that they have no legal moves and must pass.

**Undo:** This button possesses the same functionality as the “undo” option in the Options menu at the top of the game page.

**Hint:** This button possesses the same functionality as the “hint” option in the Options menu at the top of the game page.

**Pause:** This button possesses the same functionality as the “pause” option in the Options menu at the top of the game page.
The Board:

The Board itself is checkered in black and white. The pieces for the White player are placed at the bottom of the page (rows 1 and 2) while the Black player pieces are initially placed at the top of the page (rows 7 and 8). White starts the game (if it is new, and not a loaded game).

The most convenient, and quickest method, of moving pieces on the board, is by clicking with your mouse. One click on a piece (you may click anywhere within the boundaries of the square the piece currently rests on), selects the piece. A second click on the square unselects that piece position. However, if you click on another square, the game will attempt to move the piece there. If the resulting move is illegal for the current game state, no updates will occur, and you must try to move the piece to a valid square. If the move was legal, then the board will move the selected piece to the requested board position.

A useful functionality of the game is that you may choose to view animation of pieces. You may select this from the “Options” menu. When animation is turned on, and you are the player whose turn it is to make a move, the following animation will occur:

The pieces that you can move will be indicated by turning the board square they rest on green. If you scroll over any of the movable pieces, the moveable piece position that your mouse currently is placed over will turn yellow to indicate that it has been selected. All the legal moves this piece can make will be indicated by turning their board squares blue. If the piece has no legal moves, it will not be highlighted in yellow, and instead, the pieces that do have moves will reappear as green. If you actually click on a piece that has valid moves, it will become highlighted as yellow as before, but the scrolling property will be unenabled. If you click on any square that isn't indicated as a valid move, the movable pieces will reappear as green. However, if the move is valid (from yellow square to blue square) the board will be updated with this move and move control to your opponent so that he/she/it may make it's next move. The last player's move is also always shown as purple (only the starting and ending squares are colored purple – not the complete path traveled by the piece).

Directly above and below the game board are spaces that hold the captured pieces. Captured black pieces are shown at the top of the board, on the black side of the board, and white pieces are likewise shown at the bottom of the board, underneath the white side of the board. Each time a piece is captured and removed from the board, it is placed on the corresponding color's side.

If you are curious about the actual rules of the current game and the possible piece movement, please see the earlier information given about these subjects under the “Options Page” section, subsection: game themes.
Scoring:

As explained earlier, you can choose to have your game ranked. If you choose this option, a new score profile will be created under your name. From then on, whenever you use your profile to play a ranked game, your score will be updated in our database.

Here is the formula for your score:
Score = Total Wins + (Total Draws /2) + (Number of Games Played / 5)

Additionally, as described earlier in the user manual, by click on the View Score button at the main menu, you can check the ranking of all players that have ever played a ranked game against Shallow Red. Here is how the ranking page looks like:

<table>
<thead>
<tr>
<th>Rank</th>
<th>Name</th>
<th>Wins</th>
<th>Losses</th>
<th>Ties</th>
<th>Score</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Sorcush</td>
<td>1</td>
<td>1</td>
<td>0</td>
<td>1.4</td>
</tr>
<tr>
<td>2</td>
<td>Samn</td>
<td>0</td>
<td>2</td>
<td>0</td>
<td>0.4</td>
</tr>
<tr>
<td>3</td>
<td>Dharvi</td>
<td>0</td>
<td>1</td>
<td>0</td>
<td>0.2</td>
</tr>
</tbody>
</table>