
Unlike bitmap images, vector images 
retain their crisp edges at any 
enlargement. You can draw vector 
shapes and paths in your Photoshop 
images and add vector masks to 
control what is shown in an image. 
This lesson will introduce you to 
advanced uses of vector shapes and 
vector masks.
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Lesson overview
In this lesson, you’ll learn how to do the following: 

•	 Differentiate between bitmap and vector graphics.

•	 Draw straight and curved paths using the Pen tool.

•	 Convert a path to a selection, and convert a selection to a path.

•	 Save paths.

•	 Draw and edit layer shapes.

•	 Draw custom layer shapes.

•	 Import and edit a Smart Object from Adobe Illustrator.

This lesson will take about 90 minutes to complete. If needed, remove 
the previous lesson folder from your hard drive, and copy the Lesson9 
folder onto it. As you work on this lesson, you’ll preserve the start files. If 
you need to restore the start files, copy them from the lesson9.zip file you 
downloaded.

About bitmap images and vector graphics
Before working with vector shapes and vector paths, it’s important to 
understand the basic differences between the two main categories of 
computer graphics: bitmap images and vector graphics. You can use 
Photoshop to work with either type of graphic; in fact, you can combine 
both bitmap and vector data in an individual Photoshop image file.

Vector Drawing Techniques
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Bitmap images, technically called raster images, are based on a grid of colors known 
as pixels. Each pixel is assigned a specific location and color value. In working with 
bitmap images, you edit groups of pixels rather than objects or shapes. Because bitmap 
graphics can represent subtle gradations of shade and color, they are appropriate for 
continuous-tone images such as photographs or artwork created in painting programs. 
A disadvantage of bitmap graphics is that they contain a fixed number of pixels. As a 
result, they can lose detail and appear jagged when scaled up on-screen or if they are 
printed at a lower resolution than that for which they were created. 

Vector graphics are made up of lines and curves defined by mathematical objects called 
vectors. These graphics retain their crispness whether they are moved, resized, or have 
their color changed. Vector graphics are appropriate for illustrations, type, and graphics 
such as logos that may be scaled to different sizes.

Logo drawn as vector art

Logo rasterized as bitmap art

About paths and the Pen tool
In Photoshop, the outline of a vector shape is a path. A path is a curved or straight line 
segment you draw using the Pen tool, Magnetic Pen tool, or Freeform Pen tool. Of these 
tools, the Pen tool draws paths with the greatest precision; the Magnetic Pen tool and 
Freeform Pen tool draw paths as if you were drawing with a pencil on paper.
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Julieanne Kost is an official Adobe Photoshop evangelist. 

T O O L  T I P S  F R O M  T H E  P H O T O S H O P  E V A N G E L I S T

Any tool in the toolbox can be selected with a single letter shortcut key. Type the letter, get the 
tool. For example, press P to select the Pen tool. Pressing Shift with the key cycles though any 
nested tools in a group. So pressing Shift+P toggles between the Pen and Freeform Pen tools.

Paths can be open or closed. Open paths (such as a wavy line) have two distinct 
endpoints. Closed paths (such as a circle) are continuous. The type of path you draw 
affects how it can be selected and adjusted. 

Paths that have not been filled or stroked do not print when you print your artwork. 
This is because paths are vector objects that contain no pixels, unlike the bitmap shapes 
drawn by the Pencil tool and other painting tools.

Getting started
You’ll start the lesson by viewing a copy of the finished image that you’ll create—a 
poster for a fictitious toy company.

1	 Start Adobe Photoshop, holding down Ctrl+Alt+Shift (Windows) or 
Command+Option+Shift (Mac OS) to restore the default preferences. (See “Restoring 
default preferences” on page 6.)

2	 When prompted, click Yes to confirm that you want to reset preferences, and Close to 
close the Welcome Screen.

3	 Click the Go To Bridge button ( ) in the tool options bar to open Adobe Bridge.

4	 In the Favorites palette in the upper left corner of Bridge, click the Lessons favorite, 
and then double-click the Lesson9 folder in the thumbnail preview area.
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5	 Select the 9End.psd file so that it appears in the center preview window. Enlarge the 
preview if needed to get a good close-up view by dragging the thumbnail slider at the 
bottom of the window.  

To create this poster, you’ll open the image of the toy space ship and practice making 
paths and selections using the Pen tool. Along the way, you’ll learn advanced uses of 
path and vector masks, and ways to use Smart Objects, as you create the background 
shapes and type.

Note: If you open the 9End.psd file in Photoshop, you might be prompted to update type 
layers. If so, click Update. This notice sometimes appears when files are transferred between 
computers, especially between Windows and Mac OS.

6	 When you’ve finished looking at 9End.psd, double-click the Saucer.psd file to open it 
in Photoshop.

7	 Choose File > Save As, rename the file 09Working.psd, and click Save.
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Using paths with artwork
You’ll start by using the Pen tool to make selections in the image of the flying saucer. 
The saucer has long, smooth, curved edges that would be difficult to select using other 
methods.

You’ll draw a path around the saucer and create two paths inside it. After you’ve drawn 
the paths, you’ll convert them to selections. Then you’ll subtract one selection from the 
other so that only the saucer and none of the starry sky is selected. Finally, you’ll make a 
new layer from the saucer image and change the image that appears behind it.

When drawing a freehand path using the Pen tool, use as few points as possible to create 
the shape you want. The fewer points you use, the smoother the curves are and the more 
efficient your file is.

Correct number of 	 Too many points 
points
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Creating paths with the Pen tool
You can use the Pen tool to create paths that are straight or curved, open or closed. If you’re unfamiliar 
with the Pen tool, it can be confusing to use at first. Understanding the elements of a path and how to 
create them with the Pen tool makes paths much easier to draw.

To create a straight path, click the mouse button. The first time you click, you set the starting point. 
Each time that you click thereafter, a straight line is drawn between the previous point and the current 
point. To draw complex straight-segment paths with the Pen tool, simply continue to add points.

To create a curved path, click to place an anchor point, drag to create a direction line for that point, 
and then click to place the next anchor point. Each direction line ends in two direction points; the 
positions of direction lines and points determine the size and shape of the curved segment. Moving the 
direction lines and points reshapes the curves in a path.

Smooth curves are connected by anchor points called smooth points. Sharply curved paths are 
connected by corner points. When you move a direction line on a smooth point, the curved segments 
on both sides of the point adjust simultaneously, but when you move a direction line on a corner point, 
only the curve on the same side of the point as the direction line is adjusted.

Path segments and anchor points can be moved after they’re drawn, either individually or as a group. 
When a path contains more than one segment, you can drag individual anchor points to adjust 
individual segments of the path, or select all of the anchor points in a path to edit the entire path. Use 
the Direct Selection tool ( ) to select and adjust an anchor point, a path segment, or an entire path.

Creating a closed path differs from creating an open path in the way that you end the path. To end an 
open path, click the Pen tool ( ) in the toolbox. To create a closed path, position the Pen tool pointer 
over the starting point and click. Closing a path automatically ends the path. After the path closes, the 
Pen tool pointer appears with a small x, indicating that your next click will start a new path.

As you draw paths, a temporary storage area named Work Path appears in the Paths palette.  It’s a 
good idea to save work paths, and it’s essential if you use multiple discrete paths in the same image file. 
If you deselect an existing Work Path in the Paths palette and then start drawing again, a new work 
path will replace the original one, which will be lost. To save a work path, double-click it in the Paths 
palette, type a name in the Save Path dialog box, and click OK to rename and save the path. The path 
remains selected in the Paths palette. 
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Drawing the outline of a shape
In this exercise, you’re going to use the Pen tool to connect the dots from point A to 
point N, and then back to point A. You’ll set some straight segments, some smooth 
curve points, and some corner points.

You’ll begin by configuring the Pen tool options and your work area, and then you’ll 
trace the outline of a flying saucer using a template.

1	 In the toolbox, select the Pen tool ( ).

2	 In the tool options bar, select or verify the following settings:

•	 Select the Paths ( ) option.

•	 Click the arrow for Geometry Options and make sure that the Rubber Band check 
box is not selected in the Pen Options pop-up palette.

•	 Make sure that the Auto Add/Delete option is selected. 

•	 Select the Add To Path Area option ( ).

A B C

A. Paths option  B. Geometry Options menu  C. Add To Path Area option 

3	 Click the Paths tab to bring that palette to the front of the Layers palette group.

The Paths palette displays thumbnail previews of the paths you draw. Currently, the 
palette is empty because you haven’t started drawing.

4	 If necessary, zoom in so that you can easily see the lettered points and red dots on the 
shape template that has been created for you. Make sure you can see the whole template 
in the image window, and be sure to reselect the Pen tool after you zoom.

5	 Position the pointer on point A. Click the point and drag to its red dot to set the first 
anchor point and the direction of the first curve. Do the same thing at point B.

At the corner of the cockpit (point B), you’ll need to make a corner point to create a 
sharp transition between the curved segment and the straight one. 
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6	 Alt-click (Windows) or Option-click (Mac OS) point B to convert the smooth point 
into a corner point and remove one of the direction lines.

B B

Setting a smooth point at B	 Converting the smooth point  
	 to a corner point 

7	 Click point C to set a straight segment (don’t drag).

If you make a mistake while you’re drawing, choose Edit > Undo to undo the step. Then 
resume drawing. 

8	 Click point D and drag up from point D to its red dot. Then, click point E and drag 
down from point E to its red dot.

9	 Click point F. 

10	 Set curve points at G, H, and I by clicking each point and dragging from the point 
to its red dot, each in turn.

11	 Click point J.

12	 Set curve points at K and L by clicking each point and dragging from each one to its 
respective red dot.

13	 Click point M.

14	 Click point N and don’t release the mouse button. Press Alt (Windows) or Option 
(Mac OS) and drag from point N to the red dot to add one direction line to the anchor 
point at N. Then, release the mouse button and the Alt or Option key.
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15	 Move the pointer over point A so that a small circle appears in the pointer icon, 
indicating that you are about to close the path. (The small circle may be difficult to see 
because the image is dark and the circle is faint.) Drag from point A to the red dot, and 
then release the mouse button to draw the last curved line. 

16	 In the Paths palette, double-click the Work Path, type Saucer in the Save Path 
dialog box, and click OK to save it.

17	 Choose File > Save to save your work. 

Converting selections to paths 
Now, you’ll create a second path using a different method. First, you’ll use a selection 
tool to select a similarly colored area, and then you’ll convert the selection to a path. 
(You can convert any selection made with a selection tool into a path.)

1	 Click the Layers tab to display the Layers palette, and then drag the Template layer to 
the Trash button at the bottom of the palette. You no longer need this layer.

 



290
Vector Drawing Techniques
LESSON 9

2	 Select the Magic Wand tool ( ) in the tool box, hidden under the Quick Selection tool.

3	 In the Magic Wand Tool options bar, make sure that the Tolerance value is 32.

4	 Carefully click the black area inside one of the saucer’s vertical fins. 

5	 Shift-click inside the other fin to add that black area to the selection. 

6	 Click the Paths tab to bring the Paths palette forward. Then, click the Make Work 
Path From Selection button ( ) at the bottom of the palette. 

 

The selections are converted to paths, and a new Work Path is created. 

7	 Double-click the Work Path, name it Fins, and then click OK to save the path. 

8	 Choose File > Save to save your work.
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Converting paths to selections
Just as you can convert selection borders to paths, so you can convert paths to 
selections. With their smooth outlines, paths let you make precise selections. Now 
that you’ve drawn paths for the spaceship and its fins, you’ll convert those paths to a 
selection and apply a filter to the selection. 

1	 In the Paths palette, click the Saucer path to make it active. 

2	 Convert the Saucer path to a selection by doing one of the following: 

•	 From the Paths palette menu, choose Make Selection, and then click OK to close the 
dialog box that appears.

•	 Drag the Saucer path to the Load Path As Selection button ( ) at the bottom of the 
Paths palette.

Simply click the Load Path As Selection button  ( ) at the bottom of the Paths palette 
to convert the active path to a selection.

Next, you’ll subtract the Fins selection from the Saucer selection so that you can see the 
background through the vacant areas in the fins. 
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3	 In the Paths palette, click the Fins path to make it active. Then, from the Paths palette 
menu, choose Make Selection. 

4	 In the Operation area of the Make Selection dialog box, select Subtract from 
Selection, and click OK.

Subtracting the Fins selection	 Result 
from the Saucer selection

The Fins path is simultaneously converted to a selection and subtracted from the 
Saucer selection. 

Leave the paths selected, because you’re going to use the selection in the next procedure.
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Converting the selection to a layer
Now, you’ll see how creating the selection with the Pen tool can help you achieve 
interesting effects. Because you’ve isolated the saucer, you can create a duplicate of it on 
a new layer. Then, you can copy it to another image file—specifically, to the image that 
is the background for the toy store poster.

1	 Make sure that you can still see the selection outline in the image window. If you 
can’t, it was deselected and you need to repeat the previous exercise, “Converting paths 
to selections.” 

2	 Choose Layer > New > Layer Via Copy.

A new layer appears in the Layers palette, Layer 1. The Layer 1 thumbnail shows that the 
layer contains only the image of the flying saucer, not the sky areas of the original layer.

3	 In the Layers palette, double-click Layer 1, type Saucer to rename it, and press Enter 
or Return.

4	 Use Adobe Bridge or the File > Open command to open the 9Start.psd file, located in 
the Lessons/Lesson9 folder.
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This is a Photoshop image of a graduated blue background with a planet in the lower 
part of the image.

 

5	 If necessary, move the image windows so that you can see at least part of both the 
Saucer.psd window and the 9Start.psd window on-screen. Make sure that no layers 
are selected in the 9Start.psd file Layers palette; then make the 09Working.psd image 
window active, and select the Saucer layer in the Layers palette.

6	 In the toolbox, select the Move tool ( ), and drag from the 09Working.psd image 
window to the 9Start.psd image window so that the saucer appears in the sky.

 

7	 Close the 09Working.psd image without saving changes, leaving the 9Start.psd file 
open and active.
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Now you’ll position the flying saucer more precisely in the poster background.

8	 Select the Saucer layer in the Layers palette and choose Edit > Free Transform. 

A bounding box appears around the saucer.

9	 Position the cursor near any corner control handle until it turns into rotate cursor  
( ), then drag to rotate the saucer until it’s at about a 20-degree angle. When you’re 
satisfied, press Enter or Return.

Note: If you accidentally distort the saucer instead of rotating it, press Ctrl+. [period] 
(Windows) or Command+. [period] (Mac OS) and start over.

10	 To finesse the positioning of the saucer, make sure that the Saucer layer is still 
selected and use the Move tool to drag the saucer so that it grazes the top of the planet, 
as in the following image.

 

11	 Choose File > Save As, rename the file 09B_Working.psd, and click Save.
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Creating vector objects for the background
Many posters are designed to be scalable, either up or down, while retaining a crisp 
appearance. This is a good use for vector shapes. Next, you’ll create vector shapes with 
paths, and use masks to control what appears in the poster. Because they’re vector, the 
shapes can be scaled in future design revisions without a loss of quality or detail.

Drawing a scalable shape
You’ll begin by creating a white kidney-shaped object for the backdrop of the poster.

1	 Choose View > Rulers to display the horizontal and vertical rulers.

2	 Drag the tab for the Paths palette out of the Layers palette group so that it floats 
independently. Since you’ll be using the Layers and Paths palettes frequently in this 
exercise, it’s convenient to have them separated.
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3	 Hide all of the layers except the Retro Shape Guide layer and the Background layer by 
clicking the appropriate eye icons in the Layers palette. Select the Background layer to 
make it active.

The guide layer will serve as a template as you draw the kidney shape. 

4	 Set the foreground and background colors to their defaults (black and white, 
respectively) by clicking the Default Foreground And Background Colors  
button ( ) in the toolbox (or type the keyboard shortcut D), and then swap the 
foreground and background colors by clicking the Switch Foreground And Background 
Colors button ( ) (or type X). Now the foreground color is white. 

A

B

C

D

A. Default Foreground And Background Colors button 
B. Foreground Color button 
C. Switch Foreground And Background Colors button 
D. Background Color button

5	 In the toolbox, select the Pen tool ( ). Then, in the tool options bar, make sure that 
the Shape Layers option is selected.
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6	 Create the shape by clicking and dragging as follows: 

•	 Click point A and drag a direction line up and to the left of point B, and then release. 

•	 Click point C and drag a direction line toward and above point D, and then release.

•	 Continue to draw curved segments in this way around the shape until you return to 
point A, and then click on A to close the path.

Note: If you have trouble, open the saucer image again and practice drawing the path 
around the saucer shape until you get more comfortable with drawing curved path 
segments. Also, be sure to read the sidebar, “Creating paths with the Pen tool,” on page 286.

a
b

c

d

Notice as you drew that Photoshop automatically created a new layer, Shape 1, in the 
Layers palette.

7	 Double-click the Shape 1 name, rename the shape layer Retro Shape, and press Enter 
or Return.

8	 Hide the Retro Shape Guide layer by clicking its eye icon in the Layers palette.

9	 Choose File > Save to save your work.
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Deselecting paths 
Deselecting paths is sometimes necessary to see the appropriate tool options bar when 
you select a vector tool. Deselecting paths can also help you view certain effects that 
might be obscured if a path is highlighted. Before proceeding to the next exercise, you’ll 
make sure that all paths are deselected.

1	 Select the Path Selection tool ( ), which may be hidden under the Direct Selection 
tool ( ).

2	 In the tool options bar, click the Dismiss Target Path button ( ).

Note: You can also deselect paths by clicking in the blank area below the paths in the 
Paths palette.

Notice that the border between the white kidney shape and the blue background has a 
grainy quality. What you see is actually the path itself, which is a nonprinting item. This 
is a visual clue that the Retro Shape layer is still selected.

About shape layers 
A shape layer has two components: a fill and a shape. The fill properties determine the 
color (or colors), pattern, and transparency of the layer. The shape is a layer mask that 
defines the areas in which the fill can be seen and those areas in which the fill is hidden.

In the layer you’ve just created, the fill is white. The fill color is visible within the shape 
you drew and is not visible in the rest of the image, so the background sky can be seen 
around it. 

In the Layers palette, your Retro Shape layer sits above the Background layer because 
the background was selected when you started to draw. The shape layer has three items 
along with the layer name: two thumbnail images and a link icon between them. 

A B C

A. Fill thumbnail  B. Layer mask  
link icon  C. Mask thumbnail
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The left thumbnail shows that the entire layer is filled with the white foreground color. 
The nonfunctioning small slider underneath the thumbnail symbolizes that the layer 
is editable.

The Mask thumbnail on the right shows the vector mask for the layer. In this thumbnail, 
white indicates the area where the image is exposed, and gray indicates the areas where 
the image is blocked.

The icon between the two thumbnails shows that the layer and the vector mask are linked.

Subtracting shapes from a shape layer
After you create a shape layer (vector graphic), you can set options to subtract new 
shapes from the vector graphic. You can also use the Path Selection tool and the Direct 
Selection tool to move, resize, and edit shapes. You’ll add some interest to the retro 
shape by subtracting a star shape from it, allowing the outer space background to show 
through. To help you position the star, you’ll refer to the Star Guide layer, which has 
been created for you. Currently, that layer is hidden.

1	 In the Layers palette, to the far left of the Star Guide layer, click in the Show/Hide 
Visibility column to display the eye icon ( ) for that layer (but leave the Retro Shape 
layer selected). The Star Guide layer is now visible in the image window.
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2	 In the Paths palette, select the Retro Shape vector mask.

3	 In the toolbox, select the Polygon tool ( ), hidden under the Rectangle tool ( ). 

4	 On the tool options bar, do the following:

•	 For Sides, type 11.

•	 Click the Geometry Options arrow (immediately to the left of the Sides option) to 
open the Polygon Options. Select the Star check box, and type 50% in the Indent Sides 
By option. Then click anywhere outside the Polygon Options to close it.

•	 Select the Subtract From Shape Area option ( ), or press either hyphen or minus to 
select it with a keyboard shortcut. The pointer now appears as cross hairs with a small 
minus sign ( ).
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5	 Move the cross hairs pointer over the orange dot in the center of the orange circle 
in the image window, and drag outward until the tips of the star rays touch the circle’s 
perimeter.

Note: As you drag, you can rotate the star by dragging the pointer to the side.

 

When you release the mouse, the star shape becomes a cutout, allowing the planet to 
show through. If the Background layer were another image, pattern, or color, you would 
see it inside the star shape.

Notice that the star has a grainy outline, reminding you that the shape is selected. 
Another indication that the shape is selected is that the Retro Shape vector mask 
thumbnail is highlighted (outlined in white) in the Layers palette.

 



ADOBE PHOTOSHOP CS3 303
Classroom in a Book

6	 In the Layers palette, click the eye icon next to the Star Guide layer to hide it.

Notice how the thumbnails have changed in the palettes. In the Layers palette, the left 
thumbnail for the Retro Shape layer is unchanged, but the mask thumbnails in both the 
Layers palette and Paths palette show the retro shape with the star-shaped cutout.

7	 Deselect the star and retro shape paths by selecting the Path Selection tool ( ) and 
clicking the Dismiss Target Path button ( ) in the tool options bar.

Your paths are now deselected, and the grainy path lines have disappeared, leaving a 
sharp edge between the blue and white areas. Also, the Retro Shape Vector Mask is no 
longer highlighted in the Paths palette.

8	 Choose File > Save to save your work.

Working with defined custom shapes
Another way to use shapes in your artwork is to draw a custom or preset shape. Doing 
so is as easy as selecting the Custom Shape tool, picking a shape from the Custom Shape 
picker, and drawing in your image window. You will do so now to add checkerboard 
patterns to the background of your poster for the toy store. 
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1	 Make sure the Retro Shape layer is selected in the Layers palette. Then click the New 
Layer button ( ) to add a layer above it. Double-click the default Layer 1 name and 
rename it Pattern, and then press Enter or Return.

2	 In the toolbox, select the Custom Shape tool ( ), which is hidden under the Polygon 
tool ( ).

3	 In the tool options bar, click the pop-up arrow for the Shape option to open the 
Custom Shape picker. 

4	 Locate the checkerboard preset at the bottom of the Custom Shape picker (you may 
need to scroll or drag the corner of the picker to see it), and double-click to select it and 
simultaneously close the picker. 
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5	 In the tool options bar, select the Fill Pixels option.

6	 Make sure that the foreground color is white (or select white now). Then press Shift 
and drag diagonally in the image window to draw and size the shape so that it’s about 
2-inches square. (Pressing Shift constrains the shape to its original proportions.)

7	 Add five more checkerboards of various sizes until your poster resembles the 
following figure. 
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8	 In the Layers palette, reduce the opacity of the Pattern layer to 20%.

Your poster background is now complete.

9	 Click the Show/Hide Visibility column next to the Saucer layer to redisplay the layer 
and see the whole composition.

10	 Choose File > Save to save your work.

Importing a Smart Object
Photoshop offers support for Smart Objects, which lets you import vector objects from 
Adobe Illustrator and edit them in Photoshop without a loss of quality. Regardless of 
how often you scale, rotate, skew, or otherwise transform a Smart Object, it retains its 
sharp, precise edges. In addition, you can edit the original object in Illustrator, and 
the changes will be reflected in the placed Smart Object in your Photoshop image file. 
You learned a bit about Smart Objects in Lesson 8. You will explore them more now by 
placing text created in Illustrator into the toy store poster.

Adding the title
We created the toy store name for you in Illustrator. Let’s add it to the poster. 

1	 Select the Saucer layer and choose File > Place. Navigate to the Lessons/Lesson9 folder, 
select the Title.ai file, and click Place. Click OK in the Place PDF dialog box that appears. 
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The Retro Toys text is added to the middle of your composition, inside a bounding box 
with adjustable handles. A new layer, Title, appears in the Layers palette. 

2	 Drag the Retro Toys object to the upper right corner of the poster, and then press 
Shift and drag a corner to make the text object proportionally larger—so that it fills the 
top portion of the poster, as in the following figure. When you’ve finished, either press 
Enter or Return, or click the Commit Transform button ( ) in the tool options bar.

When you commit to the transform, the layer thumbnail icon changes to reflect that the 
title layer is a Smart Object.

Because the Retro Toys title is a Smart Object, you can continue to edit its size and 
shape, if you’d like. Simply select its layer and choose Edit > Free Transform to access the 
control handles, and drag to adjust them. Or, select the Move tool ( ), and check Show 
Transform Controls in the tool options bar. Then adjust the handles.

Finishing up
As a final step, let’s clean up the Layers palette by deleting your guide template layers.

1	 Make sure that the Title, Saucer, Pattern, Retro Shape, and Background layers are the 
only visible layers in the Layers palette.
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2	 Choose Delete Hidden Layers from the Layers palette pop-up menu, and then click 
Yes to confirm the delete action.

3	 Choose File > Save to save your work.

Congratulations! You’ve finished the poster. It should look like the following image. 
(The title text will only be stroked if you complete the Extra Credit task.)
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EXTRA CREDIT If you have Adobe Illustrator CS or later, you can go even further 

with the Retro Toys text Smart Object—you can edit it in Illustrator, and it will update 
automatically in Photoshop. Try this:

1	 Double-click the Smart Object thumbnail in the title layer. If an alert dialog box 
appears, click OK. Illustrator opens and displays the Retro Toys Smart Object in a 
document window.

2	 Using the Direct Selection tool ( ), drag a marquee around the type to select all  
of the letters. 

3	 Select the Stroke button ( ) in the Tools panel.

4	 Move the mouse over the Color panel (choose Window > Color if the panel 
isn’t already open on-screen), until the pointer changes to an eyedropper. Use the 
eyedropper to choose black in the Color panel, and then, in the Stroke panel, specify  
a 0.5-point width. 

A 0.5-point black stroke appears around the Retro Toys type.

In Adobe Illustrator CS3, you can select the Stroke attribute and its color, width, 
and other options in the Control panel above the document window.

5	 Close the Vector Smart Object document, and click Save when prompted.

6	 Switch back to Photoshop. The Retro Toys poster image window updates to reflect 
the stroked type. 



Review
Review questions
1	 How can the Pen tool be useful as a selection tool?

2	 What is the difference between a bitmap image and a vector graphic?

3	 What does a shape layer do?

4	 What tools can you use to move and resize paths and shapes?

5	 What are Smart Objects, and what is the benefit of using them?

Review answers
1	 If you need to create an intricate selection, it can be easier to draw the path 
with the Pen tool and then convert the path to a selection.

2	 Bitmap or raster images are based on a grid of pixels and are appropriate for 
continuous-tone images such as photographs or artwork created in painting 
programs. Vector graphics are made up of shapes based on mathematical 
expressions and are appropriate for illustrations, type, and drawings that require 
clear, smooth lines.

3	 A shape layer stores the outline of a shape in the Paths palette. You can change 
the outline of a shape by editing its path.

4	 You use the Path Selection tool ( ) and the Direct Selection tool ( ) to 
move, resize, and edit shapes. You can also modify and scale a shape or path by 
choosing Edit > Free Transform Path.

5	 Smart Objects are vector objects that you can import from Adobe Illustrator 
and place and edit in Photoshop without a loss of quality. Regardless of how 
often you scale, rotate, skew, or otherwise transform a Smart Object, it retains 
sharp, precise edges. A great benefit of using Smart Objects is that you can edit 
the original object in Illustrator, and the changes will be reflected in the placed 
Smart Object in your Photoshop image file.




