Welcome to the MIT Kerberos Distribution Page!

EXPORT LAW WARNINGS:

Contents

About the Distributions

Each distribution that is distributed as a tar file contains one or more files and their detached PGP signature files.

Kerberos V5 Release 1.12.2 - current release (2014-08-11)

For more information, please see the krb5-1.12.2 release page

Kerberos V5 Release 1.11.5 - maintenance release (2014-01-21)

For more information, please see the krb5-1.11.5 release page

Kerberos V5 Release 1.10.7 - maintenance release (2013-11-06)

For more information, please see the krb5-1.10 release page

MIT Kerberos for Windows 4.0.1

For more information, please see the release page .

MIT Kerberos for Windows 3.2.2

For more information, please see the release page .

MIT Kerberos for Windows 2.6.5

MIT Kerberos for Windows (KfW) includes Kerberos v4, Kerberos v5, Leash32, KClient, and an in-memory credentials cache. It runs on Windows 98/98SE/ME/NT4/2000/XP/2003. (Windows 95 is not supported).

MIT KfW includes redistributable binaries, an SDK, documentation, source code, and an interactive installer.

For a complete list of changes, see the release notes.

Downloads for MIT Kerberos for Windows 2.6.5

Please refer to the release notes for more detailed explanations of each of these packages (and whether you need them) as well as installation instructions.

MIT Kerberos for Macintosh 4.0.3

Mac OS X 10.2 and later bundles MIT Kerberos for Macintosh. To get the latest version of MIT Kerberos for Macintosh, please upgrade to the latest version of Mac OS X available from Apple. To download the Kerberos Extras for Mac OS X 10.2 and later to enable Kerberos support for CFM applications, please read this page.

Kerberos for Macintosh 4.0.3 is the current release for Mac OS X 10.1.x.

Kerberos for Macintosh 4.0.3 is the current release for Mac OS 8/9.

There is currently only one package available which includes both installers, loose binaries and SDKs. The SDKs are for application and library programmers to add Kerberos functionality to their code or update to newer versions of the various Kerberos APIs. Source code for components of this release may be made available at a later time.

Further links to information are provided in the distribution archive.

Note for MIT users
If you are an end user at MIT and are on this page to acquire the Kerberos for Macintosh binaries, you should go to the Information Systems' Kerberos for Macintosh help page for the software. No support will be provided to you from MIT Information Systems or the developers if you use the distribution from this page. MIT users should stay with the current release supported by IS.

Requirements

Binaries and SDKs

MIT Kerberos for Macintosh 2.5.1

Note: This release continues to be provided as it is the last release to support 68K Macintoshes. We strongly recommend PowerPC users upgrade to the latest Kerberos for Macintosh supported by their computers.

This release continues the new packaging model of Kerberos V4 and V5 on the Macintosh. While integration of Kerberos V4 and Kerberos V5 is at best only partial at this time, we are putting the separate sides together under one umbrella to better prepare for the upcoming unified release.

Kerberos for Macintosh 2.5.1 includes: KClient 1.9 for Kerberos V4 functionality, and the various pieces that make up Kerberos V5 1.1 for Macintosh.

There are currently three levels of packages: binaries only, SDKs, and source. The binary distribution is for sites who need to localize and redistribute to their end users. The SDKs are for application and library programmers to add Kerberos functionality to their code but don't want to rebuild everything from scratch. The source is for people who need to debug Kerberos or want to build the libraries from scratch.

Note for MIT users
If you are an end user at MIT and are on this page to acquire the Kerberos for Macintosh binaries, you should go to the Information Systems' Kerberos for Macintosh help page for the software. No support will be provided to you from MIT Information Systems or the developers if you use the distribution from this page.

Requirements

All archives require Stuffit Expander 5.0 or later to expand them.

Client binaries only

SDKs Source (the following components are not currently available: KClient) MIT Support Library
In order to compile MIT Kerberos for Macintosh, you will need to obtain the SDK for MIT Support Library. Information about MIT Support Library along with links to the SDK and source are available from MacDev's MIT Support Library home page.

Have a nice day!


$Id: index.html,v 1.278 2014/09/26 22:18:18 tlyu Exp $
MIT Kerberos [ home ] [ contact ]